aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer/files
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-01 14:04:20 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-01 14:04:20 +0000
commitce216f3e59f420584434222cf1c86cc826bccbb9 (patch)
tree1dfb775ea779cba0648260ed0d49de560d4b6254 /multimedia/mplayer/files
parentce630cf94302dfd9a001c4d00ce0b2a47739da19 (diff)
Notes
Diffstat (limited to 'multimedia/mplayer/files')
-rw-r--r--multimedia/mplayer/files/get-feat18
-rw-r--r--multimedia/mplayer/files/patch-Gui::mplayer::gtk::fs.h11
-rw-r--r--multimedia/mplayer/files/patch-Gui::mplayer::psignal.h11
-rw-r--r--multimedia/mplayer/files/patch-ab13
-rw-r--r--multimedia/mplayer/files/patch-ac19
-rw-r--r--multimedia/mplayer/files/patch-ad200
-rw-r--r--multimedia/mplayer/files/patch-ae25
7 files changed, 146 insertions, 151 deletions
diff --git a/multimedia/mplayer/files/get-feat b/multimedia/mplayer/files/get-feat
new file mode 100644
index 000000000000..07deea5e6107
--- /dev/null
+++ b/multimedia/mplayer/files/get-feat
@@ -0,0 +1,18 @@
+#This perl script will determine the supported CPU features
+#of this machine, so the build of the correct decode plugins
+#will do automatically
+
+@list=`cat /var/run/dmesg.boot|grep Feat`;
+@features=("MMX","SSE","3DNow!","DSP");
+open (INC,">$ENV{TEMPDIR}/Makefile.inc");
+foreach $feature(@features)
+{
+ foreach $line(@list)
+ {
+ if ( $line =~ m/$feature/)
+ {
+ print INC "WITH_$feature = yes\n";
+ }
+ }
+}
+close (INC);
diff --git a/multimedia/mplayer/files/patch-Gui::mplayer::gtk::fs.h b/multimedia/mplayer/files/patch-Gui::mplayer::gtk::fs.h
new file mode 100644
index 000000000000..bbe349a91da3
--- /dev/null
+++ b/multimedia/mplayer/files/patch-Gui::mplayer::gtk::fs.h
@@ -0,0 +1,11 @@
+--- Gui/mplayer/gtk/fs.h.orig Fri Sep 28 19:48:50 2001
++++ Gui/mplayer/gtk/fs.h Fri Sep 28 19:49:11 2001
+@@ -9,7 +9,7 @@
+ #include <glob.h>
+ #include <unistd.h>
+
+-#ifdef __SVR4
++#if defined(__SVR4) || defined (__FreeBSD__)
+ #define get_current_dir_name() getcwd(NULL, PATH_MAX)
+ #endif
+
diff --git a/multimedia/mplayer/files/patch-Gui::mplayer::psignal.h b/multimedia/mplayer/files/patch-Gui::mplayer::psignal.h
new file mode 100644
index 000000000000..a5c3768cdc7e
--- /dev/null
+++ b/multimedia/mplayer/files/patch-Gui::mplayer::psignal.h
@@ -0,0 +1,11 @@
+--- Gui/mplayer/psignal.h.orig Fri Sep 28 19:46:22 2001
++++ Gui/mplayer/psignal.h Fri Sep 28 19:46:55 2001
+@@ -39,7 +39,7 @@
+ #define mplIncAudioBufferDelay 28
+ #define mplDecAudioBufferDelay 29
+
+-#ifdef __SVR4
++#if defined(__SVR4) || defined(__FreeBSD__)
+ #define SIGTYPE SIGUSR2
+ #warning should we use SIGUSR1 or SIGUSR2 on linux, bsd, ... too?
+ #else
diff --git a/multimedia/mplayer/files/patch-ab b/multimedia/mplayer/files/patch-ab
deleted file mode 100644
index dd5250a5197a..000000000000
--- a/multimedia/mplayer/files/patch-ab
+++ /dev/null
@@ -1,13 +0,0 @@
-*** /home/volodya/usr/ports/graphics/mplayer/work/MPlayer-0.18pre5/DOCS/FREEBSD Thu Jun 21 03:06:40 2001
---- DOCS/FREEBSD Thu Aug 16 03:54:08 2001
-***************
-*** 6,11 ****
---- 6,13 ----
-
- 2. To run mplayer you will need to re-compile the kernel with
- "options USER_LDT" (unless you are running -CURRENT, where this is default).
-+ If you have a CPU with SSE also use "options CPU_ENABLE_SSE" to use it
-+ (FreeBSD-STABLE required, or use kernel patches).
-
- 3. If mplayer complains about "CD-ROM Device '/dev/cdrom' not found!" make a
- symbolic link : ln -s /dev/<your_cdrom_device> /dev/cdrom
diff --git a/multimedia/mplayer/files/patch-ac b/multimedia/mplayer/files/patch-ac
deleted file mode 100644
index 88ba8cb70b7e..000000000000
--- a/multimedia/mplayer/files/patch-ac
+++ /dev/null
@@ -1,19 +0,0 @@
-*** ../MPlayer-0.18pre5.old/loader/config.h Sat Feb 24 22:30:26 2001
---- loader/config.h Fri Aug 17 10:14:46 2001
-***************
-*** 56,62 ****
- #define HAVE_LIMITS_H 1
-
- /* Define if you have the <malloc.h> header file. */
-! #define HAVE_MALLOC_H 1
-
- /* Define if you have the <sys/ioctl.h> header file. */
- #define HAVE_SYS_IOCTL_H 1
---- 56,62 ----
- #define HAVE_LIMITS_H 1
-
- /* Define if you have the <malloc.h> header file. */
-! /* #undef HAVE_MALLOC_H */
-
- /* Define if you have the <sys/ioctl.h> header file. */
- #define HAVE_SYS_IOCTL_H 1
diff --git a/multimedia/mplayer/files/patch-ad b/multimedia/mplayer/files/patch-ad
index 941cb9a01492..82abd70949a2 100644
--- a/multimedia/mplayer/files/patch-ad
+++ b/multimedia/mplayer/files/patch-ad
@@ -1,104 +1,96 @@
-*** configure.orig Fri Jul 6 23:00:22 2001
---- configure Sat Aug 18 22:25:58 2001
-***************
-*** 181,187 ****
-
- system_name=`uname -s 2>&1`
- if [ "$system_name" = "FreeBSD" ]; then
-! _archlibs="-rdynamic -pthread"
- else
- _archlibs="-ldl -lpthread"
- fi
---- 181,187 ----
-
- system_name=`uname -s 2>&1`
- if [ "$system_name" = "FreeBSD" ]; then
-! _archlibs="-rdynamic ${PTHREAD_LIBS}"
- else
- _archlibs="-ldl -lpthread"
- fi
-***************
-*** 587,593 ****
- $_cc $_extraincdir $_extralibdir $TMPC -o $TMPO -lvgagl -lvga > /dev/null 2>&1 && _svga=yes
-
- if [ "$system_name" = "FreeBSD" ]; then
-! $_cc $TMPC -o $TMPO -pthread > /dev/null 2>&1 || \
- { echo "Lib pthread not found."; rm -f $TMPC $TMPO $TMPS ; exit 1; }
- else
- $_cc $TMPC -o $TMPO -lpthread > /dev/null 2>&1 || \
---- 587,593 ----
- $_cc $_extraincdir $_extralibdir $TMPC -o $TMPO -lvgagl -lvga > /dev/null 2>&1 && _svga=yes
-
- if [ "$system_name" = "FreeBSD" ]; then
-! $_cc $TMPC -o $TMPO ${PTHREAD_LIBS} > /dev/null 2>&1 || \
- { echo "Lib pthread not found."; rm -f $TMPC $TMPO $TMPS ; exit 1; }
- else
- $_cc $TMPC -o $TMPO -lpthread > /dev/null 2>&1 || \
-***************
-*** 669,675 ****
- $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lXxf86vm $_socklib > /dev/null 2>&1 && _vm=yes
-
- if [ "$system_name" = "FreeBSD" ]; then
-! $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL -pthread $_socklib > /dev/null 2>&1 && _gl=yes
- else
- $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL $_socklib > /dev/null 2>&1 && _gl=yes
- fi
---- 669,675 ----
- $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lXxf86vm $_socklib > /dev/null 2>&1 && _vm=yes
-
- if [ "$system_name" = "FreeBSD" ]; then
-! $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL ${PTHREAD_LIBS} $_socklib > /dev/null 2>&1 && _gl=yes
- else
- $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL $_socklib > /dev/null 2>&1 && _gl=yes
- fi
-***************
-*** 679,685 ****
- int main( void ) { return 0; }
- EOF
- if [ "$system_name" = "FreeBSD" ]; then
-! $_cc $_x11incdir $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL -pthread $_socklib > /dev/null 2>&1 || \
- { _gl=no; echo "GL includes not found!";}
- else
- $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL $_socklib > /dev/null 2>&1 || \
---- 679,685 ----
- int main( void ) { return 0; }
- EOF
- if [ "$system_name" = "FreeBSD" ]; then
-! $_cc $_x11incdir $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL ${PTHREAD_LIBS} $_socklib > /dev/null 2>&1 || \
- { _gl=no; echo "GL includes not found!";}
- else
- $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL $_socklib > /dev/null 2>&1 || \
-***************
-*** 1162,1168 ****
- if [ "$system_name" = "FreeBSD" ]; then
- # Under XFree86 4.x GL port is poorly designed
- if [ -r /usr/X11R6/bin/XFree86 ]; then
-! _gllib='-lGL -pthread'
- else
- _gllib='-lGL'
- fi
---- 1162,1168 ----
- if [ "$system_name" = "FreeBSD" ]; then
- # Under XFree86 4.x GL port is poorly designed
- if [ -r /usr/X11R6/bin/XFree86 ]; then
-! _gllib="-lGL ${PTHREAD_LIBS}"
- else
- _gllib='-lGL'
- fi
-***************
-*** 1329,1335 ****
- # Under FreeBSD (maybe other systems as well?) we have to add to CFLAGS
- # for MT applications:
- if [ "$system_name" = "FreeBSD" ]; then
-! CFLAGS="$CFLAGS -D_THREAD_SAFE"
- fi
-
- # echo 'CFLAGS=$(OPTFLAGS) -Wall -DMPG12PLAY' >> config.mak
---- 1329,1335 ----
- # Under FreeBSD (maybe other systems as well?) we have to add to CFLAGS
- # for MT applications:
- if [ "$system_name" = "FreeBSD" ]; then
-! CFLAGS="$CFLAGS ${PTHREAD_CFLAGS}"
- fi
-
- # echo 'CFLAGS=$(OPTFLAGS) -Wall -DMPG12PLAY' >> config.mak
+--- configure.orig Fri Sep 28 19:21:08 2001
++++ configure Fri Sep 28 19:33:35 2001
+@@ -299,7 +299,7 @@
+ _confcygwin="TARGET_CYGWIN=no"
+ _confwin32=
+ if [ "$system_name" = "FreeBSD" -o "$system_name" = "OpenBSD" ]; then
+- _archlibs="-rdynamic -pthread"
++ _archlibs="-rdynamic ${PTHREAD_LIBS}"
+ elif [ `echo $system_name | sed 's/[cC][yY][gG][wW][iI][nN].*/CYGWIN/'` = "CYGWIN" ]; then
+ _confcygwin="TARGET_CYGWIN=yes"
+ _confwin32="#define WIN32"
+@@ -766,7 +766,7 @@
+ $_cc $_extraincdir $_extralibdir $TMPC -o $TMPO -lvgagl -lvga > /dev/null 2>&1 && _svga=yes
+
+ if [ "$system_name" = "FreeBSD" -o "$system_name" = "OpenBSD" ]; then
+-$_cc $TMPC -o $TMPO -pthread > /dev/null 2>&1 || \
++$_cc $TMPC -o $TMPO ${PTHREAD_LIBS} > /dev/null 2>&1 || \
+ { echo "Lib pthread not found."; rm -f $TMPC $TMPO $TMPS ; exit 1; }
+ else
+ $_cc $TMPC -o $TMPO -lpthread > /dev/null 2>&1 || \
+@@ -861,7 +861,7 @@
+
+ # this is not yet checked with OpenBSD - atmos
+ if [ "$system_name" = "FreeBSD" -o "$system_name" = "OpenBSD" ]; then
+-$_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL -pthread $_socklib > /dev/null 2>&1 && _gl=yes
++$_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL ${PTHREAD_LIBS} $_socklib > /dev/null 2>&1 && _gl=yes
+ else
+ $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL $_socklib > /dev/null 2>&1 && _gl=yes
+ fi
+@@ -872,7 +872,7 @@
+ EOF
+ # this is not yet checked with OpenBSD - atmos
+ if [ "$system_name" = "FreeBSD" -o "$system_name" = "OpenBSD" ]; then
+-$_cc $_x11incdir $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL -pthread $_socklib > /dev/null 2>&1 || \
++$_cc $_x11incdir $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL ${PTHREAD_LIBS} $_socklib > /dev/null 2>&1 || \
+ { _gl=no; echo "GL includes not found!";}
+ else
+ $_cc $TMPC -o $TMPO $_x11libdir -lX11 -lXext -lGL $_socklib > /dev/null 2>&1 || \
+@@ -1613,33 +1613,33 @@
+
+ echo
+ echo $_echo_n "Checking for gtk version ... $_echo_c"
+-_gtk=`gtk-config --version 2>&1`
++_gtk=`${GTK_CONFIG} --version 2>&1`
+ [ -z "$_gtk" ] && { echo 'gtk not found.'; exit 1; }
+ echo "$_gtk"
+
+ echo $_echo_n "Checking for gtk includes ... $_echo_c"
+-_gtkinc=`gtk-config --cflags 2>&1`
++_gtkinc=`${GTK_CONFIG} --cflags 2>&1`
+ [ -z "$_gtkinc" ] && { echo 'gtk not found.'; exit 1; }
+ echo "done"
+
+ echo $_echo_n "Checking for gtk libs ... $_echo_c"
+-_gtklib=`gtk-config --libs 2>&1`
++_gtklib=`${GTK_CONFIG} --libs 2>&1`
+ [ -z "$_gtklib" ] && { echo 'gtk not found.'; exit 1; }
+ echo "done"
+
+ echo
+ echo $_echo_n "Checking for glib version ... $_echo_c"
+-_glib=`glib-config --version 2>&1`
++_glib=`${GLIB_CONFIG} --version 2>&1`
+ [ -z "$_glib" ] && { echo 'glib not found.'; exit 1; }
+ echo "$_glib"
+
+ echo $_echo_n "Checking for glib includes ... $_echo_c"
+-_glibinc=`glib-config --cflags 2>&1`
++_glibinc=`${GLIB_CONFIG} --cflags 2>&1`
+ [ -z "$_glibinc" ] && { echo 'glib not found.'; exit 1; }
+ echo "done"
+
+ echo $_echo_n "Checking for glib libs ... $_echo_c"
+-_gliblib=`glib-config --libs 2>&1`
++_gliblib=`${GLIB_CONFIG} --libs 2>&1`
+ [ -z "$_gliblib" ] && { echo 'glib not found.'; exit 1; }
+ echo "done"
+
+@@ -1668,7 +1668,7 @@
+ if [ "$system_name" = "FreeBSD" -o "$system_name" = "OpenBSD" ]; then
+ # Under XFree86 4.x GL port is poorly designed
+ if [ -r /usr/X11R6/bin/XFree86 ]; then
+- _gllib='-lGL -pthread'
++ _gllib='-lGL ${PTHREAD_LIBS}'
+ else
+ _gllib='-lGL'
+ fi
+@@ -1895,7 +1895,7 @@
+ # Under FreeBSD (maybe other systems as well?) we have to add to CFLAGS
+ # for MT applications:
+ if [ "$system_name" = "FreeBSD" ]; then
+-CFLAGS="$CFLAGS -D_THREAD_SAFE"
++CFLAGS="$CFLAGS ${PTHREAD_CFLAGS}"
+ fi
+
+ # 64 bit file offsets?
diff --git a/multimedia/mplayer/files/patch-ae b/multimedia/mplayer/files/patch-ae
index 38fcf5b69e44..80b04bc7ede0 100644
--- a/multimedia/mplayer/files/patch-ae
+++ b/multimedia/mplayer/files/patch-ae
@@ -1,25 +1,20 @@
---- Makefile Sun Jul 8 02:21:20 2001
-+++ Makefile.freebsd Wed Aug 15 19:23:54 2001
-@@ -85,14 +85,14 @@
- $(PRG_CFG): version.h codec-cfg.c codec-cfg.h
+--- Makefile.orig Fri Sep 28 19:37:12 2001
++++ Makefile Fri Sep 28 19:41:53 2001
+@@ -113,15 +113,8 @@
$(CC) $(CFLAGS) -g codec-cfg.c -o $(PRG_CFG) -DCODECS2HTML
--install: $(PRG) $(PRG_FIBMAP)
-- install -D -m 755 -s $(PRG) $(BINDIR)/$(PRG)
-- install -D -m 644 DOCS/mplayer.1 $(prefix)/man/man1/mplayer.1
+ install: $(PRG) $(PRG_FIBMAP)
+- install -d $(BINDIR)
+- install -m 755 -s $(PRG) $(BINDIR)/$(PRG)
+- install -d $(prefix)/man/man1
+- install -m 644 DOCS/mplayer.1 $(prefix)/man/man1/mplayer.1
- @echo "Following task requires root privs. If it fails don't panic"
- @echo "however it means you can't use fibmap_mplayer."
- @echo "Without this (or without running mplayer as root) you won't be"
-- @echo "able to play DVDs."
-- install -D -o root -g root -m 4755 -s $(PRG_FIBMAP) $(BINDIR)/$(PRG_FIBMAP)
-+install: $(PRG)
+- @echo "able to play encrypted DVDs."
+- install -o root -g root -m 4755 -s $(PRG_FIBMAP) $(BINDIR)/$(PRG_FIBMAP)
+ install -C -m 755 -s $(PRG) $(BINDIR)/$(PRG)
+ install -C -m 644 DOCS/mplayer.1 $(prefix)/man/man1/mplayer.1
-+# @echo "Following task requires root privs. If it fails don't panic"
-+# @echo "however it means you can't use fibmap_mplayer."
-+# @echo "Without this (or without running mplayer as root) you won't be"
-+# @echo "able to play DVDs."
-+# install -D -o root -g root -m 4755 -s $(PRG_FIBMAP) $(BINDIR)/$(PRG_FIBMAP)
clean:
rm -f *.o *~ $(OBJS)