aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-08 16:02:14 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-08 16:02:14 +0000
commit015180ee46361d232a7c1ca84364bd993f1e5638 (patch)
tree4b3bcfbd15ddec7ecd12dfce93b02819e078af68 /multimedia/mplayer
parentdfc36a6de2520907ec57e448946616d004cb0202 (diff)
downloadports-015180ee46361d232a7c1ca84364bd993f1e5638.tar.gz
ports-015180ee46361d232a7c1ca84364bd993f1e5638.zip
Notes
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile13
-rw-r--r--multimedia/mplayer/distinfo3
-rw-r--r--multimedia/mplayer/files/patch-libavcodec-h264.c11
3 files changed, 26 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 79101ef5ac83..0fc4724bf008 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -84,7 +84,7 @@
PORTNAME= mplayer
PORTVERSION= 0.99.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -101,6 +101,9 @@ DISTNAME= MPlayer-1.0rc1
MAINTAINER= riggs@rrr.de
COMMENT= High performance media player/encoder supporting many formats
+PATCH_SITES= http://www.mplayerhq.hu/MPlayer/patches/
+PATCHFILES+= asmrules_fix_20061231.diff
+
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
@@ -165,6 +168,7 @@ OPTIONS+= XANIM "Enable xanim DLL support" off
OPTIONS+= XVID "Enable XVID video codec support" on
OPTIONS+= REALPLAYER "Enable real player plugin" off
OPTIONS+= LIVEMEDIA "Enable LIVE555 streaming support" off
+OPTIONS+= SMB "Enable Samba input support" off
OPTIONS+= FRIBIDI "Enable FriBiDi support" off
OPTIONS+= LIRC "Enable lirc support" off
OPTIONS+= LIBCDIO "Enable libcdio support" off
@@ -471,6 +475,13 @@ BUILD_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/live
CONFIGURE_ARGS+= --disable-live
.endif
+.if defined(WITH_SMB)
+CONFIGURE_ARGS+= --enable-smb
+LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+.else
+CONFIGURE_ARGS+= --disable-smb
+.endif
+
.if !defined(WITHOUT_XVID)
CONFIGURE_ARGS+= --enable-xvid
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index bd09730976f0..ce7f15a5afc1 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,3 +1,6 @@
MD5 (MPlayer-1.0rc1.tar.bz2) = 18c05d88e22c3b815a43ca8d7152ccdc
SHA256 (MPlayer-1.0rc1.tar.bz2) = 8dd9dd61a0fe56904f5b76ddedb99bd359abaaf486e0b83b45e3357fecc81063
SIZE (MPlayer-1.0rc1.tar.bz2) = 8414213
+MD5 (asmrules_fix_20061231.diff) = f0b71c38b1207c1d604be091876ac051
+SHA256 (asmrules_fix_20061231.diff) = 3f71e6f4e07940d4d55084d0df12404371bc4e534a3a6b0756ca73e44ddbc3c4
+SIZE (asmrules_fix_20061231.diff) = 1450
diff --git a/multimedia/mplayer/files/patch-libavcodec-h264.c b/multimedia/mplayer/files/patch-libavcodec-h264.c
new file mode 100644
index 000000000000..371bf01eaef8
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libavcodec-h264.c
@@ -0,0 +1,11 @@
+--- libavcodec/h264.c.orig Thu Dec 21 14:57:54 2006
++++ libavcodec/h264.c Thu Dec 21 15:00:14 2006
+@@ -6034,7 +6034,7 @@
+ return ctx + 4 * cat;
+ }
+
+-static const __attribute((used)) uint8_t last_coeff_flag_offset_8x8[63] = {
++const __attribute((used)) uint8_t last_coeff_flag_offset_8x8[63] = {
+ 0, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
+ 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2,
+ 3, 3, 3, 3, 3, 3, 3, 3, 4, 4, 4, 4, 4, 4, 4, 4,