aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2021-03-18 17:36:57 +0000
committerThomas Zander <riggs@FreeBSD.org>2021-03-18 17:36:57 +0000
commite8cb0e71e6c019293f0c2ecaf5bf46ad4871bf89 (patch)
treec7561b0331d1efa27c1eb84804ffe2e80f8dad39 /multimedia/mplayer
parent81bc34e8f7bed1276c247390b8d26aaf5485c60c (diff)
downloadports-e8cb0e71e6c019293f0c2ecaf5bf46ad4871bf89.tar.gz
ports-e8cb0e71e6c019293f0c2ecaf5bf46ad4871bf89.zip
Update to upstream snapshot as of 2021-03-14.
Details: - No critical updates (that I am aware of). - Add NLS OPTION.
Notes
Notes: svn path=/head/; revision=568751
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/Makefile.common2
-rw-r--r--multimedia/mplayer/Makefile.optvars3
-rw-r--r--multimedia/mplayer/distinfo6
-rw-r--r--multimedia/mplayer/files/patch-Makefile13
-rw-r--r--multimedia/mplayer/files/patch-configure47
-rw-r--r--multimedia/mplayer/files/patch-stream_stream__cddb.c11
7 files changed, 42 insertions, 42 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 1c73eaaa37ee..58fd072afa06 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -12,7 +12,7 @@ COMMENT= High performance media player supporting many formats
OPTIONS_DEFINE= AALIB AMR_NB AMR_WB ASS BLURAY CACA CDIO DV DVDNAV \
ENCA FONTCONFIG FRIBIDI GIF GNUTLS GSM GUI IPV6 JACK \
- LADSPA LIBMNG LIRC LZO NAS OPENAL OPENGL \
+ LADSPA LIBMNG LIRC LZO NAS NLS OPENAL OPENGL \
OPENJPEG OPUS PULSEAUDIO RTMP \
SDL SKINS SNDIO SMB SPEEX SVGALIB V4L VDPAU VPX \
X11 X11DGA X11VM XINERAMA XVIDEO XVMC
diff --git a/multimedia/mplayer/Makefile.common b/multimedia/mplayer/Makefile.common
index cc42c9960f42..9339185461ef 100644
--- a/multimedia/mplayer/Makefile.common
+++ b/multimedia/mplayer/Makefile.common
@@ -5,7 +5,7 @@
# $FreeBSD$
MPLAYER_PORT_VERSION= 1.4.0
-MPLAYER_SNAPSHOT_DATE= 2020-12-25
+MPLAYER_SNAPSHOT_DATE= 2021-03-14
MASTER_SITES= LOCAL/riggs/mplayer
DISTNAME= mplayer-${MPLAYER_PORT_VERSION}.${MPLAYER_SNAPSHOT_DATE:S/-//g}
WRKSRC= ${WRKDIR}/mplayer-export-${MPLAYER_SNAPSHOT_DATE}
diff --git a/multimedia/mplayer/Makefile.optvars b/multimedia/mplayer/Makefile.optvars
index 26e94a9eed79..a470e0fb30bb 100644
--- a/multimedia/mplayer/Makefile.optvars
+++ b/multimedia/mplayer/Makefile.optvars
@@ -78,6 +78,9 @@ LZO_CONFIGURE_OFF= --disable-liblzo
NAS_LIB_DEPENDS= libaudio.so:audio/nas
NAS_CONFIGURE_OFF= --disable-nas
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
OPENAL_USES= openal:soft
OPENAL_CONFIGURE_OFF= --disable-openal
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index 41737c7e7549..b91ba38d8b1a 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608909155
-SHA256 (mplayer-1.4.0.20201225.tar.xz) = 09a1b18f343f41ee16d2b326c3411169ab80aaee285e8e1c1b842dc0f184accf
-SIZE (mplayer-1.4.0.20201225.tar.xz) = 5188704
+TIMESTAMP = 1615840634
+SHA256 (mplayer-1.4.0.20210314.tar.xz) = 7709f988fadcd24c00cc27b8c2d775dbb2e75e6b8bdc682b13ae6b66cc0a5174
+SIZE (mplayer-1.4.0.20210314.tar.xz) = 5194236
diff --git a/multimedia/mplayer/files/patch-Makefile b/multimedia/mplayer/files/patch-Makefile
index 93a051337316..9977ae9615ee 100644
--- a/multimedia/mplayer/files/patch-Makefile
+++ b/multimedia/mplayer/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2015-06-03 11:58:05 UTC
+--- Makefile.orig 2021-03-04 14:43:07 UTC
+++ Makefile
-@@ -752,7 +752,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
+@@ -751,7 +751,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
codec-cfg-test$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DTESTING
codec-cfg$(EXESUF) codecs2html$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DCODECS2HTML
codec-cfg$(EXESUF) codec-cfg-test$(EXESUF) codecs2html$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h
@@ -9,18 +9,16 @@
codecs.conf.h: codec-cfg$(EXESUF) etc/codecs.conf
./$^ > $@
-@@ -855,20 +855,17 @@ $(VIDIX_OBJS): $(VIDIX_PCI_FILES)
- install: $(INSTALL_TARGETS-yes)
-
+@@ -865,19 +865,17 @@ install: $(INSTALL_TARGETS-yes)
install-dirs:
-- $(INSTALL) -d $(BINDIR) $(CONFDIR) $(LIBDIR)
+ $(INSTALL) -d $(BINDIR) $(CONFDIR) $(LIBDIR)
-install-%: %$(EXESUF) install-dirs
- $(INSTALL) -m 755 $(INSTALLSTRIP) $< $(BINDIR)
+install-mplayer: mplayer$(EXESUF) install-dirs
+ @${BSD_INSTALL_PROGRAM} mplayer$(EXESUF) $(BINDIR)
--install-gui: install-mplayer install-gui-icons
+-install-gui: install-mplayer install-gui-icons install-gui-msg
- -ln -sf mplayer$(EXESUF) $(BINDIR)/gmplayer$(EXESUF)
- $(INSTALL) -d $(DATADIR)/skins $(prefix)/share/applications
- $(INSTALL) -m 644 etc/mplayer.desktop $(prefix)/share/applications/
@@ -28,6 +26,7 @@
install-gui-icons: $(foreach size,$(GUI_ICONSIZES),install-gui-icon-$(size))
install-gui-man: $(foreach lang,$(MAN_LANGS),install-gui-man-$(lang))
+ install-gui-msg: $(foreach lang,$(filter-out $(firstword $(MSG_LANGS)),$(MSG_LANGS)),install-gui-msg-$(lang))
install-mencoder-man: $(foreach lang,$(MAN_LANGS),install-mencoder-man-$(lang))
-install-mplayer-man: $(foreach lang,$(MAN_LANGS),install-mplayer-man-$(lang))
+install-mplayer-man:
diff --git a/multimedia/mplayer/files/patch-configure b/multimedia/mplayer/files/patch-configure
index 2f3f57066296..0fee48e1d8ad 100644
--- a/multimedia/mplayer/files/patch-configure
+++ b/multimedia/mplayer/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-05-27 20:02:12 UTC
+--- configure.orig 2021-03-05 12:28:06 UTC
+++ configure
-@@ -654,7 +654,7 @@ armthumb=auto
+@@ -664,7 +664,7 @@ armthumb=auto
_iwmmxt=auto
_mtrr=auto
_altivec=auto
@@ -9,7 +9,7 @@
_ranlib=ranlib
_windres=windres
_cc=cc
-@@ -1000,7 +1000,7 @@ for ac_option do
+@@ -1016,7 +1016,7 @@ for ac_option do
ld_static=''
;;
--enable-profile)
@@ -18,7 +18,7 @@
;;
--disable-profile)
_profile=
-@@ -1466,7 +1466,6 @@ for ac_option do
+@@ -1486,7 +1486,6 @@ for ac_option do
*)
echo "Unknown parameter: $ac_option"
@@ -26,7 +26,7 @@
;;
esac
-@@ -1504,40 +1503,6 @@ rm -f "$TMPLOG"
+@@ -1524,40 +1523,6 @@ rm -f "$TMPLOG"
echo configuration: $configuration > "$TMPLOG"
echo >> "$TMPLOG"
@@ -67,16 +67,16 @@
list_subparts() {
test ! -e ffmpeg/libav${3} && return 1
pattern="s/^[^#]*${1}.*([^ ,]*, *\([^ ,)]*\).*/\1_${2}/p"
-@@ -1755,7 +1720,7 @@ if test -z "$_target" ; then
+@@ -1836,7 +1801,7 @@ if test -z "$_target" ; then
case "$1" in
- x86_64|amd64|i[3-9]86*|i86pc|x86|x86pc|k5|k6|k6_2|k6_3|k6-2|k6-3|pentium*|athlon*|i586_i686|i586-i686) host_arch=i386 ;;
+ x86_64|amd64|x64|i[3-9]86*|i86pc|x86|x86pc|k5|k6|k6_2|k6_3|k6-2|k6-3|pentium*|athlon*|i586_i686|i586-i686) host_arch=i386 ;;
ia64) host_arch=ia64 ;;
- macppc|ppc*|Power*) host_arch=ppc ;;
+ macppc|powerpc|ppc*|Power*) host_arch=ppc ;;
alpha) host_arch=alpha ;;
sun4*|sparc*) host_arch=sparc ;;
parisc*|hppa*|9000*) host_arch=hppa ;;
-@@ -1880,7 +1845,11 @@ echocheck "working compiler"
+@@ -1962,7 +1927,11 @@ echocheck "working compiler"
cflag_check "" || die "Compiler is not functioning correctly. Check your installation and custom CFLAGS $CFLAGS ."
echo "yes"
@@ -89,7 +89,16 @@
if test -z "$_target" ; then
cat > $TMPC << EOF
-@@ -3251,6 +3220,13 @@ if arm ; then
+@@ -3090,7 +3059,7 @@ if x86_32 ; then
+ _pref_as_version='2.16.92'
+ echo 'pabsd %xmm0, %xmm1' >> $TMPS
+ fi
+- $_as -c $TMPS -o $TMPEXE > /dev/null 2>&1 || as_verc_fail=yes
++ $_as $TMPS -o $TMPEXE > /dev/null 2>&1 || as_verc_fail=yes
+
+ if test "$as_verc_fail" != yes ; then
+ echores "ok"
+@@ -3357,6 +3326,13 @@ if arm ; then
fi
echores "$setend"
@@ -103,7 +112,7 @@
echocheck "softfloat ABI"
softfloat=yes
cpp_condition_check '' 'defined(__ARM_PCS_VFP) || (!defined(__ARM_PCS) && !defined(__SOFTFP__))' && softfloat=no
-@@ -4080,7 +4056,7 @@ echocheck "pthread"
+@@ -4266,7 +4242,7 @@ echocheck "pthread"
if linux ; then
THREAD_CFLAGS=-D_REENTRANT
elif freebsd || netbsd || openbsd || bsdos ; then
@@ -112,7 +121,7 @@
fi
if test "$_pthreads" = auto ; then
cat > $TMPC << EOF
-@@ -4090,7 +4066,7 @@ int main(void) { pthread_t tid; return pthread_create(
+@@ -4276,7 +4252,7 @@ int main(void) { pthread_t tid; return pthread_create(
EOF
_pthreads=no
if ! hpux ; then
@@ -121,7 +130,7 @@
# for crosscompilation, we cannot execute the program, be happy if we can link statically
cc_check $THREAD_CFLAGS $ld_tmp && (tmp_run || test "$ld_static") && ld_pthread="$ld_tmp" && _pthreads=yes && break
done
-@@ -4239,7 +4215,7 @@ int main(void) {
+@@ -4419,7 +4395,7 @@ int main(void) {
}
EOF
_iconv=no
@@ -130,7 +139,7 @@
cc_check $ld_tmp && extra_ldflags="$extra_ldflags $ld_tmp" &&
ld_iconv="$ld_tmp" && _iconv=yes && break
done
-@@ -5685,15 +5661,6 @@ EOF
+@@ -5866,15 +5842,6 @@ EOF
break
fi
done
@@ -146,7 +155,7 @@
if win32 && cc_check -DGL_WIN32 -lopengl32 ; then
_gl=yes
_gl_win32=yes
-@@ -6257,7 +6224,7 @@ elif darwin ; then
+@@ -6409,7 +6376,7 @@ elif darwin ; then
elif dragonfly ; then
default_cdrom_device="/dev/cd0"
elif freebsd ; then
@@ -155,7 +164,7 @@
elif openbsd ; then
default_cdrom_device="/dev/rcd0c"
elif sunos ; then
-@@ -6270,7 +6237,7 @@ else
+@@ -6422,7 +6389,7 @@ else
default_cdrom_device="/dev/cdrom"
fi
@@ -164,7 +173,7 @@
default_dvd_device=$default_cdrom_device
elif darwin ; then
default_dvd_device="/dev/rdiskN"
-@@ -6788,7 +6755,7 @@ echores "$_speex"
+@@ -6948,7 +6915,7 @@ echores "$_speex"
echocheck "libgsm"
if test "$_libgsm" = auto ; then
_libgsm=no
@@ -173,7 +182,7 @@
fi
if test "$_libgsm" = yes ; then
def_libgsm='#define CONFIG_LIBGSM 1'
-@@ -7264,6 +7231,16 @@ if test "$_librtmp" = yes && test "$networking" = yes;
+@@ -7424,6 +7391,16 @@ if test "$_librtmp" = yes && test "$networking" = yes;
nolibrtmp=no
def_librtmp='#define CONFIG_LIBRTMP 1'
inputmodules="librtmp $inputmodules"
@@ -190,7 +199,7 @@
else
nolibrtmp=yes
_librtmp=no
-@@ -7594,7 +7571,7 @@ echores "$_mp3lame"
+@@ -7813,7 +7790,7 @@ echores "$_mp3lame"
echocheck "mencoder"
if test "$_mencoder" = no ; then
# mpeg1video for vf_lavc, snow for vf_uspp / vf_mcdeint,
@@ -199,7 +208,7 @@
fi
echores "$_mencoder"
-@@ -8200,7 +8177,7 @@ libs_mplayer=$ld_tmp
+@@ -8419,7 +8396,7 @@ libs_mplayer=$ld_tmp
#############################################################################
diff --git a/multimedia/mplayer/files/patch-stream_stream__cddb.c b/multimedia/mplayer/files/patch-stream_stream__cddb.c
deleted file mode 100644
index bdda2f132a85..000000000000
--- a/multimedia/mplayer/files/patch-stream_stream__cddb.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- stream/stream_cddb.c.orig 2020-07-07 15:46:58 UTC
-+++ stream/stream_cddb.c
-@@ -77,7 +77,7 @@
- #include "network.h"
- #include "libavutil/common.h"
-
--#define DEFAULT_FREEDB_SERVER "freedb.freedb.org"
-+#define DEFAULT_FREEDB_SERVER "gnudb.gnudb.org"
- #define DEFAULT_CACHE_DIR "/.cddb/"
-
- typedef struct {