aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayerxp
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-25 19:13:40 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-25 19:13:40 +0000
commit574d4b69628b1bfea6fc1b7bace5b785e61d4c6b (patch)
treef8767964e843d593105ef2afde2b956800eeb33c /multimedia/mplayerxp
parent4cbf6e85b48670c48deb837ac55dc28a839047fb (diff)
downloadports-574d4b69628b1bfea6fc1b7bace5b785e61d4c6b.tar.gz
ports-574d4b69628b1bfea6fc1b7bace5b785e61d4c6b.zip
Notes
Diffstat (limited to 'multimedia/mplayerxp')
-rw-r--r--multimedia/mplayerxp/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/multimedia/mplayerxp/Makefile b/multimedia/mplayerxp/Makefile
index 8d758bf4048d..4a8daeac4d3c 100644
--- a/multimedia/mplayerxp/Makefile
+++ b/multimedia/mplayerxp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mplayer
PORTVERSION= 0.90.0.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
http://www.mplayerhq.hu/MPlayer/releases/ \
@@ -74,6 +75,10 @@ LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
WITH_XANIM= yes
.endif
+.if exists(${LOCALBASE}/lib/RealPlayer8/realplay)
+WITH_REALPLAYER= yes
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
@@ -111,6 +116,13 @@ LIB_DEPENDS+= SDL-1.1.4:${PORTSDIR}/devel/sdl12
LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
.endif
+.if defined(WITH_REALPLAYER)
+CONFIGURE_ARGS+= --enable-real \
+ --with-reallibdir=${LOCALBASE}/lib/RealPlayer8/Codecs
+RUN_DEPENDS+= realplay:${PORTSDIR}/audio/linux-realplayer
+BUILD_DEPENDS+= realplay:${PORTSDIR}/audio/linux-realplayer
+.endif
+
.if defined(WITH_XANIM)
BUILD_DEPENDS+= xanim:${PORTSDIR}/graphics/xanim
@@ -192,6 +204,10 @@ pre-everything::
.if !defined(WITHOUT_WIN32_CODECS)
@${ECHO_MSG} "You can disable support (this turns this into a X86 only port)"
@${ECHO_MSG} "for Win32 codecs by defining WITHOUT_WIN32_CODECS"
+.if !defined(WITH_REALPLAYER)
+ @${ECHO_MSG} \
+ "You can enable RealPlayer DLL support by defining WITH_REALPLAYER."
+.endif
.endif
.if defined(WITHOUT_RUNTIME_CPUDETECTION)
.if !defined(WITHOUT_SSE)
@@ -216,7 +232,7 @@ pre-everything::
pre-configure:
.if defined(WITH_LIBDVDREAD)
- @${RM} -Rf ${WRKSRC}/libmpdvdkit/
+ @${RM} -Rf ${WRKSRC}/libmpdvdkit2/
.endif
post-install: