aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplex
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-27 12:51:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-27 12:51:06 +0000
commit9bf00ee878cbedc313abfef3e615a202bb196bb3 (patch)
treeacab3789a7fd9ceefb1914af9b790f91e98334df /multimedia/mplex
parentb290f48ebeecc6b12444e3a422eb45e9a0f864cf (diff)
downloadports-9bf00ee878cbedc313abfef3e615a202bb196bb3.tar.gz
ports-9bf00ee878cbedc313abfef3e615a202bb196bb3.zip
- Add LICENSE
- Regenerate patches
Notes
Notes: svn path=/head/; revision=434931
Diffstat (limited to 'multimedia/mplex')
-rw-r--r--multimedia/mplex/Makefile3
-rw-r--r--multimedia/mplex/files/patch-Makefile11
-rw-r--r--multimedia/mplex/files/patch-inptstrm.c8
-rw-r--r--multimedia/mplex/files/patch-interact.c8
-rw-r--r--multimedia/mplex/files/patch-main.c6
-rw-r--r--multimedia/mplex/files/patch-multplex.c12
6 files changed, 26 insertions, 22 deletions
diff --git a/multimedia/mplex/Makefile b/multimedia/mplex/Makefile
index bfdb721200a1..b76f98593bf7 100644
--- a/multimedia/mplex/Makefile
+++ b/multimedia/mplex/Makefile
@@ -9,6 +9,9 @@ MASTER_SITES= LOCAL/sanpei
MAINTAINER= ports@FreeBSD.org
COMMENT= Multiplexes MPEG component streams into system layers
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
CONFLICTS= mjpegtools-*
PLIST_FILES= bin/mplex man/man1/mplex.1.gz
diff --git a/multimedia/mplex/files/patch-Makefile b/multimedia/mplex/files/patch-Makefile
index cee34107968d..b628b3407a50 100644
--- a/multimedia/mplex/files/patch-Makefile
+++ b/multimedia/mplex/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Tue Apr 11 02:46:13 1995
-+++ Makefile Mon Sep 4 18:13:42 2000
-@@ -19,10 +19,12 @@
+--- Makefile.orig 1995-04-11 07:46:13 UTC
++++ Makefile
+@@ -19,11 +19,13 @@
#CFLAGS = -g
@@ -10,8 +10,9 @@
-CC = cc
+CC ?= cc
RM = /bin/rm -f
-+
-+CFLAGS+= -DTIMER
++CFLAGS+= -DTIMER
++
OBJS = main.o bitstrm.o buffer.o inits.o inptstrm.o interact.o multplex.o systems.o timecode.o
+ SRCS = main.c bitstrm.c buffer.c inits.c inptstrm.c interact.c multplex.c systems.c timecode.c
diff --git a/multimedia/mplex/files/patch-inptstrm.c b/multimedia/mplex/files/patch-inptstrm.c
index 92e720da93e8..88f0871910d6 100644
--- a/multimedia/mplex/files/patch-inptstrm.c
+++ b/multimedia/mplex/files/patch-inptstrm.c
@@ -1,12 +1,12 @@
---- inptstrm.c.orig Wed May 31 08:04:11 1995
-+++ inptstrm.c Mon Sep 4 18:17:45 2000
+--- inptstrm.c.orig 1995-05-31 13:04:11 UTC
++++ inptstrm.c
@@ -1,4 +1,5 @@
#include "main.h"
+extern int Interactive;
/*************************************************************************
MPEG Streams Kontrolle
-@@ -310,6 +311,7 @@
+@@ -310,6 +311,7 @@ unsigned int length;
fclose (info_file);
output_info_video (video_info);
@@ -14,7 +14,7 @@
ask_continue ();
}
-@@ -565,6 +567,7 @@
+@@ -565,6 +567,7 @@ unsigned int length;
close_bit_stream_r (&audio_bs);
fclose (info_file);
output_info_audio (audio_info);
diff --git a/multimedia/mplex/files/patch-interact.c b/multimedia/mplex/files/patch-interact.c
index 41149fd1580f..07796d00b20e 100644
--- a/multimedia/mplex/files/patch-interact.c
+++ b/multimedia/mplex/files/patch-interact.c
@@ -1,6 +1,6 @@
---- interact.c.orig Wed May 31 20:18:33 1995
-+++ interact.c Fri Feb 11 10:04:07 2000
-@@ -67,7 +67,7 @@
+--- interact.c.orig 1995-05-31 11:18:33 UTC
++++ interact.c
+@@ -67,7 +67,7 @@ void ask_continue ()
char input[20];
printf ("\nContinue processing (y/n) : ");
@@ -9,7 +9,7 @@
while (input[0]!='N'&&input[0]!='n'&&input[0]!='y'&&input[0]!='Y');
if (input[0]=='N' || input[0]=='n')
-@@ -92,7 +92,7 @@
+@@ -92,7 +92,7 @@ unsigned char ask_verbose ()
char input[20];
printf ("\nVery verbose mode (y/n) : ");
diff --git a/multimedia/mplex/files/patch-main.c b/multimedia/mplex/files/patch-main.c
index 12d99a0ca25d..97983d5d3c96 100644
--- a/multimedia/mplex/files/patch-main.c
+++ b/multimedia/mplex/files/patch-main.c
@@ -1,5 +1,5 @@
---- main.c.orig Wed Apr 5 03:51:53 1995
-+++ main.c Mon Sep 4 18:17:45 2000
+--- main.c.orig 1995-04-05 08:51:53 UTC
++++ main.c
@@ -59,6 +59,7 @@
*************************************************************************/
@@ -17,7 +17,7 @@
int main (argc, argv)
int argc;
-@@ -93,6 +96,14 @@
+@@ -93,6 +96,14 @@ char* argv[];
unsigned int which_streams=0;
double startup_delay=0;
diff --git a/multimedia/mplex/files/patch-multplex.c b/multimedia/mplex/files/patch-multplex.c
index 7830a3668993..7788222ddc02 100644
--- a/multimedia/mplex/files/patch-multplex.c
+++ b/multimedia/mplex/files/patch-multplex.c
@@ -1,12 +1,12 @@
---- multplex.c.orig Tue Jun 6 07:16:52 1995
-+++ multplex.c Mon Sep 4 18:17:45 2000
+--- multplex.c.orig 1995-06-06 12:16:52 UTC
++++ multplex.c
@@ -1,4 +1,5 @@
#include "main.h"
+extern int Interactive;
#ifdef TIMER
extern long total_sec;
extern long total_usec;
-@@ -129,6 +130,7 @@
+@@ -129,6 +130,7 @@ unsigned int which_streams;
picture_start = TRUE;
}
@@ -14,7 +14,7 @@
printf("\nMerging elementary streams to MPEG/SYSTEMS multiplexed stream.\n");
printf("\n+------------------ MPEG/SYSTEMS INFORMATION -----------------+\n");
-@@ -144,6 +146,12 @@
+@@ -144,6 +146,12 @@ printf("\n+------------------ MPEG/SYSTE
scanf ("%ld", &video_buffer_size);
printf ("STD audio buffer in kB (CSPS: max 4 kB) : ");
scanf ("%ld", &audio_buffer_size);
@@ -27,7 +27,7 @@
write_pack = packets_per_pack;
video_buffer_size *= 1024;
-@@ -197,6 +205,7 @@
+@@ -197,6 +205,7 @@ printf("\n+------------------ MPEG/SYSTE
(double)(packets_per_pack-1.))) / (double)(packets_per_pack) );
data_rate = ceil(dmux_rate/50.)*50;
@@ -35,7 +35,7 @@
printf ("\ncomputed multiplexed stream data rate : %7.3f\n",dmux_rate);
printf ("target data rate (e.g. %6u) : ",data_rate);
scanf ("%lf", &dmux_rate);
-@@ -206,12 +215,21 @@
+@@ -206,12 +215,21 @@ printf("\n+------------------ MPEG/SYSTE
scanf ("%u", &video_delay_ms);
printf ("audio stream startup offset (ms) : ");
scanf ("%u", &audio_delay_ms);