aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mpv-mpris
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-12-13 22:36:11 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-12-13 22:36:11 +0000
commit2d913739f69ecfcba9bd1e8fd98ad3b33a6f150b (patch)
tree8f8a4dea7372af86ee3d92d4494b068d30d41820 /multimedia/mpv-mpris
parentbbd4c7cd3d64f21488781ae7c4b0517cbdfc5f67 (diff)
Notes
Diffstat (limited to 'multimedia/mpv-mpris')
-rw-r--r--multimedia/mpv-mpris/Makefile29
-rw-r--r--multimedia/mpv-mpris/distinfo3
-rw-r--r--multimedia/mpv-mpris/pkg-descr7
3 files changed, 39 insertions, 0 deletions
diff --git a/multimedia/mpv-mpris/Makefile b/multimedia/mpv-mpris/Makefile
new file mode 100644
index 000000000000..0b1218ac66b3
--- /dev/null
+++ b/multimedia/mpv-mpris/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= mpv-mpris
+DISTVERSION= 0.2
+CATEGORIES= multimedia
+
+MAINTAINER= tcberner@FreeBSD.org
+COMMENT= MPRIS plugin for mpv
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= mpv:multimedia/mpv
+
+USES= gettext-runtime gnome
+USE_GNOME= glib20
+USE_GITHUB= yes
+GH_ACCOUNT= hoyon
+
+ALL_TARGET= mpris.so
+
+PLIST_FILES= etc/mpv/scripts/mpris.so
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/mpv/scripts
+ ${INSTALL_LIB} ${BUILD_WRKSRC}/mpris.so \
+ ${STAGEDIR}${PREFIX}/etc/mpv/scripts
+
+.include <bsd.port.mk>
diff --git a/multimedia/mpv-mpris/distinfo b/multimedia/mpv-mpris/distinfo
new file mode 100644
index 000000000000..1cd0ae27be5e
--- /dev/null
+++ b/multimedia/mpv-mpris/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1576275542
+SHA256 (hoyon-mpv-mpris-0.2_GH0.tar.gz) = d21a9617759bc368d6e9cb229d099b12968f0e673db5cd0bf12d8a251516d81a
+SIZE (hoyon-mpv-mpris-0.2_GH0.tar.gz) = 6902
diff --git a/multimedia/mpv-mpris/pkg-descr b/multimedia/mpv-mpris/pkg-descr
new file mode 100644
index 000000000000..034f99c9a592
--- /dev/null
+++ b/multimedia/mpv-mpris/pkg-descr
@@ -0,0 +1,7 @@
+mpv-mpris is a plugin for mpv which allows control of the player using standard
+media keys.
+
+This plugin implements the MPRIS D-Bus interface and can be controlled using
+tools such as playerctl or through many Linux DEs, such as Gnome and KDE.
+
+WWW: https://github.com/hoyon/mpv-mpris