aboutsummaryrefslogtreecommitdiff
path: root/multimedia/msdl
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-24 00:50:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-24 00:50:48 +0000
commit01de41410e95056ec3b83d45a1f4c594118585a2 (patch)
tree95b48af30ef61097bca2cec27e034660c8b7020e /multimedia/msdl
parente7050498e29f1d5f72b1aa1bc74fa343c8e1a39c (diff)
downloadports-01de41410e95056ec3b83d45a1f4c594118585a2.tar.gz
ports-01de41410e95056ec3b83d45a1f4c594118585a2.zip
This program is to download multimedia streaming files.
Currently it supports following protocols. * mmst (Microsoft Media Server over TCP) * mmsh (MMS over HTTP) * http (Hyper Text Transfer Protocol) * real-rtsp (Real Time Streaming Protocol / Real/helix) * wms-rtsp (Real Time Streaming Protocol / WMServer) * ftp (File Transfer Protocol) WWW: http://msdl.sourceforge.net/ PR: 132946 Submitted by: Ashish SHUKLA <wahjava at gmail dot com>
Notes
Notes: svn path=/head/; revision=230827
Diffstat (limited to 'multimedia/msdl')
-rw-r--r--multimedia/msdl/Makefile20
-rw-r--r--multimedia/msdl/distinfo3
-rw-r--r--multimedia/msdl/files/patch-src-url.h11
-rw-r--r--multimedia/msdl/pkg-descr11
4 files changed, 45 insertions, 0 deletions
diff --git a/multimedia/msdl/Makefile b/multimedia/msdl/Makefile
new file mode 100644
index 000000000000..0ee28719caec
--- /dev/null
+++ b/multimedia/msdl/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: msdl
+# Date created: 2009-03-23
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= msdl
+PORTVERSION= 1.2.3
+CATEGORIES= multimedia
+MASTER_SITES= SF
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= Streaming multimedia files downloader
+
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/msdl
+MAN1= msdl.1
+
+.include <bsd.port.mk>
diff --git a/multimedia/msdl/distinfo b/multimedia/msdl/distinfo
new file mode 100644
index 000000000000..5ffe005f6d7a
--- /dev/null
+++ b/multimedia/msdl/distinfo
@@ -0,0 +1,3 @@
+MD5 (msdl-1.2.3.tar.gz) = e76cafc8cd5594954faa879b68771438
+SHA256 (msdl-1.2.3.tar.gz) = 63f5e252ab2143000f41fd1a973dbab8da78d97ce37ea01ff9ae64934b95ba35
+SIZE (msdl-1.2.3.tar.gz) = 195425
diff --git a/multimedia/msdl/files/patch-src-url.h b/multimedia/msdl/files/patch-src-url.h
new file mode 100644
index 000000000000..75285619e6e3
--- /dev/null
+++ b/multimedia/msdl/files/patch-src-url.h
@@ -0,0 +1,11 @@
+--- src/url.h.orig 2008-08-29 15:51:58.000000000 +0400
++++ src/url.h 2009-03-23 03:49:40.000000000 +0300
+@@ -60,7 +60,7 @@
+ struct url_t *new_url_t(const char *url);
+ void free_url_t(struct url_t *u);
+ void copy_url_t(struct url_t *url,struct url_t *srcurl);
+-inline int is_url_valid_char(int c);
++int is_url_valid_char(int c);
+ void url_unescape_string(char *dst,char *src);
+
+
diff --git a/multimedia/msdl/pkg-descr b/multimedia/msdl/pkg-descr
new file mode 100644
index 000000000000..3ac593c5f3ee
--- /dev/null
+++ b/multimedia/msdl/pkg-descr
@@ -0,0 +1,11 @@
+This program is to download multimedia streaming files.
+Currently it supports following protocols.
+
+* mmst (Microsoft Media Server over TCP)
+* mmsh (MMS over HTTP)
+* http (Hyper Text Transfer Protocol)
+* real-rtsp (Real Time Streaming Protocol / Real/helix)
+* wms-rtsp (Real Time Streaming Protocol / WMServer)
+* ftp (File Transfer Protocol)
+
+WWW: http://msdl.sourceforge.net/