aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mythtv
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-12-03 08:25:31 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-12-03 08:25:31 +0000
commit38308bbce8121d08ed2d1addc44a6d4af9b1d8da (patch)
tree19fcb52e1a08c10e10288210eaf522890abc2def /multimedia/mythtv
parent574e3bddf9eae410ebf30e17e38f77fb6ec3d85f (diff)
- Add explicit FLAVOR to a few dependencies
- Remove FLAVOR from py-docutils dependency in comms/uhd, in this case it needs the rst2html command, not the docutils module - Mark some ports as not compatible with python3
Notes
Notes: svn path=/head/; revision=455392
Diffstat (limited to 'multimedia/mythtv')
-rw-r--r--multimedia/mythtv/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index d7b0ede13c68..2b6b122a5c0a 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -91,22 +91,22 @@ SUB_FILES= pkg-message
.if ${PORT_OPTIONS:MBINDINGS}
CONFIGURE_ARGS+= --python=${PYTHON_CMD}
-USES+= python
+USES+= python:2.7
PYDISTUTILS_PKGNAME=MythTV
PYDISTUTILS_PKGVERSION=0.27._1
-BUILD_DEPENDS+= py*-lxml>=0:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb \
- ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:www/py-urlgrabber \
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:www/py-urlgrabber@${PY_FLAVOR} \
p5-HTTP-Request-Params>=0:www/p5-HTTP-Request-Params \
p5-LWP-UserAgent-Determined>=0:www/p5-LWP-UserAgent-Determined \
p5-Net-UPnP>=0:multimedia/p5-Net-UPnP \
p5-IO-Socket-INET6>=2.51:net/p5-IO-Socket-INET6 \
p5-DBI>=0:databases/p5-DBI \
p5-DBD-mysql>0:databases/p5-DBD-mysql
-RUN_DEPENDS+= py*-lxml>=0:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb \
- ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:www/py-urlgrabber \
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:www/py-urlgrabber@${PY_FLAVOR} \
p5-HTTP-Request-Params>=0:www/p5-HTTP-Request-Params \
p5-LWP-UserAgent-Determined>=0:www/p5-LWP-UserAgent-Determined \
p5-Net-UPnP>=0:multimedia/p5-Net-UPnP \