aboutsummaryrefslogtreecommitdiff
path: root/multimedia/oggvideotools
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-02 05:48:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-02 05:48:59 +0000
commit3ed3a7d64cccf2a72aebcf936fad60e6d464537a (patch)
tree28e5f2c2912f52ea35c45c72c9b2d69cdedd0b51 /multimedia/oggvideotools
parent25ba5ec1186e9a208ccb05973fd5d07de6420be7 (diff)
downloadports-3ed3a7d64cccf2a72aebcf936fad60e6d464537a.tar.gz
ports-3ed3a7d64cccf2a72aebcf936fad60e6d464537a.zip
- Update to 0.8a
PR: 176532 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=313195
Diffstat (limited to 'multimedia/oggvideotools')
-rw-r--r--multimedia/oggvideotools/Makefile36
-rw-r--r--multimedia/oggvideotools/distinfo4
-rw-r--r--multimedia/oggvideotools/pkg-descr6
-rw-r--r--multimedia/oggvideotools/pkg-plist82
4 files changed, 103 insertions, 25 deletions
diff --git a/multimedia/oggvideotools/Makefile b/multimedia/oggvideotools/Makefile
index 68aaf80e50e5..293bf4b6dff8 100644
--- a/multimedia/oggvideotools/Makefile
+++ b/multimedia/oggvideotools/Makefile
@@ -2,30 +2,30 @@
# $FreeBSD$
PORTNAME= oggvideotools
-PORTVERSION= 0.8
-PORTREVISION= 5
+PORTVERSION= 0.8a
CATEGORIES= multimedia
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= oggvideotools/oggvideotools/${DISTNAME}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A toolbox for manipulating Ogg video files
+COMMENT= Toolbox for manipulating Ogg video files
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
+LICENSE= GPLv2 # (or later)
+
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
ogg:${PORTSDIR}/audio/libogg \
- theora.0:${PORTSDIR}/multimedia/libtheora \
- vorbis.4:${PORTSDIR}/audio/libvorbis
+ theora:${PORTSDIR}/multimedia/libtheora \
+ vorbis:${PORTSDIR}/audio/libvorbis
USE_SDL= sdl
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-MAKEFILE= makefile
-
-.for app in oggSplit oggDump oggJoin oggCut oggCat oggLength oggSlideshow oggThumb oggResize oggSilence oggScroll mkThumbs mkSlideshow
-PLIST_FILES+= bin/${app}
-.endfor
-.for app in oggResize oggSlideshow oggThumb oggSplit oggJoin oggCut oggCat oggSilence
-MAN1+= ${app}.1
-.endfor
+USE_PKGCONFIG= build
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+LDFLAGS+= -L${LOCALBASE}/lib
+
+MAN1= mkThumbs.1 oggCat.1 oggCut.1 oggDump.1 oggJoin.1 \
+ oggLength.1 oggSilence.1 oggSlideshow.1 oggSplit.1 \
+ oggThumb.1 oggTranscode.1
.include <bsd.port.mk>
diff --git a/multimedia/oggvideotools/distinfo b/multimedia/oggvideotools/distinfo
index 286b158316a9..39c919d3eb3b 100644
--- a/multimedia/oggvideotools/distinfo
+++ b/multimedia/oggvideotools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (oggvideotools-0.8.tar.gz) = c33f33b400d6c01d12490a063e29347ac36fb59eac00892256552cafb0d4c93a
-SIZE (oggvideotools-0.8.tar.gz) = 476044
+SHA256 (oggvideotools-0.8a.tar.gz) = 27f96a98d8b5a2c90f042ace7b4d08c9246d4d0590a8e630800b4779024514cc
+SIZE (oggvideotools-0.8a.tar.gz) = 186093
diff --git a/multimedia/oggvideotools/pkg-descr b/multimedia/oggvideotools/pkg-descr
index 662eb5741f71..c19fe5c18fef 100644
--- a/multimedia/oggvideotools/pkg-descr
+++ b/multimedia/oggvideotools/pkg-descr
@@ -4,8 +4,4 @@ which usually consist of a video stream (Theora) and an audio stream
creating an manipulating these video files, such as for splitting the
different streams.
-At the moment there are the following tools available: oggResize,
-oggThumb, oggSlideshow, oggCut, oggCat, oggSplit, oggJoin, oggDump,
-oggLength, oggSilence and oggScroll.
-
-WWW: http://dev.streamnik.de/oggvideotools.html
+WWW: http://www.streamnik.de/oggvideotools.html
diff --git a/multimedia/oggvideotools/pkg-plist b/multimedia/oggvideotools/pkg-plist
new file mode 100644
index 000000000000..d955517b8c73
--- /dev/null
+++ b/multimedia/oggvideotools/pkg-plist
@@ -0,0 +1,82 @@
+bin/oggCat
+bin/oggCut
+bin/oggDump
+bin/oggJoin
+bin/oggLength
+bin/oggSilence
+bin/oggSlideshow
+bin/oggSplit
+bin/oggThumb
+bin/oggTranscode
+include/oggvt/audioConverter.h
+include/oggvt/audioHook.h
+include/oggvt/audioPacket.h
+include/oggvt/basePlane.h
+include/oggvt/blendElement.h
+include/oggvt/bufferRepository.h
+include/oggvt/cmdlineextractor.h
+include/oggvt/crc.h
+include/oggvt/crossfader.h
+include/oggvt/definition.h
+include/oggvt/effector.h
+include/oggvt/exception.h
+include/oggvt/fileRepository.h
+include/oggvt/granulePosInterpreter.h
+include/oggvt/helper.h
+include/oggvt/hookHandler.h
+include/oggvt/kateExtractor.h
+include/oggvt/kateHeader.h
+include/oggvt/katePosInterpreter.h
+include/oggvt/kateStreamParameter.h
+include/oggvt/kenburnseffect.h
+include/oggvt/log.h
+include/oggvt/lowpassEffect.h
+include/oggvt/mediaConverter.h
+include/oggvt/mediaDecoder.h
+include/oggvt/mediaEncoder.h
+include/oggvt/mediaInputEncoder.h
+include/oggvt/mediaOutputDecoder.h
+include/oggvt/mediaRepository.h
+include/oggvt/mediaUnit.h
+include/oggvt/oggBOSExtractorFactory.h
+include/oggvt/oggComment.h
+include/oggvt/oggDecoder.h
+include/oggvt/oggEncoder.h
+include/oggvt/oggHeader.h
+include/oggvt/oggPacket.h
+include/oggvt/oggPage.h
+include/oggvt/oggRingbuffer.h
+include/oggvt/oggStreamDecoder.h
+include/oggvt/oggStreamEncoder.h
+include/oggvt/oggTypes.h
+include/oggvt/pictureBlend.h
+include/oggvt/pictureLoader.h
+include/oggvt/pictureResize.h
+include/oggvt/plainPicture.h
+include/oggvt/rawMediaPacket.h
+include/oggvt/refObject.h
+include/oggvt/rgbPlane.h
+include/oggvt/ringbuffer.h
+include/oggvt/streamConfig.h
+include/oggvt/streamExtractor.h
+include/oggvt/streamMux.h
+include/oggvt/streamParameter.h
+include/oggvt/streamSerializer.h
+include/oggvt/th_helper.h
+include/oggvt/theoraDecoder.h
+include/oggvt/theoraEncoder.h
+include/oggvt/theoraExtractor.h
+include/oggvt/theoraHeader.h
+include/oggvt/theoraPosInterpreter.h
+include/oggvt/theoraStreamParameter.h
+include/oggvt/videoHook.h
+include/oggvt/vorbisDecoder.h
+include/oggvt/vorbisEncoder.h
+include/oggvt/vorbisExtractor.h
+include/oggvt/vorbisHeader.h
+include/oggvt/vorbisPosInterpreter.h
+include/oggvt/vorbisStreamParameter.h
+include/oggvt/wishList.h
+lib/liboggvideotools.so
+sbin/mkThumbs
+@dirrm include/oggvt