aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ogmrip
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-29 16:13:41 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-29 16:13:41 +0000
commitb999017f3a48f610108079a1fb52481168522908 (patch)
treef13a3eebe608ff9bf6ad0b616562f530f575276b /multimedia/ogmrip
parent5989eb5b6ebd643a666ef1016ce627ab5f0ebed7 (diff)
downloadports-b999017f3a48f610108079a1fb52481168522908.tar.gz
ports-b999017f3a48f610108079a1fb52481168522908.zip
Notes
Diffstat (limited to 'multimedia/ogmrip')
-rw-r--r--multimedia/ogmrip/Makefile122
-rw-r--r--multimedia/ogmrip/files/patch-data-Makefile.in6
-rw-r--r--multimedia/ogmrip/files/patch-libogmrip-ogmrip-encoding.c28
-rw-r--r--multimedia/ogmrip/pkg-plist132
4 files changed, 115 insertions, 173 deletions
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index d368881804f3..de39c7a92016 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Application and libraries for encoding DVDs into DivX/OGM files
-LICENSE= GPLv2 LGPL21
-LICENSE_COMB= multi
+LICENSE= GPLv2+ # from source, though COPYING says LGPLv2
BUILD_DEPENDS= mencoder:multimedia/mencoder \
mplayer:multimedia/mplayer \
@@ -26,106 +25,49 @@ RUN_DEPENDS= lame:audio/lame \
mplayer:multimedia/mplayer \
ogmmerge:multimedia/ogmtools
+USES= desktop-file-utils gmake libtool localbase:ldflags pathfix pkgconfig
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 intlhack libxml2
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
OPTIONS_DEFINE= GTK2 ENCHANT MATROSKA MP4BOX NLS THEORA FAAC SRT DEBUG
OPTIONS_DEFAULT=GTK2
+OPTIONS_SUB= yes
ENCHANT_DESC= Enable spell checking for text subtitles
MATROSKA_DESC= Enable Matroska container support
MP4BOX_DESC= Enable Mpeg-4 container support
THEORA_DESC= Enable Ogg Theora video codec support
SRT_DESC= Enable SRT text subtitles support
-USES= desktop-file-utils gmake libtool pathfix pkgconfig
-USE_GNOME= glib20 intlhack libxml2
-USE_LDCONFIG= yes
+GTK2_CONFIGURE_ENABLE= gtk-support dbus-support libnotify-support
+GTK2_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
+ libnotify.so:devel/libnotify
+GTK2_USE= GNOME=gconf2,libglade2
+GTK2_VARS= GCONF_SCHEMAS=ogmrip.schemas
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
+ENCHANT_CONFIGURE_ENABLE=enchant-support
+ENCHANT_LIB_DEPENDS= libenchant.so:textproc/enchant
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+MATROSKA_CONFIGURE_ENABLE=mkv-support
+MATROSKA_RUN_DEPENDS= mkvmerge:multimedia/mkvtoolnix
-.include <bsd.port.options.mk>
+MP4BOX_CONFIGURE_ENABLE=mp4-support
+MP4BOX_RUN_DEPENDS= mp4box:multimedia/gpac-mp4box
-.if ${PORT_OPTIONS:MGTK2}
-CONFIGURE_ARGS+= --enable-gtk-support --enable-dbus-support \
- --enable-libnotify-support
-LIB_DEPENDS+= libdbus-glib-1.so:devel/dbus-glib \
- libnotify.so:devel/libnotify
-USE_GNOME+= gconf2 libglade2
-GCONF_SCHEMAS= ogmrip.schemas
-PLIST_SUB+= GTK2_SUPPORT=""
-.else
-CONFIGURE_ARGS+= --disable-gtk-support --disable-dbus-support \
- --disable-libnotify-support
-PLIST_SUB+= GTK2_SUPPORT="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MENCHANT}
-CONFIGURE_ARGS+= --enable-enchant-support
-LIB_DEPENDS+= libenchant.so:textproc/enchant
-PLIST_SUB+= ENCHANT_SUPPORT=""
-.else
-CONFIGURE_ARGS+= --disable-enchant-support
-PLIST_SUB+= ENCHANT_SUPPORT="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMATROSKA}
-CONFIGURE_ARGS+= --enable-mkv-support
-RUN_DEPENDS+= mkvmerge:multimedia/mkvtoolnix
-PLIST_SUB+= MATROSKA_SUPPORT=""
-.else
-CONFIGURE_ARGS+= --disable-mkv-support
-PLIST_SUB+= MATROSKA_SUPPORT="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMP4BOX}
-CONFIGURE_ARGS+= --enable-mp4-support
-RUN_DEPENDS+= mp4box:multimedia/gpac-mp4box
-PLIST_SUB+= MP4BOX_SUPPORT=""
-.else
-CONFIGURE_ARGS+= --disable-mp4-support
-PLIST_SUB+= MP4BOX_SUPPORT="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTHEORA}
-CONFIGURE_ARGS+= --enable-theora-support
-LIB_DEPENDS+= libtheora.so:multimedia/libtheora
-PLIST_SUB+= THEORA_SUPPORT=""
-.else
-CONFIGURE_ARGS+= --disable-theora-support
-PLIST_SUB+= THEORA_SUPPORT="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MFAAC}
-CONFIGURE_ARGS+= --enable-aac-support
-RUN_DEPENDS+= faac:audio/faac
-PLIST_SUB+= FAAC_SUPPORT=""
-.else
-CONFIGURE_ARGS+= --disable-aac-support
-PLIST_SUB+= FAAC_SUPPORT="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSRT}
-CONFIGURE_ARGS+= --enable-srt-support
-RUN_DEPENDS+= gocr:graphics/gocr
-MAN1+= subp2pgm.1 subptools.1
-PLIST_SUB+= SRT_SUPPORT=""
-.else
-CONFIGURE_ARGS+= --disable-srt-support
-PLIST_SUB+= SRT_SUPPORT="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-maintainer-mode --enable-devel-mode
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+THEORA_CONFIGURE_ENABLE=theora-support
+THEORA_LIB_DEPENDS= libtheora.so:multimedia/libtheora
+
+FAAC_CONFIGURE_ENABLE= aac-support
+FAAC_RUN_DEPENDS= faac:audio/faac
+
+SRT_CONFIGURE_ENABLE= srt-support
+SRT_RUN_DEPENDS= gocr:graphics/gocr
+
+DEBUG_CONFIGURE_ON= --enable-maintainer-mode --enable-devel-mode
pre-everything::
@${ECHO_MSG} ""
diff --git a/multimedia/ogmrip/files/patch-data-Makefile.in b/multimedia/ogmrip/files/patch-data-Makefile.in
index 0122edcf444f..bb70441a405b 100644
--- a/multimedia/ogmrip/files/patch-data-Makefile.in
+++ b/multimedia/ogmrip/files/patch-data-Makefile.in
@@ -1,6 +1,6 @@
---- data/Makefile.in.orig 2014-05-30 20:04:27.000000000 +0200
-+++ data/Makefile.in 2014-06-07 09:59:01.045874372 +0200
-@@ -719,10 +719,6 @@
+--- data/Makefile.in.orig 2016-02-26 14:45:06 UTC
++++ data/Makefile.in
+@@ -719,10 +719,6 @@ uninstall-am: uninstall-desktopDATA unin
@HAVE_GTK_SUPPORT_TRUE@@INTLTOOL_DESKTOP_RULE@
@HAVE_GTK_SUPPORT_TRUE@@INTLTOOL_SCHEMAS_RULE@
diff --git a/multimedia/ogmrip/files/patch-libogmrip-ogmrip-encoding.c b/multimedia/ogmrip/files/patch-libogmrip-ogmrip-encoding.c
index 7cd7b71c2990..5113c7140aed 100644
--- a/multimedia/ogmrip/files/patch-libogmrip-ogmrip-encoding.c
+++ b/multimedia/ogmrip/files/patch-libogmrip-ogmrip-encoding.c
@@ -1,6 +1,6 @@
---- libogmrip/ogmrip-encoding.c.orig 2013-10-05 15:05:24.000000000 +0200
-+++ libogmrip/ogmrip-encoding.c 2014-06-07 08:00:31.601300584 +0200
-@@ -1197,7 +1197,7 @@
+--- libogmrip/ogmrip-encoding.c.orig 2015-01-10 13:39:43 UTC
++++ libogmrip/ogmrip-encoding.c
+@@ -1197,7 +1197,7 @@ ogmrip_encoding_spawn_suspended (OGMRipE
encoding->priv->task.options,
OGMRIP_TASK_SUSPEND,
encoding->priv->task.type,
@@ -9,7 +9,7 @@
}
static void
-@@ -1208,7 +1208,7 @@
+@@ -1208,7 +1208,7 @@ ogmrip_encoding_spawn_resumed (OGMRipEnc
encoding->priv->task.options,
OGMRIP_TASK_RESUME,
encoding->priv->task.type,
@@ -18,7 +18,7 @@
}
static void
-@@ -1706,10 +1706,10 @@
+@@ -1706,10 +1706,10 @@ ogmrip_encoding_analyze_video_stream (OG
return OGMJOB_RESULT_ERROR;
ogmrip_encoding_emit_task (encoding, spawn,
@@ -31,7 +31,7 @@
if (result == OGMJOB_RESULT_SUCCESS)
{
-@@ -1777,9 +1777,9 @@
+@@ -1777,9 +1777,9 @@ ogmrip_encoding_extract_chapters (OGMRip
if (!spawn)
return OGMJOB_RESULT_ERROR;
@@ -43,7 +43,7 @@
if (result != OGMJOB_RESULT_SUCCESS)
{
-@@ -1871,10 +1871,10 @@
+@@ -1871,10 +1871,10 @@ ogmrip_encoding_encode_subp_streams (OGM
ogmrip_codec_set_options (OGMRIP_CODEC (spawn), encoding->priv->profile_section);
ogmrip_encoding_emit_task (encoding, spawn, (OGMRipOptions *) &data->options,
@@ -56,7 +56,7 @@
if (result != OGMJOB_RESULT_SUCCESS)
{
-@@ -1987,10 +1987,10 @@
+@@ -1987,10 +1987,10 @@ ogmrip_encoding_encode_audio_streams (OG
ogmrip_codec_set_options (OGMRIP_CODEC (spawn), encoding->priv->profile_section);
ogmrip_encoding_emit_task (encoding, spawn, (OGMRipOptions *) &data->options,
@@ -69,7 +69,7 @@
if (result != OGMJOB_RESULT_SUCCESS)
{
-@@ -2058,10 +2058,10 @@
+@@ -2058,10 +2058,10 @@ ogmrip_encoding_crop (OGMRipEncoding *en
{
case OGMRIP_OPTIONS_AUTOMATIC:
ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (codec),
@@ -82,7 +82,7 @@
if (result != OGMJOB_RESULT_SUCCESS)
return OGMJOB_RESULT_CANCEL;
-@@ -2226,9 +2226,9 @@
+@@ -2226,9 +2226,9 @@ ogmrip_encoding_encode_video_stream (OGM
if (encoding->priv->profile_section && encoding->priv->preset == OGMRIP_VIDEO_PRESET_USER)
ogmrip_codec_set_options (OGMRIP_CODEC (codec), encoding->priv->profile_section);
@@ -94,7 +94,7 @@
if (result == OGMJOB_RESULT_ERROR && error && !(*error))
g_set_error (error, OGMRIP_ENCODING_ERROR, OGMRIP_ENCODING_ERROR_UNKNOWN,
-@@ -2258,9 +2258,9 @@
+@@ -2258,9 +2258,9 @@ ogmrip_encoding_merge (OGMRipEncoding *e
ogmjob_log_printf ("\nMerging\n");
ogmjob_log_printf ("-------\n\n");
@@ -106,7 +106,7 @@
if (cwd)
{
-@@ -2376,7 +2376,7 @@
+@@ -2376,7 +2376,7 @@ ogmrip_encoding_test_internal (OGMRipEnc
relative = ogmrip_encoding_get_relative (encoding);
ogmrip_encoding_set_relative_internal (encoding, TRUE);
@@ -115,7 +115,7 @@
ogmrip_encoding_set_play_length (encoding, SAMPLE_LENGTH * SAMPLE_PERCENT);
-@@ -2430,7 +2430,7 @@
+@@ -2430,7 +2430,7 @@ ogmrip_encoding_test_internal (OGMRipEnc
}
}
@@ -124,7 +124,7 @@
if (result == OGMJOB_RESULT_SUCCESS && files > 0)
{
-@@ -5972,9 +5972,9 @@
+@@ -5972,9 +5972,9 @@ ogmrip_encoding_backup (OGMRipEncoding *
OGMRIP_ENCODING_SET_FLAGS (encoding, OGMRIP_ENCODING_BACKUPING);
diff --git a/multimedia/ogmrip/pkg-plist b/multimedia/ogmrip/pkg-plist
index b296edcecaa1..d442ba3ade0e 100644
--- a/multimedia/ogmrip/pkg-plist
+++ b/multimedia/ogmrip/pkg-plist
@@ -1,30 +1,30 @@
bin/avibox
bin/dvdcpy
-%%GTK2_SUPPORT%%bin/ogmrip
-%%SRT_SUPPORT%%bin/subp2pgm
-%%SRT_SUPPORT%%bin/subp2png
-%%SRT_SUPPORT%%bin/subp2tiff
-%%SRT_SUPPORT%%bin/subptools
-%%THEORA_SUPPORT%%bin/theoraenc
+%%GTK2%%bin/ogmrip
+%%SRT%%bin/subp2pgm
+%%SRT%%bin/subp2png
+%%SRT%%bin/subp2tiff
+%%SRT%%bin/subptools
+%%THEORA%%bin/theoraenc
include/ogmdvd/ogmdvd-audio.h
-%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-cell-renderer-language.h
-%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-chapter-list.h
+%%GTK2%%include/ogmdvd/ogmdvd-cell-renderer-language.h
+%%GTK2%%include/ogmdvd/ogmdvd-chapter-list.h
include/ogmdvd/ogmdvd-disc.h
-%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-drive-chooser-dialog.h
-%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-drive-chooser-widget.h
-%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-drive-chooser.h
+%%GTK2%%include/ogmdvd/ogmdvd-drive-chooser-dialog.h
+%%GTK2%%include/ogmdvd/ogmdvd-drive-chooser-widget.h
+%%GTK2%%include/ogmdvd/ogmdvd-drive-chooser.h
include/ogmdvd/ogmdvd-drive.h
include/ogmdvd/ogmdvd-enums.h
-%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-gtk.h
+%%GTK2%%include/ogmdvd/ogmdvd-gtk.h
include/ogmdvd/ogmdvd-labels.h
-%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-marshal.h
+%%GTK2%%include/ogmdvd/ogmdvd-marshal.h
include/ogmdvd/ogmdvd-monitor.h
include/ogmdvd/ogmdvd-parser.h
include/ogmdvd/ogmdvd-reader.h
include/ogmdvd/ogmdvd-stream.h
include/ogmdvd/ogmdvd-subp.h
-%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-title-chooser-widget.h
-%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-title-chooser.h
+%%GTK2%%include/ogmdvd/ogmdvd-title-chooser-widget.h
+%%GTK2%%include/ogmdvd/ogmdvd-title-chooser.h
include/ogmdvd/ogmdvd-title.h
include/ogmdvd/ogmdvd-types.h
include/ogmdvd/ogmdvd.h
@@ -39,9 +39,9 @@ include/ogmjob/ogmjob-queue.h
include/ogmjob/ogmjob-spawn.h
include/ogmjob/ogmjob.h
include/ogmrip/ogmrip-audio-codec.h
-%%GTK2_SUPPORT%%include/ogmrip/ogmrip-chapter-list.h
+%%GTK2%%include/ogmrip/ogmrip-chapter-list.h
include/ogmrip/ogmrip-chapters.h
-%%GTK2_SUPPORT%%include/ogmrip/ogmrip-chooser-list.h
+%%GTK2%%include/ogmrip/ogmrip-chooser-list.h
include/ogmrip/ogmrip-codec.h
include/ogmrip/ogmrip-container.h
include/ogmrip/ogmrip-dvdcpy.h
@@ -51,29 +51,29 @@ include/ogmrip/ogmrip-encoding.h
include/ogmrip/ogmrip-enums.h
include/ogmrip/ogmrip-file.h
include/ogmrip/ogmrip-fs.h
-%%GTK2_SUPPORT%%include/ogmrip/ogmrip-gconf-settings.h
-%%GTK2_SUPPORT%%include/ogmrip/ogmrip-gtk.h
+%%GTK2%%include/ogmrip/ogmrip-gconf-settings.h
+%%GTK2%%include/ogmrip/ogmrip-gtk.h
include/ogmrip/ogmrip-hardsub.h
-%%GTK2_SUPPORT%%include/ogmrip/ogmrip-helper.h
+%%GTK2%%include/ogmrip/ogmrip-helper.h
include/ogmrip/ogmrip-keyfile-settings.h
include/ogmrip/ogmrip-lavc.h
include/ogmrip/ogmrip-mplayer.h
include/ogmrip/ogmrip-novideo.h
-%%GTK2_SUPPORT%%include/ogmrip/ogmrip-options-plugin.h
+%%GTK2%%include/ogmrip/ogmrip-options-plugin.h
include/ogmrip/ogmrip-options.h
include/ogmrip/ogmrip-player.h
include/ogmrip/ogmrip-plugin.h
include/ogmrip/ogmrip-settings.h
-%%GTK2_SUPPORT%%include/ogmrip/ogmrip-source-chooser-widget.h
-%%GTK2_SUPPORT%%include/ogmrip/ogmrip-source-chooser.h
+%%GTK2%%include/ogmrip/ogmrip-source-chooser-widget.h
+%%GTK2%%include/ogmrip/ogmrip-source-chooser.h
include/ogmrip/ogmrip-subp-codec.h
include/ogmrip/ogmrip-version.h
include/ogmrip/ogmrip-video-codec.h
include/ogmrip/ogmrip.h
-%%GTK2_SUPPORT%%lib/libogmdvd-gtk.a
-%%GTK2_SUPPORT%%lib/libogmdvd-gtk.so
-%%GTK2_SUPPORT%%lib/libogmdvd-gtk.so.1
-%%GTK2_SUPPORT%%lib/libogmdvd-gtk.so.1.0.0
+%%GTK2%%lib/libogmdvd-gtk.a
+%%GTK2%%lib/libogmdvd-gtk.so
+%%GTK2%%lib/libogmdvd-gtk.so.1
+%%GTK2%%lib/libogmdvd-gtk.so.1.0.0
lib/libogmdvd.a
lib/libogmdvd.so
lib/libogmdvd.so.1
@@ -82,10 +82,10 @@ lib/libogmjob.a
lib/libogmjob.so
lib/libogmjob.so.1
lib/libogmjob.so.1.0.0
-%%GTK2_SUPPORT%%lib/libogmrip-gtk.a
-%%GTK2_SUPPORT%%lib/libogmrip-gtk.so
-%%GTK2_SUPPORT%%lib/libogmrip-gtk.so.1
-%%GTK2_SUPPORT%%lib/libogmrip-gtk.so.1.0.0
+%%GTK2%%lib/libogmrip-gtk.a
+%%GTK2%%lib/libogmrip-gtk.so
+%%GTK2%%lib/libogmrip-gtk.so.1
+%%GTK2%%lib/libogmrip-gtk.so.1.0.0
lib/libogmrip-lavc.a
lib/libogmrip-lavc.so
lib/libogmrip-lavc.so.1
@@ -98,8 +98,8 @@ lib/libogmrip.a
lib/libogmrip.so
lib/libogmrip.so.1
lib/libogmrip.so.1.0.0
-%%FAAC_SUPPORT%%lib/ogmrip/audio-plugins/libogmrip-aac.a
-%%FAAC_SUPPORT%%lib/ogmrip/audio-plugins/libogmrip-aac.so
+%%FAAC%%lib/ogmrip/audio-plugins/libogmrip-aac.a
+%%FAAC%%lib/ogmrip/audio-plugins/libogmrip-aac.so
lib/ogmrip/audio-plugins/libogmrip-acopy.a
lib/ogmrip/audio-plugins/libogmrip-acopy.so
lib/ogmrip/audio-plugins/libogmrip-mp3.a
@@ -110,28 +110,28 @@ lib/ogmrip/audio-plugins/libogmrip-wav.a
lib/ogmrip/audio-plugins/libogmrip-wav.so
lib/ogmrip/container-plugins/libogmrip-avi.a
lib/ogmrip/container-plugins/libogmrip-avi.so
-%%MATROSKA_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mkv.a
-%%MATROSKA_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mkv.so
+%%MATROSKA%%lib/ogmrip/container-plugins/libogmrip-mkv.a
+%%MATROSKA%%lib/ogmrip/container-plugins/libogmrip-mkv.so
lib/ogmrip/container-plugins/libogmrip-mov.a
lib/ogmrip/container-plugins/libogmrip-mov.so
-%%MP4BOX_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mp4.a
-%%MP4BOX_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mp4.so
+%%MP4BOX%%lib/ogmrip/container-plugins/libogmrip-mp4.a
+%%MP4BOX%%lib/ogmrip/container-plugins/libogmrip-mp4.so
lib/ogmrip/container-plugins/libogmrip-ogg.a
lib/ogmrip/container-plugins/libogmrip-ogg.so
-%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-lavc-options.a
-%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-lavc-options.so
-%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-x264-options.a
-%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-x264-options.so
-%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-xvid-options.a
-%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-xvid-options.so
-%%SRT_SUPPORT%%lib/ogmrip/subp-plugins/libogmrip-srt.a
-%%SRT_SUPPORT%%lib/ogmrip/subp-plugins/libogmrip-srt.so
+%%GTK2%%lib/ogmrip/options-plugins/libogmrip-lavc-options.a
+%%GTK2%%lib/ogmrip/options-plugins/libogmrip-lavc-options.so
+%%GTK2%%lib/ogmrip/options-plugins/libogmrip-x264-options.a
+%%GTK2%%lib/ogmrip/options-plugins/libogmrip-x264-options.so
+%%GTK2%%lib/ogmrip/options-plugins/libogmrip-xvid-options.a
+%%GTK2%%lib/ogmrip/options-plugins/libogmrip-xvid-options.so
+%%SRT%%lib/ogmrip/subp-plugins/libogmrip-srt.a
+%%SRT%%lib/ogmrip/subp-plugins/libogmrip-srt.so
lib/ogmrip/subp-plugins/libogmrip-vobsub.a
lib/ogmrip/subp-plugins/libogmrip-vobsub.so
lib/ogmrip/video-plugins/libogmrip-lavc-mpeg4.a
lib/ogmrip/video-plugins/libogmrip-lavc-mpeg4.so
-%%THEORA_SUPPORT%%lib/ogmrip/video-plugins/libogmrip-theora.a
-%%THEORA_SUPPORT%%lib/ogmrip/video-plugins/libogmrip-theora.so
+%%THEORA%%lib/ogmrip/video-plugins/libogmrip-theora.a
+%%THEORA%%lib/ogmrip/video-plugins/libogmrip-theora.so
lib/ogmrip/video-plugins/libogmrip-x264.a
lib/ogmrip/video-plugins/libogmrip-x264.so
lib/ogmrip/video-plugins/libogmrip-xvid.a
@@ -146,28 +146,28 @@ libdata/pkgconfig/ogmrip-gtk.pc
libdata/pkgconfig/ogmrip.pc
man/man1/dvdcpy.1.gz
man/man1/avibox.1.gz
-%%SRT_SUPPORT%%man/man1/subp2pgm.1.gz
-%%SRT_SUPPORT%%man/man1/subptools.1.gz
-%%GTK2_SUPPORT%%share/applications/ogmrip.desktop
+%%SRT%%man/man1/subp2pgm.1.gz
+%%SRT%%man/man1/subptools.1.gz
+%%GTK2%%share/applications/ogmrip.desktop
%%NLS%%share/locale/cs/LC_MESSAGES/ogmrip.mo
%%NLS%%share/locale/de/LC_MESSAGES/ogmrip.mo
%%NLS%%share/locale/fr/LC_MESSAGES/ogmrip.mo
%%NLS%%share/locale/nb/LC_MESSAGES/ogmrip.mo
%%NLS%%share/locale/ru/LC_MESSAGES/ogmrip.mo
%%NLS%%share/locale/sk/LC_MESSAGES/ogmrip.mo
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-crop.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-lavc.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-main.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-options.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-pref.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-profile-editor.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-profiles.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-progress.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-queue.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-spell.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-ui.xml
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-update.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-x264.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-xvid.glade
-%%GTK2_SUPPORT%%%%DATADIR%%/profiles/profiles.xml
-%%GTK2_SUPPORT%%share/pixmaps/ogmrip.png
+%%GTK2%%%%DATADIR%%/ogmrip-crop.glade
+%%GTK2%%%%DATADIR%%/ogmrip-lavc.glade
+%%GTK2%%%%DATADIR%%/ogmrip-main.glade
+%%GTK2%%%%DATADIR%%/ogmrip-options.glade
+%%GTK2%%%%DATADIR%%/ogmrip-pref.glade
+%%GTK2%%%%DATADIR%%/ogmrip-profile-editor.glade
+%%GTK2%%%%DATADIR%%/ogmrip-profiles.glade
+%%GTK2%%%%DATADIR%%/ogmrip-progress.glade
+%%GTK2%%%%DATADIR%%/ogmrip-queue.glade
+%%GTK2%%%%DATADIR%%/ogmrip-spell.glade
+%%GTK2%%%%DATADIR%%/ogmrip-ui.xml
+%%GTK2%%%%DATADIR%%/ogmrip-update.glade
+%%GTK2%%%%DATADIR%%/ogmrip-x264.glade
+%%GTK2%%%%DATADIR%%/ogmrip-xvid.glade
+%%GTK2%%%%DATADIR%%/profiles/profiles.xml
+%%GTK2%%share/pixmaps/ogmrip.png