aboutsummaryrefslogtreecommitdiff
path: root/multimedia/okle
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-07-15 17:36:25 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-07-15 17:36:25 +0000
commitaab6be4745870258b121265449873c9c5149b24a (patch)
treec0ff5e7b14b80cd65c3c51c700bbb850d9a6884f /multimedia/okle
parent800ef6c0b0033de28d4551a8dcefcd27457c8c54 (diff)
downloadports-aab6be4745870258b121265449873c9c5149b24a.tar.gz
ports-aab6be4745870258b121265449873c9c5149b24a.zip
Notes
Diffstat (limited to 'multimedia/okle')
-rw-r--r--multimedia/okle/Makefile71
-rw-r--r--multimedia/okle/distinfo1
-rw-r--r--multimedia/okle/files/patch-configure.in11
-rw-r--r--multimedia/okle/files/patch-src::sniffer.cpp27
-rw-r--r--multimedia/okle/files/wrapper.sh7
-rw-r--r--multimedia/okle/pkg-comment1
-rw-r--r--multimedia/okle/pkg-descr11
-rw-r--r--multimedia/okle/pkg-plist41
8 files changed, 170 insertions, 0 deletions
diff --git a/multimedia/okle/Makefile b/multimedia/okle/Makefile
new file mode 100644
index 000000000000..0e1916bdedfc
--- /dev/null
+++ b/multimedia/okle/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: Ogle KDE GUI
+# Date created: Tue Jul 9 20:24:02 UTC 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= okle
+PORTVERSION= 0.2.2
+CATEGORIES= graphics kde
+MASTER_SITES= http://okle.sourceforge.net/
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.7:${PORTSDIR}/graphics/ogle \
+ autoconf:${PORTSDIR}/devel/autoconf
+RUN_DEPENDS= ogle:${PORTSDIR}/graphics/ogle
+
+USE_KDELIBS_VER= 3
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ogle-dir=${LOCALBASE}/bin \
+ --with-ogle-includes=${LOCALBASE}/include \
+ --with-ogle-libs=${LOCALBASE}/lib/ogle
+
+# location of okle ogle_gui
+DVDP_UI=${PREFIX}/lib/okle/ogle_gui
+OGLE=${LOCALBASE}/bin/ogle
+
+pre-everything::
+.ifndef(WITH_DVD_DEVICE)
+ @${ECHO_MSG} '===> The default DVD device is /dev/acd0c'
+ @${ECHO_MSG} "===> You can choose any DVD device at Ogle's command line"
+ @${ECHO_MSG} '===> Define WITH_DVD_DEVICE if you want to change the default'
+ @${ECHO_MSG} "===> For example, 'make WITH_DVD_DEVICE=\"/dev/somedevice\"'"
+.endif
+
+pre-configure:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf && ${LOCALBASE}/bin/autoheader
+
+post-install:
+ @${MKDIR} ${PREFIX}/lib/okle
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/ogle_gui ${PREFIX}/lib/okle
+ @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_DVD_DEVICE)
+DEFAULT_DVD_DEVICE=${WITH_DVD_DEVICE}
+.else
+DEFAULT_DVD_DEVICE=/dev/acd0c
+.endif
+
+post-patch:
+# wrapper hack to allow ogle to have both ogle-gui and oKle installed
+# at same time
+ @${SED} -e "s|%%DVDP_UI%%|${DVDP_UI}|; \
+ s|%%ENV%%|${SETENV}|; \
+ s|%%OGLE%%|${OGLE}|" \
+ ${FILESDIR}/wrapper.sh > \
+ ${WRKDIR}/wrapper.sh
+ @${REINPLACE_CMD} -E -e 's|^(Exec=).+$$|\1${PORTNAME}|' \
+ ${WRKSRC}/src/okle.desktop
+# point to specific device
+ @${REINPLACE_CMD} -e "s|\"/dev/dvd\"|\"${DEFAULT_DVD_DEVICE}\"|" \
+ ${WRKSRC}/src/okle_win.cpp
+# do not use version names
+ @${REINPLACE_CMD} -E -e 's|^(PACKAGE[[:space:]]+=).+$$|\1${PORTNAME}|' \
+ ${WRKSRC}/po/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/okle/distinfo b/multimedia/okle/distinfo
new file mode 100644
index 000000000000..e77dd07d625f
--- /dev/null
+++ b/multimedia/okle/distinfo
@@ -0,0 +1 @@
+MD5 (okle-0.2.2.tar.gz) = 1fe13301f071f9aa52b1c9093d7b4677
diff --git a/multimedia/okle/files/patch-configure.in b/multimedia/okle/files/patch-configure.in
new file mode 100644
index 000000000000..b8ad1201387f
--- /dev/null
+++ b/multimedia/okle/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Mon Jul 15 14:00:59 2002
++++ configure.in Mon Jul 15 14:01:18 2002
+@@ -63,7 +63,7 @@
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
+ AC_HEADER_TIME
+-AC_CHECK_HEADERS(fcntl.h sys/time.h unistd.h stdlib.h paths.h)
++AC_CHECK_HEADERS(fcntl.h sys/param.h sys/time.h unistd.h stdlib.h paths.h)
+ AC_CHECK_FUNCS(usleep)
+
+ dnl Checks for ogle.
diff --git a/multimedia/okle/files/patch-src::sniffer.cpp b/multimedia/okle/files/patch-src::sniffer.cpp
new file mode 100644
index 000000000000..069862b7c9bb
--- /dev/null
+++ b/multimedia/okle/files/patch-src::sniffer.cpp
@@ -0,0 +1,27 @@
+--- src/sniffer.cpp.orig Sun Jul 14 07:58:36 2002
++++ src/sniffer.cpp Mon Jul 15 14:20:26 2002
+@@ -1,3 +1,9 @@
++#include "config.h"
++
++#ifdef HAVE_SYS_PARAM_H
++# include <sys/param.h>
++#endif
++
+ #include "sniffer.h"
+
+ #include <kapp.h>
+@@ -37,7 +43,13 @@
+
+ while(1)
+ {
+- DVDNextEvent(nav2, &mev);
++#if (defined(BSD) && (BSD >= 199306))
++ if (DVDNextEventNonBlocking(nav2, &mev) != DVD_E_Ok)
++ QThread::exit();
++#else
++ if (DVDNextEvent(nav2, &mev) != DVD_E_Ok)
++ QThread::exit();
++#endif
+ switch(mev.type)
+ {
+ case MsgEventQInputPointerMotion:
diff --git a/multimedia/okle/files/wrapper.sh b/multimedia/okle/files/wrapper.sh
new file mode 100644
index 000000000000..98bcd8c1d26f
--- /dev/null
+++ b/multimedia/okle/files/wrapper.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+DVDP_UI="%%DVDP_UI%%"
+ENV="%%ENV%%"
+OGLE="%%OGLE%%"
+
+${ENV} DVDP_UI="${DVDP_UI}" ${OGLE}
diff --git a/multimedia/okle/pkg-comment b/multimedia/okle/pkg-comment
new file mode 100644
index 000000000000..3712acf31f7c
--- /dev/null
+++ b/multimedia/okle/pkg-comment
@@ -0,0 +1 @@
+oKle is a KDE frontend to the Ogle DVD player
diff --git a/multimedia/okle/pkg-descr b/multimedia/okle/pkg-descr
new file mode 100644
index 000000000000..9533a569beff
--- /dev/null
+++ b/multimedia/okle/pkg-descr
@@ -0,0 +1,11 @@
+This is a Graphical Interface for Ogle.
+
+It is oKle is a KDE frontend to the Ogle DVD player both visually
+and functionally resembling the one from graphics/ogle-gui port.
+
+It is very helpful if you would rather use a KDE based frontend
+than the ogle-gui Glade (which incidently installs Gnome Libraries)
+based one.
+
+Author: Martin Piskernig <martin.piskernig@univie.ac.at>
+WWW: http://okle.sourceforge.net/
diff --git a/multimedia/okle/pkg-plist b/multimedia/okle/pkg-plist
new file mode 100644
index 000000000000..0ebdda557457
--- /dev/null
+++ b/multimedia/okle/pkg-plist
@@ -0,0 +1,41 @@
+bin/okle
+lib/okle/ogle_gui
+share/applnk/Multimedia/okle.desktop
+share/apps/okle/okleui.rc
+share/apps/okle/pics/angleselect.png
+share/apps/okle/pics/audioselect.png
+share/apps/okle/pics/back.png
+share/apps/okle/pics/down.png
+share/apps/okle/pics/enter.png
+share/apps/okle/pics/fastforward.png
+share/apps/okle/pics/forward.png
+share/apps/okle/pics/goup.png
+share/apps/okle/pics/pause.png
+share/apps/okle/pics/play.png
+share/apps/okle/pics/playfast.png
+share/apps/okle/pics/playslow.png
+share/apps/okle/pics/reverse.png
+share/apps/okle/pics/rewind.png
+share/apps/okle/pics/selmenu.png
+share/apps/okle/pics/skipbackward.png
+share/apps/okle/pics/skipforward.png
+share/apps/okle/pics/stepforward.png
+share/apps/okle/pics/stepreverse.png
+share/apps/okle/pics/stop.png
+share/apps/okle/pics/subtitleselect.png
+share/apps/okle/pics/up.png
+share/icons/hicolor/16x16/apps/okle.png
+share/icons/hicolor/32x32/apps/okle.png
+share/locale/de/LC_MESSAGES/okle.mo
+share/locale/sv/LC_MESSAGES/okle.mo
+@unexec rmdir %D/share/locale/sv/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/sv 2>/dev/null || true
+@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/de 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
+@dirrm share/apps/okle/pics
+@dirrm share/apps/okle
+@dirrm lib/okle