aboutsummaryrefslogtreecommitdiff
path: root/multimedia/openh264
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-11-15 12:56:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-11-15 12:56:54 +0000
commit50a7356718adc665dceeb8d28380ba0cc35996d6 (patch)
tree923b618bebdbc4238c062b98c5a404d170c486ef /multimedia/openh264
parentc72eedcb04e6dda5447dd823b1fa540d0db2b08c (diff)
downloadports-50a7356718adc665dceeb8d28380ba0cc35996d6.tar.gz
ports-50a7356718adc665dceeb8d28380ba0cc35996d6.zip
multimedia/openh264: make sure as(1) is available
aarch64 lacks binutils in base unlike armv6 while the buildbot only copies ld(1) from ports under /usr/bin. Note, Clang 3.9 still doesn't support the assembly used here.
Notes
Notes: svn path=/head/; revision=426166
Diffstat (limited to 'multimedia/openh264')
-rw-r--r--multimedia/openh264/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/multimedia/openh264/Makefile b/multimedia/openh264/Makefile
index 01e50733a3c2..b6c731b10149 100644
--- a/multimedia/openh264/Makefile
+++ b/multimedia/openh264/Makefile
@@ -27,13 +27,12 @@ MAKE_ARGS= PREFIX="${PREFIX}" \
CFLAGS_OPT="" CFLAGS_DEBUG=""
ALL_TARGET= all
-BROKEN_aarch64= Fails to compile: cc: error: unable to execute command: Executable as does not exist
-
OPTIONS_DEFINE= DEBUG PLUGINS TEST
OPTIONS_DEFAULT=PLUGINS
OPTIONS_SUB= yes
DEBUG_BUILD_DEPENDS_OFF= ${DEBUG_BUILD_DEPENDS_OFF_${ARCH}}
+DEBUG_BUILD_DEPENDS_OFF_aarch64=as:devel/binutils
DEBUG_BUILD_DEPENDS_OFF_amd64= nasm:devel/nasm
DEBUG_BUILD_DEPENDS_OFF_i386= nasm:devel/nasm
DEBUG_MAKE_ARGS=BUILDTYPE=Debug