aboutsummaryrefslogtreecommitdiff
path: root/multimedia/p5-FLV-Info
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-07-14 15:53:46 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-07-14 15:53:46 +0000
commitd03c723524295b4bd8e3b0835f2a4268b55722a2 (patch)
tree1ab4c8dc14b26cc0003eb74db562b27742e38dbd /multimedia/p5-FLV-Info
parent695697c8ce95dfecf1ec31a15c6912f2ee758398 (diff)
downloadports-d03c723524295b4bd8e3b0835f2a4268b55722a2.tar.gz
ports-d03c723524295b4bd8e3b0835f2a4268b55722a2.zip
This module reads Macromedia FLV files and reports metadata about
those files. WWW: http://search.cpan.org/dist/FLV-Info/ PR: ports/100280 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=167805
Diffstat (limited to 'multimedia/p5-FLV-Info')
-rw-r--r--multimedia/p5-FLV-Info/Makefile40
-rw-r--r--multimedia/p5-FLV-Info/distinfo3
-rw-r--r--multimedia/p5-FLV-Info/pkg-descr4
-rw-r--r--multimedia/p5-FLV-Info/pkg-plist18
4 files changed, 65 insertions, 0 deletions
diff --git a/multimedia/p5-FLV-Info/Makefile b/multimedia/p5-FLV-Info/Makefile
new file mode 100644
index 000000000000..abec04ca1a18
--- /dev/null
+++ b/multimedia/p5-FLV-Info/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-FLV-Info
+# Date created: 2006-07-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FLV-Info
+PORTVERSION= 0.02
+CATEGORIES= multimedia perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CL/CLOTHO
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Extract metadata from Flash Video files
+
+BUILD_DEPENDS= ${SITE_PERL}/AMF/Perl.pm:${PORTSDIR}/www/p5-AMF-Perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= flvinfo.1
+MAN3= FLV::AMFReader.3 FLV::AMFWriter.3 FLV::AudioTag.3 \
+ FLV::Base.3 FLV::Body.3 FLV::Constants.3 FLV::File.3 \
+ FLV::Header.3 FLV::Info.3 FLV::MetaTag.3 FLV::Tag.3 \
+ FLV::VideoTag.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.if ${PERL_LEVEL} < 500702
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/p5-FLV-Info/distinfo b/multimedia/p5-FLV-Info/distinfo
new file mode 100644
index 000000000000..73d67e7c22dd
--- /dev/null
+++ b/multimedia/p5-FLV-Info/distinfo
@@ -0,0 +1,3 @@
+MD5 (FLV-Info-0.02.tgz) = b34dd8463fbef7990fdf6f2bd029ab00
+SHA256 (FLV-Info-0.02.tgz) = 9412c14a6b807ae13bbc20e99b51f2d75255b8b8e23e134d81d52a2b844c1f65
+SIZE (FLV-Info-0.02.tgz) = 518747
diff --git a/multimedia/p5-FLV-Info/pkg-descr b/multimedia/p5-FLV-Info/pkg-descr
new file mode 100644
index 000000000000..01aca967910b
--- /dev/null
+++ b/multimedia/p5-FLV-Info/pkg-descr
@@ -0,0 +1,4 @@
+This module reads Macromedia FLV files and reports metadata about
+those files.
+
+WWW: http://search.cpan.org/dist/FLV-Info/
diff --git a/multimedia/p5-FLV-Info/pkg-plist b/multimedia/p5-FLV-Info/pkg-plist
new file mode 100644
index 000000000000..664885182626
--- /dev/null
+++ b/multimedia/p5-FLV-Info/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+bin/flvinfo
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/FLV/Info/.packlist
+%%SITE_PERL%%/FLV/AMFReader.pm
+%%SITE_PERL%%/FLV/AMFWriter.pm
+%%SITE_PERL%%/FLV/AudioTag.pm
+%%SITE_PERL%%/FLV/Base.pm
+%%SITE_PERL%%/FLV/Body.pm
+%%SITE_PERL%%/FLV/Constants.pm
+%%SITE_PERL%%/FLV/File.pm
+%%SITE_PERL%%/FLV/Header.pm
+%%SITE_PERL%%/FLV/Info.pm
+%%SITE_PERL%%/FLV/MetaTag.pm
+%%SITE_PERL%%/FLV/Tag.pm
+%%SITE_PERL%%/FLV/VideoTag.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FLV/Info
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FLV
+@dirrmtry %%SITE_PERL%%/FLV