aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon-designerplugin
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-21 16:52:09 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-21 16:52:09 +0000
commit60539b7275681c5d8ac91d2e89508f20b5059ba2 (patch)
tree52d56bde5dacbad51f88fdfd8939a709ff216747 /multimedia/phonon-designerplugin
parente394fa51777a2afe4532a9d75443598cc43ddd8f (diff)
Notes
Diffstat (limited to 'multimedia/phonon-designerplugin')
-rw-r--r--multimedia/phonon-designerplugin/Makefile32
-rw-r--r--multimedia/phonon-designerplugin/pkg-descr2
2 files changed, 25 insertions, 9 deletions
diff --git a/multimedia/phonon-designerplugin/Makefile b/multimedia/phonon-designerplugin/Makefile
index 2f202426b7ed..f71a6a700d4e 100644
--- a/multimedia/phonon-designerplugin/Makefile
+++ b/multimedia/phonon-designerplugin/Makefile
@@ -1,26 +1,42 @@
# $FreeBSD$
PORTNAME= phonon
-PORTVERSION= 4.9.1
+DISTVERSION= 4.10.1
CATEGORIES= multimedia kde
-MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
-PKGNAMESUFFIX= -designerplugin
-DIST_SUBDIR= KDE
+MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}
+DIST_SUBDIR= KDE/phonon
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt Designer plugin for Phonon
LICENSE= LGPL21
-USE_QT4= corelib designer gui phonon \
- qmake_build moc_build rcc_build uic_build
+FLAVORS= qt4 qt5
+FLAVOR?= ${FLAVORS:[1]}
+
+qt4_PKGNAMESUFFIX= -designerplugin-qt4
+qt5_PKGNAMESUFFIX= -designerplugin-qt5
+
USES= cmake tar:xz
+
+. if ${FLAVOR} == qt4
+USES+= kde:4
+USE_QT4= corelib designer gui phonon \
+ qmake_build moc_build rcc_build uic_build
+PLIST_FILES= ${QT_PLUGINDIR_REL}/designer/libphononwidgets.so
+. else
+USES+= kde:5
+USE_KDE= ecm
+USE_QT5= core designer gui phonon4 widgets xml \
+ buildtools_build qmake_build
+CMAKE_ON= PHONON_BUILD_PHONON4QT5
+PLIST_FILES= ${QT_PLUGINDIR_REL}/designer/phononwidgets.so
+. endif
+
CMAKE_ARGS= -DPHONON_QT_PLUGIN_INSTALL_DIR=${PREFIX}/${QT_PLUGINDIR_REL}/designer
BUILD_WRKSRC= ${WRKSRC}/designer
INSTALL_WRKSRC= ${BUILD_WRKSRC}
DISTINFO_FILE= ${.CURDIR:H}/phonon/distinfo
-PLIST_FILES= ${QT_PLUGINDIR_REL}/designer/libphononwidgets.so
-
.include <bsd.port.mk>
diff --git a/multimedia/phonon-designerplugin/pkg-descr b/multimedia/phonon-designerplugin/pkg-descr
index 129f8f4c1a4e..f060aee2af45 100644
--- a/multimedia/phonon-designerplugin/pkg-descr
+++ b/multimedia/phonon-designerplugin/pkg-descr
@@ -1,5 +1,5 @@
Phonon is the framework responsible for an ubiquitous multimedia
-experience in KDE Software Compilation 4.
+experience in KDE Software Compilation 4 and Plasma Desktop.
This port installs Qt Designer plugin for Phonon.
WWW: http://phonon.kde.org