aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon-gstreamer
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /multimedia/phonon-gstreamer
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadports-0f583d87000061087521fb77c44c9055d122d787.tar.gz
ports-0f583d87000061087521fb77c44c9055d122d787.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Notes
Notes: svn path=/head/; revision=420774
Diffstat (limited to 'multimedia/phonon-gstreamer')
-rw-r--r--multimedia/phonon-gstreamer/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/phonon-gstreamer/Makefile b/multimedia/phonon-gstreamer/Makefile
index b732613ff7e3..7ea43f11124b 100644
--- a/multimedia/phonon-gstreamer/Makefile
+++ b/multimedia/phonon-gstreamer/Makefile
@@ -15,14 +15,14 @@ COMMENT= GStreamer backend for Phonon
LICENSE= LGPL21
+USES= cmake kde:4 pkgconfig tar:xz
USE_GL= gl
USE_GNOME= glib20 libxml2
USE_GSTREAMER1= yes
-USE_KDE4= automoc4
+USE_KDE= automoc4
USE_QT4= corelib gui opengl phonon \
qmake_build moc_build rcc_build uic_build
USE_XORG= x11
-USES= cmake pkgconfig tar:xz
SUB_FILES= pkg-message