aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon-gstreamer
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-29 01:00:36 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-29 01:00:36 +0000
commit1ba9d5f3b6ae67837afca5e88d2c0e68cc676e83 (patch)
tree27b56d741e5d52346739bf29754d723825b4917e /multimedia/phonon-gstreamer
parent57f42b7532626372b57991bade5e428e242911b7 (diff)
downloadports-1ba9d5f3b6ae67837afca5e88d2c0e68cc676e83.tar.gz
ports-1ba9d5f3b6ae67837afca5e88d2c0e68cc676e83.zip
- Add an option to alternatively:
* depend on gstreamer-plugins-all; * show a pkg-message alerting user he needs plugins.
Notes
Notes: svn path=/head/; revision=284579
Diffstat (limited to 'multimedia/phonon-gstreamer')
-rw-r--r--multimedia/phonon-gstreamer/Makefile16
-rw-r--r--multimedia/phonon-gstreamer/files/pkg-message.in7
2 files changed, 23 insertions, 0 deletions
diff --git a/multimedia/phonon-gstreamer/Makefile b/multimedia/phonon-gstreamer/Makefile
index cf4a9b4b679b..97d872201044 100644
--- a/multimedia/phonon-gstreamer/Makefile
+++ b/multimedia/phonon-gstreamer/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= GStreamer backend for Phonon
+# Required in order to avoid conflicts with multimedia/phonon's OPTIONS.
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
+
CONFLICTS= qt4-phonon-gst-4*
PHONON_BRANCH= stable
@@ -43,11 +46,24 @@ CMAKE_ARGS+= -DWITH_Alsa:BOOL=OFF
IGNORE= conflicts with Qt 4 Phonon. Please, deinstall qt4-phonon-gst and unset WITH_QT_PHONON to continue
.endif
+OPTIONS= PLUGINS "Install GStreamer plugins" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PLUGINS)
+RUN_DEPENDS+= gstreamer-plugins-all>=0:${PORTSDIR}/multimedia/gstreamer-plugins-all
+.else
+SUB_FILES= pkg-message
+.endif
+
pre-su-install:
${MKDIR} ${QT_PLUGINDIR}/phonon_backend
post-install:
${LN} -sf ${PREFIX}/lib/kde4/plugins/phonon_backend/phonon_gstreamer.so \
${QT_PLUGINDIR}/phonon_backend/libphonon_gstreamer.so
+.if !defined(WITH_PLUGINS)
+ @${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.mk>
diff --git a/multimedia/phonon-gstreamer/files/pkg-message.in b/multimedia/phonon-gstreamer/files/pkg-message.in
new file mode 100644
index 000000000000..1a601e0be98f
--- /dev/null
+++ b/multimedia/phonon-gstreamer/files/pkg-message.in
@@ -0,0 +1,7 @@
+======================================================================
+
+You'll need to install some GStreamer plugins to make Phonon able to
+play something via this backend: multimedia/gstreamer-plugins-all will
+let you choose among all of them.
+
+======================================================================