aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon-gstreamer
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /multimedia/phonon-gstreamer
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'multimedia/phonon-gstreamer')
-rw-r--r--multimedia/phonon-gstreamer/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/multimedia/phonon-gstreamer/Makefile b/multimedia/phonon-gstreamer/Makefile
index f5177d3299d5..e46cc06e8170 100644
--- a/multimedia/phonon-gstreamer/Makefile
+++ b/multimedia/phonon-gstreamer/Makefile
@@ -29,14 +29,14 @@ USE_GSTREAMER1= yes
USE_XORG= x11
. if ${FLAVOR} == qt4
-USES+= kde:4
+USES+= kde:4 qt:4
USE_KDE= automoc4
-USE_QT4= corelib gui opengl phonon \
+USE_QT= corelib gui opengl phonon \
qmake_build moc_build rcc_build uic_build
. else
-USES+= kde:5
+USES+= kde:5 qt:5
USE_KDE= ecm
-USE_QT5= core gui opengl phonon4 widgets x11extras \
+USE_QT= core gui opengl phonon4 widgets x11extras \
buildtools_build qmake_build
CMAKE_ON= PHONON_BUILD_PHONON4QT5
. endif