aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon-gstreamer
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-09-04 14:30:13 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-09-04 14:30:13 +0000
commitc4394b98d47f1acbcbb5f63aa48d1504970ce68d (patch)
treedb2c94b6941a9bbff6570a1a05753da490db151d /multimedia/phonon-gstreamer
parent9d00fc2b3e0dd12135a6a5919110bc054349b9f8 (diff)
downloadports-c4394b98d47f1acbcbb5f63aa48d1504970ce68d.tar.gz
ports-c4394b98d47f1acbcbb5f63aa48d1504970ce68d.zip
Update Phonon to 4.9.0.
Release notes: - https://community.kde.org/Phonon/Releases/Core/4.9.0 - https://community.kde.org/Phonon/Releases/GStreamer/4.9.0 - https://community.kde.org/Phonon/Releases/VLC/0.9.0 This release fixes the build with the upcoming Qt 5.6, which was failing like this: /usr/bin/c++ -O2 -pipe -fstack-protector -fno-strict-aliasing -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -Woverloaded-virtual -fno-common -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -Wno-return-type-c-linkage CMakeFiles/cmTC_08ed6.dir/check_qt_visibility.cpp.o -o cmTC_08ed6 CMakeFiles/cmTC_08ed6.dir/check_qt_visibility.cpp.o:(.qtversion[qt_version_tag]+0x0): undefined reference to `qt_version_tag' Most of the work was done by tcberner@. PR: 211916
Notes
Notes: svn path=/head/; revision=421340
Diffstat (limited to 'multimedia/phonon-gstreamer')
-rw-r--r--multimedia/phonon-gstreamer/Makefile7
-rw-r--r--multimedia/phonon-gstreamer/distinfo5
-rw-r--r--multimedia/phonon-gstreamer/files/patch-CMakeLists.txt10
-rw-r--r--multimedia/phonon-gstreamer/pkg-plist2
4 files changed, 8 insertions, 16 deletions
diff --git a/multimedia/phonon-gstreamer/Makefile b/multimedia/phonon-gstreamer/Makefile
index 7ea43f11124b..d5833b1b561b 100644
--- a/multimedia/phonon-gstreamer/Makefile
+++ b/multimedia/phonon-gstreamer/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= phonon
-PORTVERSION= 4.8.2
-PORTREVISION= 1
+PORTVERSION= 4.9.0
CATEGORIES= multimedia kde
-MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}/src
+MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}
PKGNAMESUFFIX= -gstreamer
DISTNAME= ${PORTNAME}-backend${PKGNAMESUFFIX}-${PORTVERSION}
DIST_SUBDIR= KDE
@@ -15,6 +14,8 @@ COMMENT= GStreamer backend for Phonon
LICENSE= LGPL21
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-backend//}
+
USES= cmake kde:4 pkgconfig tar:xz
USE_GL= gl
USE_GNOME= glib20 libxml2
diff --git a/multimedia/phonon-gstreamer/distinfo b/multimedia/phonon-gstreamer/distinfo
index d0a1351adf83..79a7b3fd7eeb 100644
--- a/multimedia/phonon-gstreamer/distinfo
+++ b/multimedia/phonon-gstreamer/distinfo
@@ -1,2 +1,3 @@
-SHA256 (KDE/phonon-backend-gstreamer-4.8.2.tar.xz) = 20e0f71f2beb4f859db8385079a13aef5473863ee6f27aad7b065aa7bfe931e0
-SIZE (KDE/phonon-backend-gstreamer-4.8.2.tar.xz) = 76044
+TIMESTAMP = 1472999348
+SHA256 (KDE/phonon-backend-gstreamer-4.9.0.tar.xz) = cec3e5ece1261d344b68363ef0606ebf49772628ba94bb55b0c0d18773b885f1
+SIZE (KDE/phonon-backend-gstreamer-4.9.0.tar.xz) = 75960
diff --git a/multimedia/phonon-gstreamer/files/patch-CMakeLists.txt b/multimedia/phonon-gstreamer/files/patch-CMakeLists.txt
deleted file mode 100644
index f82e7f0bea11..000000000000
--- a/multimedia/phonon-gstreamer/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- CMakeLists.txt.orig 2015-09-28 21:27:35.073619000 +0200
-+++ CMakeLists.txt 2015-09-28 21:44:28.823199000 +0200
-@@ -50,6 +50,7 @@
- macro_log_feature(LIBXML2_FOUND "LibXml2" "LibXml2 is required to compile the gstreamer backend for Phonon" "http://xmlsoft.org/downloads.html" TRUE)
-
-
-+add_definitions(${GSTREAMER_DEFINITIONS})
-
- add_subdirectory(gstreamer)
-
diff --git a/multimedia/phonon-gstreamer/pkg-plist b/multimedia/phonon-gstreamer/pkg-plist
index 38ca3188d241..bf3ee3915298 100644
--- a/multimedia/phonon-gstreamer/pkg-plist
+++ b/multimedia/phonon-gstreamer/pkg-plist
@@ -1,4 +1,5 @@
lib/kde4/plugins/phonon_backend/phonon_gstreamer.so
+%%QT_PLUGINDIR%%/phonon_backend/libphonon_gstreamer.so
share/icons/hicolor/128x128/apps/phonon-gstreamer.png
share/icons/hicolor/16x16/apps/phonon-gstreamer.png
share/icons/hicolor/22x22/apps/phonon-gstreamer.png
@@ -6,4 +7,3 @@ share/icons/hicolor/48x48/apps/phonon-gstreamer.png
share/icons/hicolor/64x64/apps/phonon-gstreamer.png
share/icons/hicolor/scalable/apps/phonon-gstreamer.svgz
share/kde4/services/phononbackends/gstreamer.desktop
-%%QT_PREFIX%%/%%QT_PLUGINDIR%%/phonon_backend/libphonon_gstreamer.so