aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-12-16 16:49:17 +0000
committerRene Ladan <rene@FreeBSD.org>2018-12-16 16:49:17 +0000
commit7cbe341ae63754f2ad63dd52f20d9d1b9b312aa5 (patch)
tree892baa84cc0c67b08795b6576e985d83e5a8f6d1 /multimedia/phonon
parent278e6c95a6bbd77f475d8bd167ba51814bb09fc0 (diff)
downloadports-7cbe341ae63754f2ad63dd52f20d9d1b9b312aa5.tar.gz
ports-7cbe341ae63754f2ad63dd52f20d9d1b9b312aa5.zip
Use regular DEPRECATED and EXPIRATION_DATE variables in an "if FLAVOR" block
instead of flavoring the variables themselves. This caused too much hassle for Tools/scripts/rmport. Discussed with: tcberner
Notes
Notes: svn path=/head/; revision=487601
Diffstat (limited to 'multimedia/phonon')
-rw-r--r--multimedia/phonon/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/multimedia/phonon/Makefile b/multimedia/phonon/Makefile
index 3159812f0663..3e3f3cdeb388 100644
--- a/multimedia/phonon/Makefile
+++ b/multimedia/phonon/Makefile
@@ -23,9 +23,6 @@ qt5_PKGNAMESUFFIX= -qt5
qt4_PLIST= ${.CURDIR}/pkg-plist.qt4
qt5_PLIST= ${.CURDIR}/pkg-plist.qt5
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= cmake compiler:c++11-lang pathfix tar:xz
CMAKE_ON= PHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT \
PHONON_NO_PLATFORMPLUGIN
@@ -33,6 +30,8 @@ CMAKE_OFF= PHONON_BUILD_DESIGNER_PLUGIN:BOOL=OFF
USE_LDCONFIG= yes
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= kde:4 qt:4
USE_KDE= automoc4
USE_QT= corelib dbus declarative gui testlib \