aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ptx-kmod/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2011-07-03 16:47:58 +0000
committerHiroki Sato <hrs@FreeBSD.org>2011-07-03 16:47:58 +0000
commit18774eff9a3aa03d67926ac77702062d179ec8e4 (patch)
tree56e025b3d2ebcd7ad412c90cf62ddb049424c650 /multimedia/ptx-kmod/Makefile
parent9eae4374f556fa873eca1d79e5eb214a420ccb74 (diff)
downloadports-18774eff9a3aa03d67926ac77702062d179ec8e4.tar.gz
ports-18774eff9a3aa03d67926ac77702062d179ec8e4.zip
Notes
Diffstat (limited to 'multimedia/ptx-kmod/Makefile')
-rw-r--r--multimedia/ptx-kmod/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/multimedia/ptx-kmod/Makefile b/multimedia/ptx-kmod/Makefile
new file mode 100644
index 000000000000..02fe442fa38c
--- /dev/null
+++ b/multimedia/ptx-kmod/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ptx-kmod
+# Date created: July 2 2011
+# Whom: hrs
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptx
+PORTVERSION= 0.0.20110326
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= hrs
+PKGNAMESUFFIX= -kmod
+DISTNAME= ${PORTNAME}-${PORTVERSION:S,0.0.,,}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Device driver for PT1/PT2 ISDB-S/T tuner cards
+
+LICENSE= GPLv3
+ONLY_FOR_ARCHS= amd64 i386
+BUILD_WRKSRC= ${WRKSRC}/dev/ptx
+MAKE_ENV= KMODDIR=${PREFIX}/${KMODDIR} SYSDIR=${SYSDIR}
+PLIST_FILES= ${KMODDIR}/ptx.ko
+PLIST_DIRS= ${KMODDIR}
+SUB_LIST= KMODDIR=${KMODDIR}
+USE_RC_SUBR= ptx.sh
+PORTDOCS= README
+
+KMODDIR= libexec/${PORTNAME}
+SYSDIR?= ${SRC_BASE}/sys
+
+.include <bsd.port.pre.mk>
+KERNCONF?= GENERIC
+
+# Use the first component of ${KERNCONF}.
+.for K in ${KERNCONF}
+_KERNCONF?=$K
+.endfor
+
+.if !exists(${SRC_BASE}/sys/${ARCH}/conf/${_KERNCONF})
+IGNORE= requires kernel source to be installed
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/${KMODDIR}
+ ${INSTALL_KLD} ${BUILD_WRKSRC}/ptx.ko ${PREFIX}/${KMODDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>