aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ptx-kmod
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
committerRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
commitbfc52e710421bd92466b329f6fbb9be930eb4755 (patch)
tree7436338612f22a81def9ee6c2d2e3826c1504ea4 /multimedia/ptx-kmod
parent16a624cb31062d141fd07c5dc3f7794ed7fe74cd (diff)
downloadports-bfc52e710421bd92466b329f6fbb9be930eb4755.tar.gz
ports-bfc52e710421bd92466b329f6fbb9be930eb4755.zip
Convert to USES=kmod, which removes duplicated code and ensures that all
required steps are followed. There are no user-visible changes. The exception is multimedia/ptx-kmod, which now installs the kernel module into /boot/modules instead of ${PREFIX}/libexec/${PORTNAME}, this was something USES=kmod cannot handle. PR: ports/183625 Submitted by: myself Approved by: portmgr (bdrewery) Exp-run by: bdrewery
Notes
Notes: svn path=/head/; revision=333329
Diffstat (limited to 'multimedia/ptx-kmod')
-rw-r--r--multimedia/ptx-kmod/Makefile26
-rw-r--r--multimedia/ptx-kmod/files/ptx.in2
2 files changed, 7 insertions, 21 deletions
diff --git a/multimedia/ptx-kmod/Makefile b/multimedia/ptx-kmod/Makefile
index 893d00c9ea15..abe5c71ed59e 100644
--- a/multimedia/ptx-kmod/Makefile
+++ b/multimedia/ptx-kmod/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ptx
PORTVERSION= 0.0.20111212
-CATEGORIES= multimedia kld
+CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= hrs
PKGNAMESUFFIX= -kmod
@@ -13,13 +13,12 @@ COMMENT= Device driver for PT1/PT2 ISDB-S/T tuner cards
LICENSE= GPLv3
-SSP_UNSAFE= kernel module does not support ssp
+#XXX rene: change KMODDIR from ${PREFIX}/libexec/${PORTNAME} to
+# the default /boot/modules to get directories right
ONLY_FOR_ARCHS= amd64 i386
BUILD_WRKSRC= ${WRKSRC}/dev/ptx
-MAKE_ENV= KMODDIR=${PREFIX}/${KMODDIR} SYSDIR=${SYSDIR}
PLIST_FILES= ${KMODDIR}/ptx.ko bin/recptx.pl
-PLIST_DIRS= ${KMODDIR}
SUB_LIST= KMODDIR=${KMODDIR}
USE_RC_SUBR= ptx
PORTDOCS= README
@@ -27,25 +26,12 @@ PORTDOCS= README
OPTIONS_DEFINE= DOCS
NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-KMODDIR= libexec/${PORTNAME}
-SYSDIR?= ${SRC_BASE}/sys
-
-KERNCONF?= GENERIC
-# Use the first component of ${KERNCONF}.
-.for K in ${KERNCONF}
-_KERNCONF?=$K
-.endfor
-
-.if !exists(${SRC_BASE}/sys/${ARCH}/conf/${_KERNCONF})
-IGNORE= requires kernel source to be installed
-.endif
+USES= kmod
+.include <bsd.port.pre.mk>
do-install:
- @${MKDIR} ${PREFIX}/${KMODDIR}
- ${INSTALL_KLD} ${BUILD_WRKSRC}/ptx.ko ${PREFIX}/${KMODDIR}
+ ${INSTALL_KLD} ${BUILD_WRKSRC}/ptx.ko ${KMODDIR}
${INSTALL_SCRIPT} ${WRKSRC}/tools/recptx.pl ${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
diff --git a/multimedia/ptx-kmod/files/ptx.in b/multimedia/ptx-kmod/files/ptx.in
index 498196bf256c..b9121b17c5b5 100644
--- a/multimedia/ptx-kmod/files/ptx.in
+++ b/multimedia/ptx-kmod/files/ptx.in
@@ -14,7 +14,7 @@ stop_cmd="ptx_stop"
ptx_start()
{
- load_kld %%PREFIX%%/%%KMODDIR%%/ptx.ko
+ load_kld %%KMODDIR%%/ptx.ko
}
ptx_stop()
{