aboutsummaryrefslogtreecommitdiff
path: root/multimedia/pwcbsd
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-11 12:58:40 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-11 12:58:40 +0000
commit6850c2351051c685e2d85b2cbd7dc7bb4525e7df (patch)
tree2ec79ba0438e788ff8ca417ef033f5706959398e /multimedia/pwcbsd
parent7d7e088c9d0165dc80ef649c781b4db1d536a00e (diff)
downloadports-6850c2351051c685e2d85b2cbd7dc7bb4525e7df.tar.gz
ports-6850c2351051c685e2d85b2cbd7dc7bb4525e7df.zip
Convert to new options framework
While here remove test for unsupported versions
Notes
Notes: svn path=/head/; revision=317872
Diffstat (limited to 'multimedia/pwcbsd')
-rw-r--r--multimedia/pwcbsd/Makefile30
1 files changed, 11 insertions, 19 deletions
diff --git a/multimedia/pwcbsd/Makefile b/multimedia/pwcbsd/Makefile
index f2387e3373e6..1a4f9b6abc07 100644
--- a/multimedia/pwcbsd/Makefile
+++ b/multimedia/pwcbsd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pwcbsd
-# Date created: 17 Feb 2006
-# Whom: Raaf <freebsd@luna.afraid.org>
-#
+# Created by: Raaf <freebsd@luna.afraid.org>
# $FreeBSD$
-#
PORTNAME= pwcbsd
PORTVERSION= 1.4.1
@@ -24,33 +20,29 @@ MAN4= pwc.4
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
-OPTIONS= PROGRAMS "Build the programs" on \
- MMAP "Enable mmap support (MAY CRASH YOUR SYSTEM)" off
+OPTIONS_DEFINE= PROGRAMS MMAP
+OPTIONS_DEFAULT= PROGRAMS
+PROGRAMS_DESC= Build the programs
+MMAP_DESC= Enable mmap support (MAY CRASH YOUR SYSTEM)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if (${OSVERSION} > 800063) && (${OSVERSION} < 800094)
-BROKEN= Please update to a newer version of FreeBSD 8
-.endif
-
-.if ${OSVERSION} >= 800094
EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.kld \
${FILESDIR}/extra-patch-pwc-ctrl.c \
${FILESDIR}/extra-patch-pwc-v4l.c \
${FILESDIR}/extra-patch-pwc.c \
${FILESDIR}/extra-patch-pwc.h
-.endif
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel source files
.endif
-.if defined(WITH_MMAP)
+.if ${PORT_OPTIONS:MMMAP}
ALL_TARGET= mmap
.else
ALL_TARGET= all
.endif
-.if !defined(WITHOUT_PROGRAMS)
+.if ${PORT_OPTIONS:MPROGRAMS}
ALL_TARGET+= pwcview
PROGRAMS= pwcview
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
@@ -62,16 +54,16 @@ PLIST_SUB+= PROGRAMS="@comment "
.endif
post-patch:
-.if !defined(WITHOUT_PROGRAMS)
+.if ${PORT_OPTIONS:MPROGRAMS}
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/Makefile
.endif
post-install:
${INSTALL_MAN} ${MAN4:S|^|${WRKSRC}/|} ${PREFIX}/man/man4
-.if !defined(WITHOUT_PROGRAMS)
+.if ${PORT_OPTIONS:MPROGRAMS}
${INSTALL_PROGRAM} ${PROGRAMS:S|^|${WRKSRC}/|} ${PREFIX}/bin
${INSTALL_MAN} ${MAN1:S|^|${WRKSRC}/|} ${PREFIX}/man/man1
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>