aboutsummaryrefslogtreecommitdiff
path: root/multimedia/py-periscope
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2011-08-27 02:39:08 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2011-08-27 02:39:08 +0000
commit23d5ac7afa69a1bf6181608081135676f92da148 (patch)
tree0736a12c59e2ce348d9ccbe286241f25ca45417c /multimedia/py-periscope
parentab54ce7d5d3aaef1ef3a07905043cc6078c0de97 (diff)
downloadports-23d5ac7afa69a1bf6181608081135676f92da148.tar.gz
ports-23d5ac7afa69a1bf6181608081135676f92da148.zip
Notes
Diffstat (limited to 'multimedia/py-periscope')
-rw-r--r--multimedia/py-periscope/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/multimedia/py-periscope/Makefile b/multimedia/py-periscope/Makefile
index 1aaa5a12eb08..2f60aff288ff 100644
--- a/multimedia/py-periscope/Makefile
+++ b/multimedia/py-periscope/Makefile
@@ -6,6 +6,7 @@
PORTNAME= periscope
PORTVERSION= 0.2.4
+PORTREVISION= 1
CATEGORIES= multimedia python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -23,10 +24,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=3.2.0:${PORTSDIR}/www/py-beau
BUILD_DEPENDS= ${RUN_DEPENDS}
USE_GNOME= desktopfileutils
-USE_PYTHON= yes
+USE_PYTHON= 2.6+
USE_PYDISTUTILS= easy_install
NO_WRKSUBDIR= yes
+OPTIONS= UNRAR "Enable support for rar (.rar) compressed subtitles" on
+
PLIST_SUB= DESKTOPDIR=${DESKTOPDIR_WITHOUT_PREFIX:Q}
DESKTOPDIR_WITHOUT_PREFIX= ${DESKTOPDIR:S,^${PREFIX}/,,}
@@ -37,4 +40,11 @@ post-install:
${DESKTOPDIR}
@-${LOCALBASE}/bin/update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# unrar (.rar) support
+.if !defined(WITHOUT_UNRAR)
+RUN_DEPENDS+= unrar:${PORTSDIR}/archivers/unrar
+.endif
+
+.include <bsd.port.post.mk>