aboutsummaryrefslogtreecommitdiff
path: root/multimedia/quodlibet
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /multimedia/quodlibet
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'multimedia/quodlibet')
-rw-r--r--multimedia/quodlibet/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/multimedia/quodlibet/Makefile b/multimedia/quodlibet/Makefile
index a28bdbcba040..980766a094dd 100644
--- a/multimedia/quodlibet/Makefile
+++ b/multimedia/quodlibet/Makefile
@@ -13,16 +13,16 @@ COMMENT= GTK+-based audio player written in Python
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}musicbrainzngs>=0.4:audio/py-musicbrainzngs \
- ${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}musicbrainzngs>=0.4:audio/py-musicbrainzngs@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen@${FLAVOR} \
${LOCALBASE}/libexec/notification-daemon:deskutils/notification-daemon
LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libwebkit2gtk-4.0.so:www/webkit2-gtk3
USE_PYTHON= distutils autoplist
USE_GNOME= gtk30 intltool pygobject3
-USES= desktop-file-utils display gettext python
+USES= desktop-file-utils display gettext python:2.7
PYDISTUTILS_INSTALLNOSINGLE= yes
USE_GSTREAMER1= good
@@ -49,10 +49,10 @@ WAVPACK_USE= GSTREAMER1=wavpack
AAC_LIB_DEPENDS= libmp4v2.so:multimedia/mp4v2
AAC_USE= GSTREAMER1=faad
-DBUS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus
-DBUS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus
+DBUS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${FLAVOR}
+DBUS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${FLAVOR}
-REMOTE_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>0:textproc/py-feedparser
-REMOTE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>0:textproc/py-feedparser
+REMOTE_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>0:textproc/py-feedparser@${FLAVOR}
+REMOTE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>0:textproc/py-feedparser@${FLAVOR}
.include <bsd.port.mk>