aboutsummaryrefslogtreecommitdiff
path: root/multimedia/recmpeg
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-02-02 13:07:45 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-02-02 13:07:45 +0000
commitd5baed084e8cd06181eb272013fcb7b206973b43 (patch)
treeddab8c483dccd167f2033ddd29525534c00c0560 /multimedia/recmpeg
parent6a789c1f78b36fbaca7e816b60d8ed84fa5ac150 (diff)
downloadports-d5baed084e8cd06181eb272013fcb7b206973b43.tar.gz
ports-d5baed084e8cd06181eb272013fcb7b206973b43.zip
Conditionalize gnugetopt dependencies.
PR: ports/47325 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=74476
Diffstat (limited to 'multimedia/recmpeg')
-rw-r--r--multimedia/recmpeg/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/multimedia/recmpeg/Makefile b/multimedia/recmpeg/Makefile
index b26843f659b8..2ba6dedd6605 100644
--- a/multimedia/recmpeg/Makefile
+++ b/multimedia/recmpeg/Makefile
@@ -14,13 +14,19 @@ MASTER_SITE_SUBDIR= fame
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- fame-0.9.0:${PORTSDIR}/graphics/libfame
+LIB_DEPENDS= fame-0.9.0:${PORTSDIR}/graphics/libfame
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= recmpeg.1
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LDFLAGS+= -lgnugetopt
+.endif
+
.include <bsd.port.mk>