aboutsummaryrefslogtreecommitdiff
path: root/multimedia/replex
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-01-20 04:45:05 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-01-20 04:45:05 +0000
commite638b9b3070aabe2aac00ac4897e75a99d159b9a (patch)
treeff0a496c920b861959c219beef804169c28bc104 /multimedia/replex
parent620e25eccd04edc620a6f1fcd1bfc0d7a684eb1e (diff)
downloadports-e638b9b3070aabe2aac00ac4897e75a99d159b9a.tar.gz
ports-e638b9b3070aabe2aac00ac4897e75a99d159b9a.zip
Replex was created to remultiplex transport stream (TS) data taken from a DVB
source. The result is supposed to be a program stream (PS) that can be used to be burned to a DVD (with dvdauthor). Replex can also remultiplex other PSs and AVIs with MPEG2 content. WWW: http://www.metzlerbros.org/dvb/
Notes
Notes: svn path=/head/; revision=98630
Diffstat (limited to 'multimedia/replex')
-rw-r--r--multimedia/replex/Makefile41
-rw-r--r--multimedia/replex/distinfo1
-rw-r--r--multimedia/replex/files/patch-Makefile29
-rw-r--r--multimedia/replex/files/patch-pes.c10
-rw-r--r--multimedia/replex/pkg-descr6
-rw-r--r--multimedia/replex/pkg-plist6
6 files changed, 93 insertions, 0 deletions
diff --git a/multimedia/replex/Makefile b/multimedia/replex/Makefile
new file mode 100644
index 000000000000..f044c0df8ba7
--- /dev/null
+++ b/multimedia/replex/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: replex
+# Date created: 20 Jan 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= replex
+PORTVERSION= 0.0.7
+CATEGORIES= multimedia
+MASTER_SITES= http://www.metzlerbros.org/dvb/
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Remultiplex an MPEG2 TS into a PS for DVD
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GETOPT_LONG= yes
+CFLAGS+= -I${LOCALBASE}/include -DO_LARGEFILE=0
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+TOFIX= avi.h element.h mpg_common.h pes.h replex.h ringbuffer.h \
+ replex.c ts.c
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libreplex.a ${PREFIX}/lib/
+ ${INSTALL_PROGRAM} ${WRKSRC}/replex ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}/
+.endif
+
+do-configure:
+.if !exists(/usr/include/stdint.h)
+.for i in ${TOFIX}
+ @${REINPLACE_CMD} -e 's|stdint.h|sys/types.h|g' ${WRKSRC}/${i}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/replex/distinfo b/multimedia/replex/distinfo
new file mode 100644
index 000000000000..8474f45255ed
--- /dev/null
+++ b/multimedia/replex/distinfo
@@ -0,0 +1 @@
+MD5 (replex-0.0.7.tar.gz) = 2600aba2bb40b391d6fc27d42ccef36f
diff --git a/multimedia/replex/files/patch-Makefile b/multimedia/replex/files/patch-Makefile
new file mode 100644
index 000000000000..015b722c4a5e
--- /dev/null
+++ b/multimedia/replex/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig Sun Dec 28 17:57:19 2003
++++ Makefile Tue Jan 20 05:17:32 2004
+@@ -2,7 +2,7 @@
+ DISTNAME = replex-$(VERSION)
+ TARNAME = $(DISTNAME).tar.gz
+ INCS = -I..
+-CFLAGS = -g -Wall -O2 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
++CFLAGS += -g -Wall -O2 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ LIBS = -L.
+ MFLAG = -M
+ OBJS = element.o pes.o mpg_common.o ts.o ringbuffer.o avi.o multiplex.o
+@@ -26,7 +26,7 @@
+ ar -rcs libreplex.a $(OBJS)
+
+ replex: libreplex.a replex.o
+- $(CC) -o replex replex.o -L. -lreplex
++ $(CC) $(LDFLAGS) -o replex replex.o -L. -lreplex
+
+ dist: $(SRC) $(HEADERS) Makefile
+ mkdir $(DISTNAME)
+@@ -47,7 +47,7 @@
+
+
+ .depend:
+- $(CC) $(DEFINES) $(MFLAG) $(SRC) $(CSRC) $(CPPSRC) $(INCS)> .depend
++ $(CC) $(CFLAGS) $(DEFINES) $(MFLAG) $(SRC) $(CSRC) $(CPPSRC) $(INCS)> .depend
+
+
+
diff --git a/multimedia/replex/files/patch-pes.c b/multimedia/replex/files/patch-pes.c
new file mode 100644
index 000000000000..4c95f268a38b
--- /dev/null
+++ b/multimedia/replex/files/patch-pes.c
@@ -0,0 +1,10 @@
+--- pes.c.orig Sun Dec 28 17:57:19 2003
++++ pes.c Tue Jan 20 05:15:09 2004
+@@ -26,6 +26,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <string.h>
+
diff --git a/multimedia/replex/pkg-descr b/multimedia/replex/pkg-descr
new file mode 100644
index 000000000000..a786185bafd5
--- /dev/null
+++ b/multimedia/replex/pkg-descr
@@ -0,0 +1,6 @@
+Replex was created to remultiplex transport stream (TS) data taken from a DVB
+source. The result is supposed to be a program stream (PS) that can be
+used to be burned to a DVD (with dvdauthor).
+Replex can also remultiplex other PSs and AVIs with MPEG2 content.
+
+WWW: http://www.metzlerbros.org/dvb/
diff --git a/multimedia/replex/pkg-plist b/multimedia/replex/pkg-plist
new file mode 100644
index 000000000000..9030576877ac
--- /dev/null
+++ b/multimedia/replex/pkg-plist
@@ -0,0 +1,6 @@
+bin/replex
+lib/libreplex.a
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%