aboutsummaryrefslogtreecommitdiff
path: root/multimedia/schroedinger
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-25 18:44:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-25 18:44:57 +0000
commite33f156926d78f19fc679b34595db08635b08b86 (patch)
tree13f4c343677821b5d1da6cfa4a27e7bb257ad3ac /multimedia/schroedinger
parenta09e2de7df712ed16c18f49fcaafd95b5e9bd3fa (diff)
downloadports-e33f156926d78f19fc679b34595db08635b08b86.tar.gz
ports-e33f156926d78f19fc679b34595db08635b08b86.zip
- Add gstreamer support & fix build when gstreamer is present
PR: 127624 Submitted by: "Eric L. Chen" <d9364104 at mail dot nchu dot edu dot tw> Improved by: me
Notes
Notes: svn path=/head/; revision=220771
Diffstat (limited to 'multimedia/schroedinger')
-rw-r--r--multimedia/schroedinger/Makefile16
-rw-r--r--multimedia/schroedinger/pkg-plist6
2 files changed, 20 insertions, 2 deletions
diff --git a/multimedia/schroedinger/Makefile b/multimedia/schroedinger/Makefile
index 76844f2ea4a1..283c88af5c38 100644
--- a/multimedia/schroedinger/Makefile
+++ b/multimedia/schroedinger/Makefile
@@ -7,6 +7,7 @@
PORTNAME= schroedinger
PORTVERSION= 1.0.5
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://www.diracvideo.org/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,8 +19,21 @@ LIB_DEPENDS= oil:${PORTSDIR}/devel/liboil
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+WANT_GSTREAMER= yes
+
+OPTIONS= GSTREAMER "Enable gstreamer plugin" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GSTREAMER)
+CONFIGURE_ARGS+= --disable-gstreamer
+PLIST_SUB+= GSTREAMER="@comment "
+.else
+USE_GSTREAMER= yes
+PLIST_SUB+= GSTREAMER=""
+.endif
post-patch:
${REINPLACE_CMD} -e 's|^pkgconfigdir=.*|pkgconfigdir="\\$$(prefix)/libdata/pkgconfig"|' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/schroedinger/pkg-plist b/multimedia/schroedinger/pkg-plist
index a1b4905bd635..67dcc42e7849 100644
--- a/multimedia/schroedinger/pkg-plist
+++ b/multimedia/schroedinger/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
include/schroedinger-1.0/schroedinger/schro-stdint.h
include/schroedinger-1.0/schroedinger/schro.h
include/schroedinger-1.0/schroedinger/schroanalysis.h
@@ -37,6 +36,9 @@ lib/libschroedinger-1.0.a
lib/libschroedinger-1.0.la
lib/libschroedinger-1.0.so
lib/libschroedinger-1.0.so.1
+%%GSTREAMER%%lib/gstreamer-0.10/libgstschro.a
+%%GSTREAMER%%lib/gstreamer-0.10/libgstschro.la
+%%GSTREAMER%%lib/gstreamer-0.10/libgstschro.so
libdata/pkgconfig/schroedinger-1.0.pc
share/gtk-doc/html/schroedinger/home.png
share/gtk-doc/html/schroedinger/index.html
@@ -78,5 +80,7 @@ share/gtk-doc/html/schroedinger/schropublic.html
share/gtk-doc/html/schroedinger/style.css
share/gtk-doc/html/schroedinger/up.png
@dirrm share/gtk-doc/html/schroedinger
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
@dirrm include/schroedinger-1.0/schroedinger
@dirrm include/schroedinger-1.0