aboutsummaryrefslogtreecommitdiff
path: root/multimedia/shotcut
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-23 08:24:57 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-23 08:24:57 +0000
commit318761fb183a1a958fa81871adb78965ba01a8ee (patch)
tree684ac2d9ba8e743003a9a716a0b7a163e0190ee0 /multimedia/shotcut
parent9b9d61c39605f856851b8f6ae0ef6f638ab3739e (diff)
downloadports-318761fb183a1a958fa81871adb78965ba01a8ee.tar.gz
ports-318761fb183a1a958fa81871adb78965ba01a8ee.zip
multimedia/shotcut: update to 21.03.21
From ChangeLog: https://shotcut.org/blog/new-release-210321/ * Fixed <tractor> and blank considered missing and blocking export * Added an Ignore button to the missing files error dialog in Export. * Fixed black frames appearing in Slideshow Generator * Fixed being able to use mouse wheel over Timeline and Keyframes zoom sliders * Improved sound quality with small changes in Speed with Pitch Compensation or Pitch audio filter (broke in v20.11). * Fixed the Timeline clip audio waveform incorrect after adding transition by dragging the clip left. * Fixed repairing a project file opened using a network path on Windows. * Fixed writing a raw FLAC file does not set its duration. * Fixed an elided file name in clip Properties can become the clip name. Deleteing patch integrated upstream: https://github.com/mltframework/shotcut/pull/1050 Reported by: portscout
Notes
Notes: svn path=/head/; revision=569012
Diffstat (limited to 'multimedia/shotcut')
-rw-r--r--multimedia/shotcut/Makefile2
-rw-r--r--multimedia/shotcut/distinfo6
-rw-r--r--multimedia/shotcut/files/patch-src_util.cpp22
3 files changed, 4 insertions, 26 deletions
diff --git a/multimedia/shotcut/Makefile b/multimedia/shotcut/Makefile
index d99827b15af8..de590f3da34d 100644
--- a/multimedia/shotcut/Makefile
+++ b/multimedia/shotcut/Makefile
@@ -22,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= mltframework
# Needed to be able to correctly check for updates in-app.
-FULLVERSION= 21.02.27
+FULLVERSION= 21.03.21
USE_GL+= gl
USE_QT= buildtools_build concurrent_build core declarative \
diff --git a/multimedia/shotcut/distinfo b/multimedia/shotcut/distinfo
index cfb62bf1f490..acc51bc72c3b 100644
--- a/multimedia/shotcut/distinfo
+++ b/multimedia/shotcut/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1614514351
-SHA256 (mltframework-shotcut-v21.02.27_GH0.tar.gz) = 5ca5a5fb4b13a9da72a1bcff665af5c55fff2516bc90850d128c282d1f4296e9
-SIZE (mltframework-shotcut-v21.02.27_GH0.tar.gz) = 4101402
+TIMESTAMP = 1616401712
+SHA256 (mltframework-shotcut-v21.03.21_GH0.tar.gz) = be668454896c540746a3d27c42c858d7652399722c7ec073c7cd3e52d7578ccd
+SIZE (mltframework-shotcut-v21.03.21_GH0.tar.gz) = 4101401
diff --git a/multimedia/shotcut/files/patch-src_util.cpp b/multimedia/shotcut/files/patch-src_util.cpp
deleted file mode 100644
index c99c1e5e9e3b..000000000000
--- a/multimedia/shotcut/files/patch-src_util.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/util.cpp.orig 2021-02-27 02:57:47 UTC
-+++ src/util.cpp
-@@ -480,6 +480,19 @@ bool Util::isMemoryLow()
- }
- }
- return false;
-+#elif defined(__FreeBSD__)
-+ QProcess p;
-+ p.start("sysctl -n hw.usermem");
-+ p.waitForFinished();
-+ auto lines = p.readAllStandardOutput();
-+ p.close();
-+ bool ok = false;
-+ auto availableKB = lines.toUInt(&ok);
-+ if (ok) {
-+ return availableKB < kLowMemoryThresholdKB;
-+ }
-+
-+ return false;
- #elif defined(Q_OS_LINUX)
- unsigned int availableKB = UINT_MAX;
- QFile meminfo("/proc/meminfo");