aboutsummaryrefslogtreecommitdiff
path: root/multimedia/shotcut
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-03 11:00:00 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-03 11:00:00 +0000
commit5ee90b005fb518b455fe2c5ea3bc4e22d0e68cbd (patch)
tree3b00264e0513b47205d3637a1afa0b083debe456 /multimedia/shotcut
parente2e8411abb3dce785daad30bf8e08d4880cc5e31 (diff)
downloadports-5ee90b005fb518b455fe2c5ea3bc4e22d0e68cbd.tar.gz
ports-5ee90b005fb518b455fe2c5ea3bc4e22d0e68cbd.zip
multimedia/shotcut: update to 21.02.27
Notes
Notes: svn path=/head/; revision=567061
Diffstat (limited to 'multimedia/shotcut')
-rw-r--r--multimedia/shotcut/Makefile4
-rw-r--r--multimedia/shotcut/distinfo6
-rw-r--r--multimedia/shotcut/files/patch-src_spatialmedia_constants.h11
-rw-r--r--multimedia/shotcut/files/patch-src_util.cpp22
-rw-r--r--multimedia/shotcut/pkg-plist52
5 files changed, 37 insertions, 58 deletions
diff --git a/multimedia/shotcut/Makefile b/multimedia/shotcut/Makefile
index df58d0670ac6..d99827b15af8 100644
--- a/multimedia/shotcut/Makefile
+++ b/multimedia/shotcut/Makefile
@@ -22,12 +22,12 @@ USE_GITHUB= yes
GH_ACCOUNT= mltframework
# Needed to be able to correctly check for updates in-app.
-FULLVERSION= 20.10.31
+FULLVERSION= 21.02.27
USE_GL+= gl
USE_QT= buildtools_build concurrent_build core declarative \
graphicaleffects_run gui multimedia network opengl \
- printsupport quickcontrols_run sql \
+ printsupport quickcontrols2 sql \
sql-sqlite3_run webkit websockets widgets x11extras xml \
linguisttools_build
USE_SDL= sdl2
diff --git a/multimedia/shotcut/distinfo b/multimedia/shotcut/distinfo
index e7aa12e3eae6..cfb62bf1f490 100644
--- a/multimedia/shotcut/distinfo
+++ b/multimedia/shotcut/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604318101
-SHA256 (mltframework-shotcut-v20.10.31_GH0.tar.gz) = f18580f1bd725a55c285c622982d9c947e295c9fc81911697f3cce69f806c0dc
-SIZE (mltframework-shotcut-v20.10.31_GH0.tar.gz) = 5735908
+TIMESTAMP = 1614514351
+SHA256 (mltframework-shotcut-v21.02.27_GH0.tar.gz) = 5ca5a5fb4b13a9da72a1bcff665af5c55fff2516bc90850d128c282d1f4296e9
+SIZE (mltframework-shotcut-v21.02.27_GH0.tar.gz) = 4101402
diff --git a/multimedia/shotcut/files/patch-src_spatialmedia_constants.h b/multimedia/shotcut/files/patch-src_spatialmedia_constants.h
deleted file mode 100644
index 02a9dd0c6aeb..000000000000
--- a/multimedia/shotcut/files/patch-src_spatialmedia_constants.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/spatialmedia/constants.h.orig 2020-12-28 20:21:17 UTC
-+++ src/spatialmedia/constants.h
-@@ -36,6 +36,8 @@
- # define le64toh(x) qFromLittleEndian(x)
- #elif !defined(__FreeBSD__)
- # include <endian.h>
-+#elif defined(__FreeBSD__)
-+# include <sys/endian.h>
- #endif
-
- struct AudioMetadata {
diff --git a/multimedia/shotcut/files/patch-src_util.cpp b/multimedia/shotcut/files/patch-src_util.cpp
new file mode 100644
index 000000000000..c99c1e5e9e3b
--- /dev/null
+++ b/multimedia/shotcut/files/patch-src_util.cpp
@@ -0,0 +1,22 @@
+--- src/util.cpp.orig 2021-02-27 02:57:47 UTC
++++ src/util.cpp
+@@ -480,6 +480,19 @@ bool Util::isMemoryLow()
+ }
+ }
+ return false;
++#elif defined(__FreeBSD__)
++ QProcess p;
++ p.start("sysctl -n hw.usermem");
++ p.waitForFinished();
++ auto lines = p.readAllStandardOutput();
++ p.close();
++ bool ok = false;
++ auto availableKB = lines.toUInt(&ok);
++ if (ok) {
++ return availableKB < kLowMemoryThresholdKB;
++ }
++
++ return false;
+ #elif defined(Q_OS_LINUX)
+ unsigned int availableKB = UINT_MAX;
+ QFile meminfo("/proc/meminfo");
diff --git a/multimedia/shotcut/pkg-plist b/multimedia/shotcut/pkg-plist
index 89d442881282..2c4f6ab75587 100644
--- a/multimedia/shotcut/pkg-plist
+++ b/multimedia/shotcut/pkg-plist
@@ -3,7 +3,7 @@ share/applications/org.shotcut.Shotcut.desktop
share/icons/hicolor/128x128/apps/org.shotcut.Shotcut.png
share/icons/hicolor/64x64/apps/org.shotcut.Shotcut.png
share/man/man1/shotcut.1.gz
-share/metainfo/org.shotcut.Shotcut.appdata.xml
+share/metainfo/org.shotcut.Shotcut.metainfo.xml
share/mime/packages/org.shotcut.Shotcut.xml
%%DATADIR%%/qml/export-edl/export-edl.js
%%DATADIR%%/qml/export-edl/main.js
@@ -139,6 +139,8 @@ share/mime/packages/org.shotcut.Shotcut.xml
%%DATADIR%%/qml/filters/fadeout_movit/ui.qml
%%DATADIR%%/qml/filters/flip/meta.qml
%%DATADIR%%/qml/filters/flip/meta_movit.qml
+%%DATADIR%%/qml/filters/fspp/meta.qml
+%%DATADIR%%/qml/filters/fspp/ui.qml
%%DATADIR%%/qml/filters/glitch/meta.qml
%%DATADIR%%/qml/filters/glitch/ui.qml
%%DATADIR%%/qml/filters/glow/meta_frei0r.qml
@@ -178,6 +180,7 @@ share/mime/packages/org.shotcut.Shotcut.xml
%%DATADIR%%/qml/filters/mask_alphaspot/meta.qml
%%DATADIR%%/qml/filters/mask_alphaspot/ui.qml
%%DATADIR%%/qml/filters/mask_apply/meta.qml
+%%DATADIR%%/qml/filters/mask_apply/ui.qml
%%DATADIR%%/qml/filters/mask_shape/meta.qml
%%DATADIR%%/qml/filters/mask_shape/ui.qml
%%DATADIR%%/qml/filters/mirror/meta.qml
@@ -205,10 +208,6 @@ share/mime/packages/org.shotcut.Shotcut.xml
%%DATADIR%%/qml/filters/pillar_echo/vui.qml
%%DATADIR%%/qml/filters/posterize/meta.qml
%%DATADIR%%/qml/filters/posterize/ui.qml
-%%DATADIR%%/qml/filters/rectangle/meta.qml
-%%DATADIR%%/qml/filters/rectangle/rectangle.qml
-%%DATADIR%%/qml/filters/rectangle/ui.qml
-%%DATADIR%%/qml/filters/rectangle/vui.qml
%%DATADIR%%/qml/filters/rgbsplit0r/meta.qml
%%DATADIR%%/qml/filters/rgbsplit0r/ui.qml
%%DATADIR%%/qml/filters/richtext/meta.qml
@@ -276,45 +275,16 @@ share/mime/packages/org.shotcut.Shotcut.xml
%%DATADIR%%/qml/filters/waveform/meta.qml
%%DATADIR%%/qml/filters/waveform/ui.qml
%%DATADIR%%/qml/filters/waveform/vui.qml
-%%DATADIR%%/qml/filters/webvfx_choppy/choppy.html
-%%DATADIR%%/qml/filters/webvfx_choppy/meta.qml
-%%DATADIR%%/qml/filters/webvfx_choppy/ui.qml
-%%DATADIR%%/qml/filters/webvfx_circular_frame/filter-demo.html
-%%DATADIR%%/qml/filters/webvfx_circular_frame/meta.qml
-%%DATADIR%%/qml/filters/webvfx_circular_frame/ui.qml
-%%DATADIR%%/qml/filters/webvfx_clip/filter-clip.html
-%%DATADIR%%/qml/filters/webvfx_clip/meta.qml
-%%DATADIR%%/qml/filters/webvfx_clip/ui.qml
-%%DATADIR%%/qml/filters/webvfx_clip/vui.qml
-%%DATADIR%%/qml/filters/webvfx_ruttetraizer/meta.qml
-%%DATADIR%%/qml/filters/webvfx_ruttetraizer/ruttetraizer.html
-%%DATADIR%%/qml/filters/webvfx_ruttetraizer/three.js
-%%DATADIR%%/qml/filters/webvfx_ruttetraizer/ui.qml
-%%DATADIR%%/qml/filters/webvfx_swirl/meta.qml
-%%DATADIR%%/qml/filters/webvfx_swirl/shaderkit.js
-%%DATADIR%%/qml/filters/webvfx_swirl/swirl.html
-%%DATADIR%%/qml/filters/webvfx_swirl/ui.qml
-%%DATADIR%%/qml/filters/webvfx_threejs_text/Detector.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/GeometryUtils.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/gentilis_bold.typeface.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/gentilis_regular.typeface.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/helvetiker_bold.typeface.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/helvetiker_regular.typeface.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/liberation_sans_bold.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/liberation_sans_regular.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/liberation_serif_bold.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/liberation_serif_regular.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/optimer_bold.typeface.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/fonts/optimer_regular.typeface.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/meta.qml
-%%DATADIR%%/qml/filters/webvfx_threejs_text/three.min.js
-%%DATADIR%%/qml/filters/webvfx_threejs_text/threejs_text.html
-%%DATADIR%%/qml/filters/webvfx_threejs_text/ui.qml
%%DATADIR%%/qml/filters/white/meta_frei0r.qml
%%DATADIR%%/qml/filters/white/meta_movit.qml
%%DATADIR%%/qml/filters/white/ui.qml
+%%DATADIR%%/qml/modules/Shotcut/Controls/Button.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/ColorPicker.qml
+%%DATADIR%%/qml/modules/Shotcut/Controls/ComboBox.qml
+%%DATADIR%%/qml/modules/Shotcut/Controls/DoubleSpinBox.qml
+%%DATADIR%%/qml/modules/Shotcut/Controls/Gauge.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/GradientControl.qml
+%%DATADIR%%/qml/modules/Shotcut/Controls/HoverTip.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/KeyframableFilter.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/KeyframesButton.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/Preset.qml
@@ -326,8 +296,7 @@ share/mime/packages/org.shotcut.Shotcut.xml
%%DATADIR%%/qml/modules/Shotcut/Controls/TextFilterVui.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/TimeSpinner.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/ToggleButton.qml
-%%DATADIR%%/qml/modules/Shotcut/Controls/ToolBarToggle.qml
-%%DATADIR%%/qml/modules/Shotcut/Controls/ToolTip.qml
+%%DATADIR%%/qml/modules/Shotcut/Controls/ToolButton.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/UndoButton.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/VuiBase.qml
%%DATADIR%%/qml/modules/Shotcut/Controls/qmldir
@@ -344,7 +313,6 @@ share/mime/packages/org.shotcut.Shotcut.xml
%%DATADIR%%/qml/views/keyframes/Parameter.qml
%%DATADIR%%/qml/views/keyframes/ParameterHead.qml
%%DATADIR%%/qml/views/keyframes/Ruler.qml
-%%DATADIR%%/qml/views/keyframes/ToggleButton.qml
%%DATADIR%%/qml/views/keyframes/ZoomSlider.qml
%%DATADIR%%/qml/views/keyframes/keyframes.qml
%%DATADIR%%/qml/views/timeline/Clip.qml