aboutsummaryrefslogtreecommitdiff
path: root/multimedia/shotcut
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-12-28 20:49:01 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-12-28 20:49:01 +0000
commitaabe581f95bb35e7c6d33f6bb8072b5a2bff1151 (patch)
treea2bf3b5eb3c586d8d7feebd303a3c2b2b4c09ad2 /multimedia/shotcut
parent709be67d4501e5f70125cefe056f389817deeeae (diff)
downloadports-aabe581f95bb35e7c6d33f6bb8072b5a2bff1151.tar.gz
ports-aabe581f95bb35e7c6d33f6bb8072b5a2bff1151.zip
multimedia/shotcut: fix build on big-endian
Also remove unnecessary post-patch: Warning: Possible REINPLACE_CMD issues: - - REINPLACE_CMD ran, but did not modify file contents: src/jobs/meltjob.cpp
Notes
Notes: svn path=/head/; revision=559525
Diffstat (limited to 'multimedia/shotcut')
-rw-r--r--multimedia/shotcut/Makefile5
-rw-r--r--multimedia/shotcut/files/patch-src_spatialmedia_constants.h11
2 files changed, 12 insertions, 4 deletions
diff --git a/multimedia/shotcut/Makefile b/multimedia/shotcut/Makefile
index 08ee2dc31931..df58d0670ac6 100644
--- a/multimedia/shotcut/Makefile
+++ b/multimedia/shotcut/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libmlt.so:multimedia/mlt
RUN_DEPENDS= ffmpeg:multimedia/ffmpeg \
${LOCALBASE}/lib/libjack.so:audio/jack
-USES= desktop-file-utils gl pkgconfig \
+USES= compiler:c++11-lang desktop-file-utils gl pkgconfig \
qmake qt:5 sdl shared-mime-info \
xorg
@@ -46,9 +46,6 @@ LADSPA_RUN_DEPENDS= swhplugins>=0:audio/swhplugins
WEBVFX_RUN_DEPENDS= ${LOCALBASE}/lib/mlt/libmltwebvfx.so:multimedia/webvfx-qt5
-post-patch:
- @${REINPLACE_CMD} -e 's/"qmelt"/"melt"/' ${WRKSRC}/src/jobs/meltjob.cpp
-
pre-build:
@${FIND} ${WRKSRC} -name '.depend' -delete
diff --git a/multimedia/shotcut/files/patch-src_spatialmedia_constants.h b/multimedia/shotcut/files/patch-src_spatialmedia_constants.h
new file mode 100644
index 000000000000..02a9dd0c6aeb
--- /dev/null
+++ b/multimedia/shotcut/files/patch-src_spatialmedia_constants.h
@@ -0,0 +1,11 @@
+--- src/spatialmedia/constants.h.orig 2020-12-28 20:21:17 UTC
++++ src/spatialmedia/constants.h
+@@ -36,6 +36,8 @@
+ # define le64toh(x) qFromLittleEndian(x)
+ #elif !defined(__FreeBSD__)
+ # include <endian.h>
++#elif defined(__FreeBSD__)
++# include <sys/endian.h>
+ #endif
+
+ struct AudioMetadata {