aboutsummaryrefslogtreecommitdiff
path: root/multimedia/simplescreenrecorder
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-11 08:08:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-11 08:08:16 +0000
commit0ee05daf613ea037b93b43b1a4d00209dddef65f (patch)
tree382fc5a418964b8b40b4b0e4288ff19367a48b9f /multimedia/simplescreenrecorder
parentad0b4f5ea49c59b81d8b44f1d55a313a421fab57 (diff)
downloadports-0ee05daf613ea037b93b43b1a4d00209dddef65f.tar.gz
ports-0ee05daf613ea037b93b43b1a4d00209dddef65f.zip
Notes
Diffstat (limited to 'multimedia/simplescreenrecorder')
-rw-r--r--multimedia/simplescreenrecorder/Makefile42
-rw-r--r--multimedia/simplescreenrecorder/distinfo3
-rw-r--r--multimedia/simplescreenrecorder/files/patch-glinject_Hook.cpp11
-rw-r--r--multimedia/simplescreenrecorder/files/patch-glinject_Makefile.in11
-rw-r--r--multimedia/simplescreenrecorder/files/patch-scripts_ssr-glinject8
-rw-r--r--multimedia/simplescreenrecorder/pkg-descr24
-rw-r--r--multimedia/simplescreenrecorder/pkg-plist87
7 files changed, 186 insertions, 0 deletions
diff --git a/multimedia/simplescreenrecorder/Makefile b/multimedia/simplescreenrecorder/Makefile
new file mode 100644
index 000000000000..092cfc14f707
--- /dev/null
+++ b/multimedia/simplescreenrecorder/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= simplescreenrecorder
+DISTVERSION= 0.3.8-26
+DISTVERSIONSUFFIX= -g0f6eebf
+CATEGORIES= multimedia
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Screen video recorder
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libavformat.so:multimedia/ffmpeg
+
+USES= gmake localbase libtool pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= MaartenBaert
+GH_PROJECT= ssr
+USE_GL= gl glu
+USE_QT4= corelib gui moc_build rcc_build uic_build linguisttools_build
+USE_XORG= x11 xext xfixes xi
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-assert
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= PULSEAUDIO JACK
+OPTIONS_DEFAULT= PULSEAUDIO
+PULSEAUDIO_CONFIGURE_WITH= pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+JACK_CONFIGURE_WITH= jack
+JACK_LIB_DEPENDS= libjack.so:audio/jack
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|-ldl([". ])|-lc\1|g' \
+ -e 's|-ldl$$|-lc|g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/multimedia/simplescreenrecorder/distinfo b/multimedia/simplescreenrecorder/distinfo
new file mode 100644
index 000000000000..0286bcd7459c
--- /dev/null
+++ b/multimedia/simplescreenrecorder/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509824652
+SHA256 (MaartenBaert-ssr-0.3.8-26-g0f6eebf_GH0.tar.gz) = 168782672ce04bd68cb65254c7a6bb22337559149e3dfad4b5dbc6158e70c53e
+SIZE (MaartenBaert-ssr-0.3.8-26-g0f6eebf_GH0.tar.gz) = 2188599
diff --git a/multimedia/simplescreenrecorder/files/patch-glinject_Hook.cpp b/multimedia/simplescreenrecorder/files/patch-glinject_Hook.cpp
new file mode 100644
index 000000000000..66db6151a5f9
--- /dev/null
+++ b/multimedia/simplescreenrecorder/files/patch-glinject_Hook.cpp
@@ -0,0 +1,11 @@
+--- glinject/Hook.cpp.orig 2017-07-25 22:43:33 UTC
++++ glinject/Hook.cpp
+@@ -15,6 +15,8 @@ THE SOFTWARE IS PROVIDED "AS IS" AND THE
+ #include <GL/glx.h>
+ #include <X11/X.h>
+
++extern char **environ;
++
+ typedef void (*GLXextFuncPtr)(void);
+
+ void InitGLInject();
diff --git a/multimedia/simplescreenrecorder/files/patch-glinject_Makefile.in b/multimedia/simplescreenrecorder/files/patch-glinject_Makefile.in
new file mode 100644
index 000000000000..170561f1ccb0
--- /dev/null
+++ b/multimedia/simplescreenrecorder/files/patch-glinject_Makefile.in
@@ -0,0 +1,11 @@
+--- glinject/Makefile.in.orig 2017-08-02 06:41:19 UTC
++++ glinject/Makefile.in
+@@ -375,7 +375,7 @@ top_srcdir = @top_srcdir@
+ @ENABLE_GLINJECTLIB_TRUE@ $(am__append_1)
+ @ENABLE_GLINJECTLIB_TRUE@libssr_glinject_la_CFLAGS = -pthread -fPIC
+ @ENABLE_GLINJECTLIB_TRUE@libssr_glinject_la_CXXFLAGS = -pthread -fPIC -std=c++0x
+-@ENABLE_GLINJECTLIB_TRUE@libssr_glinject_la_LDFLAGS = -pthread -fPIC -avoid-version -shared -lrt -ldl -lGL -lGLU -lX11 -lXfixes
++@ENABLE_GLINJECTLIB_TRUE@libssr_glinject_la_LDFLAGS = -pthread -fPIC -avoid-version -shared -lrt -lGL -lGLU -lX11 -lXfixes
+ @ENABLE_GLINJECTLIB_TRUE@libssr_glinject_la_SOURCES = \
+ @ENABLE_GLINJECTLIB_TRUE@ elfhacks.c \
+ @ENABLE_GLINJECTLIB_TRUE@ elfhacks.h \
diff --git a/multimedia/simplescreenrecorder/files/patch-scripts_ssr-glinject b/multimedia/simplescreenrecorder/files/patch-scripts_ssr-glinject
new file mode 100644
index 000000000000..cdfa6682d5ff
--- /dev/null
+++ b/multimedia/simplescreenrecorder/files/patch-scripts_ssr-glinject
@@ -0,0 +1,8 @@
+--- scripts/ssr-glinject.orig 2017-07-25 22:43:33 UTC
++++ scripts/ssr-glinject
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ set -e
+
diff --git a/multimedia/simplescreenrecorder/pkg-descr b/multimedia/simplescreenrecorder/pkg-descr
new file mode 100644
index 000000000000..7390d2b7e2f5
--- /dev/null
+++ b/multimedia/simplescreenrecorder/pkg-descr
@@ -0,0 +1,24 @@
+A program that can record programs and games.
+
+Features:
+* Graphical user interface (Qt-based).
+* Faster than VLC and ffmpeg/avconv.
+* Records the entire screen or part of it, or records OpenGL
+ applications directly (similar to Fraps on Windows).
+* Synchronizes audio and video properly (a common issue with
+ VLC and ffmpeg/avconv).
+* Reduces the video frame rate if your computer is too slow
+ (rather than using up all your RAM like VLC does).
+* Fully multithreaded: small delays in any of the components
+ will never block the other components, resulting is smoother
+ video and better performance on computers with multiple processors.
+* Pause and resume recording at any time (either by clicking
+ a button or by pressing a hotkey).
+* Shows statistics during recording (file size, bit rate, total
+ recording time, actual frame rate, ...).
+* Can show a preview during recording, so you don't waste time
+ recording something only to figure out afterwards that some setting was wrong.
+* Supports many different codecs and file formats (adding more is trivial).
+* Can also do live streaming (experimental).
+
+WWW: http://www.maartenbaert.be/simplescreenrecorder/
diff --git a/multimedia/simplescreenrecorder/pkg-plist b/multimedia/simplescreenrecorder/pkg-plist
new file mode 100644
index 000000000000..d7b398baf371
--- /dev/null
+++ b/multimedia/simplescreenrecorder/pkg-plist
@@ -0,0 +1,87 @@
+bin/simplescreenrecorder
+bin/ssr-glinject
+lib/libssr-glinject.so
+man/man1/simplescreenrecorder.1.gz
+man/man1/ssr-glinject.1.gz
+share/appdata/simplescreenrecorder.appdata.xml
+share/applications/simplescreenrecorder.desktop
+share/icons/hicolor/128x128/apps/simplescreenrecorder-error.png
+share/icons/hicolor/128x128/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/128x128/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/128x128/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/128x128/apps/simplescreenrecorder.png
+share/icons/hicolor/16x16/apps/simplescreenrecorder-error.png
+share/icons/hicolor/16x16/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/16x16/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/16x16/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/16x16/apps/simplescreenrecorder.png
+share/icons/hicolor/192x192/apps/simplescreenrecorder-error.png
+share/icons/hicolor/192x192/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/192x192/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/192x192/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/192x192/apps/simplescreenrecorder.png
+share/icons/hicolor/22x22/apps/simplescreenrecorder-error.png
+share/icons/hicolor/22x22/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/22x22/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/22x22/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/22x22/apps/simplescreenrecorder.png
+share/icons/hicolor/24x24/apps/simplescreenrecorder-error.png
+share/icons/hicolor/24x24/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/24x24/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/24x24/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/24x24/apps/simplescreenrecorder.png
+share/icons/hicolor/256x256/apps/simplescreenrecorder-error.png
+share/icons/hicolor/256x256/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/256x256/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/256x256/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/256x256/apps/simplescreenrecorder.png
+share/icons/hicolor/32x32/apps/simplescreenrecorder-error.png
+share/icons/hicolor/32x32/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/32x32/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/32x32/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/32x32/apps/simplescreenrecorder.png
+share/icons/hicolor/48x48/apps/simplescreenrecorder-error.png
+share/icons/hicolor/48x48/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/48x48/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/48x48/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/48x48/apps/simplescreenrecorder.png
+share/icons/hicolor/64x64/apps/simplescreenrecorder-error.png
+share/icons/hicolor/64x64/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/64x64/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/64x64/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/64x64/apps/simplescreenrecorder.png
+share/icons/hicolor/96x96/apps/simplescreenrecorder-error.png
+share/icons/hicolor/96x96/apps/simplescreenrecorder-idle.png
+share/icons/hicolor/96x96/apps/simplescreenrecorder-paused.png
+share/icons/hicolor/96x96/apps/simplescreenrecorder-recording.png
+share/icons/hicolor/96x96/apps/simplescreenrecorder.png
+share/icons/hicolor/scalable/apps/simplescreenrecorder-error.svg
+share/icons/hicolor/scalable/apps/simplescreenrecorder-idle.svg
+share/icons/hicolor/scalable/apps/simplescreenrecorder-paused.svg
+share/icons/hicolor/scalable/apps/simplescreenrecorder-recording.svg
+share/icons/hicolor/scalable/apps/simplescreenrecorder.svg
+%%DATADIR%%/output-profiles/High%20Quality%20Intermediate.conf
+%%DATADIR%%/output-profiles/Live%20Stream%20%281000kbps%29.conf
+%%DATADIR%%/output-profiles/Live%20Stream%20%282000kbps%29.conf
+%%DATADIR%%/output-profiles/Live%20Stream%20%283000kbps%29.conf
+%%DATADIR%%/output-profiles/YouTube.conf
+%%DATADIR%%/translations/simplescreenrecorder_ar.qm
+%%DATADIR%%/translations/simplescreenrecorder_bg.qm
+%%DATADIR%%/translations/simplescreenrecorder_cs.qm
+%%DATADIR%%/translations/simplescreenrecorder_de.qm
+%%DATADIR%%/translations/simplescreenrecorder_el.qm
+%%DATADIR%%/translations/simplescreenrecorder_es.qm
+%%DATADIR%%/translations/simplescreenrecorder_fr.qm
+%%DATADIR%%/translations/simplescreenrecorder_he.qm
+%%DATADIR%%/translations/simplescreenrecorder_hu.qm
+%%DATADIR%%/translations/simplescreenrecorder_it.qm
+%%DATADIR%%/translations/simplescreenrecorder_ja.qm
+%%DATADIR%%/translations/simplescreenrecorder_lt.qm
+%%DATADIR%%/translations/simplescreenrecorder_nl.qm
+%%DATADIR%%/translations/simplescreenrecorder_pl.qm
+%%DATADIR%%/translations/simplescreenrecorder_pt_BR.qm
+%%DATADIR%%/translations/simplescreenrecorder_ru.qm
+%%DATADIR%%/translations/simplescreenrecorder_sv.qm
+%%DATADIR%%/translations/simplescreenrecorder_uk.qm
+%%DATADIR%%/translations/simplescreenrecorder_zh_CN.qm
+%%DATADIR%%/translations/simplescreenrecorder_zh_TW.qm