aboutsummaryrefslogtreecommitdiff
path: root/multimedia/snapcast
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-26 01:33:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-26 01:33:39 +0000
commitb9afdbb7302599ca3be9658f6aff3bd64e9dc963 (patch)
treebcdcb35ee0bf3d1dcb9cb5380482117058906a68 /multimedia/snapcast
parent240c1eec9e8cfc7f13f017d72464348d0de9174c (diff)
downloadports-b9afdbb7302599ca3be9658f6aff3bd64e9dc963.tar.gz
ports-b9afdbb7302599ca3be9658f6aff3bd64e9dc963.zip
New port: multimedia/snapcast: Multiroom client-server audio player
Notes
Notes: svn path=/head/; revision=566577
Diffstat (limited to 'multimedia/snapcast')
-rw-r--r--multimedia/snapcast/Makefile36
-rw-r--r--multimedia/snapcast/distinfo3
-rw-r--r--multimedia/snapcast/files/patch-CMakeLists.txt20
-rw-r--r--multimedia/snapcast/pkg-descr13
-rw-r--r--multimedia/snapcast/pkg-plist18
5 files changed, 90 insertions, 0 deletions
diff --git a/multimedia/snapcast/Makefile b/multimedia/snapcast/Makefile
new file mode 100644
index 000000000000..65c46ff4c1fd
--- /dev/null
+++ b/multimedia/snapcast/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= snapcast
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.23.0
+CATEGORIES= multimedia audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Multiroom client-server audio player
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/asio.hpp:devel/boost-libs
+LIB_DEPENDS= libavahi-common.so:net/avahi-app \
+ libexpat.so:textproc/expat2 \
+ libFLAC.so:audio/flac \
+ libogg.so:audio/libogg \
+ libopus.so:audio/opus \
+ libvorbis.so:audio/libvorbis \
+ libsoxr.so:audio/libsoxr
+
+USES= cmake compiler:c++14-lang pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= badaix
+
+OPTIONS_DEFINE= CLIENT
+OPTIONS_DEFAULT= CLIENT
+OPTIONS_SUB= yes
+
+CLIENT_DESC= Build and install client in addition to server
+CLIENT_CMAKE_BOOL= BUILD_CLIENT
+CLIENT_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+
+.include <bsd.port.mk>
diff --git a/multimedia/snapcast/distinfo b/multimedia/snapcast/distinfo
new file mode 100644
index 000000000000..6c3a0aaafd09
--- /dev/null
+++ b/multimedia/snapcast/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614300754
+SHA256 (badaix-snapcast-v0.23.0_GH0.tar.gz) = 70efdeea60021f493f77ba1f3d00784911463cad11c6df214ecb19d74899b611
+SIZE (badaix-snapcast-v0.23.0_GH0.tar.gz) = 1279670
diff --git a/multimedia/snapcast/files/patch-CMakeLists.txt b/multimedia/snapcast/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..0b28024b3671
--- /dev/null
+++ b/multimedia/snapcast/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2021-01-09 21:43:59 UTC
++++ CMakeLists.txt
+@@ -73,7 +73,7 @@ if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ set(MACOSX TRUE)
+ elseif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ set (FREEBSD TRUE)
+- if (BUILD_CLIENT)
++ if (FALSE AND BUILD_CLIENT)
+ message(FATAL_ERROR "Snapclient not yet supported for FreeBSD, use \"-DBUILD_CLIENT=OFF\"")
+ endif()
+ elseif (${CMAKE_SYSTEM_NAME} MATCHES "Android")
+@@ -163,7 +163,7 @@ if(NOT WIN32 AND NOT ANDROID)
+ list(APPEND INCLUDE_DIRS "/usr/local/include")
+ else()
+
+- pkg_search_module(ALSA REQUIRED alsa)
++ #pkg_search_module(ALSA REQUIRED alsa)
+ if (ALSA_FOUND)
+ add_definitions(-DHAS_ALSA)
+ endif (ALSA_FOUND)
diff --git a/multimedia/snapcast/pkg-descr b/multimedia/snapcast/pkg-descr
new file mode 100644
index 000000000000..a8f7afecbb28
--- /dev/null
+++ b/multimedia/snapcast/pkg-descr
@@ -0,0 +1,13 @@
+Snapcast is a multiroom client-server audio player, where all clients are time
+synchronized with the server to play perfectly synced audio. It's not a
+standalone player, but an extension that turns your existing audio player into
+a Sonos-like multiroom solution.
+
+Audio is captured by the server and routed to the connected clients. Several
+players can feed audio to the server in parallel and clients can be grouped to
+play the same audio stream.
+
+One of the most generic ways to use Snapcast is in conjunction with the music
+player daemon (MPD) or Mopidy.
+
+WWW: https://github.com/badaix/snapcast
diff --git a/multimedia/snapcast/pkg-plist b/multimedia/snapcast/pkg-plist
new file mode 100644
index 000000000000..a1a04594a4b1
--- /dev/null
+++ b/multimedia/snapcast/pkg-plist
@@ -0,0 +1,18 @@
+%%CLIENT%%bin/snapclient
+bin/snapserver
+etc/snapserver.conf
+%%CLIENT%%man/man1/snapclient.1.gz
+man/man1/snapserver.1.gz
+share/snapserver/index.html
+share/snapserver/snapweb/3rd-party/libflac.js
+share/snapserver/snapweb/favicon.ico
+share/snapserver/snapweb/index.html
+share/snapserver/snapweb/launcher-icon.png
+share/snapserver/snapweb/manifest.json
+share/snapserver/snapweb/mute_icon.png
+share/snapserver/snapweb/play.png
+share/snapserver/snapweb/snapcontrol.js
+share/snapserver/snapweb/snapstream.js
+share/snapserver/snapweb/speaker_icon.png
+share/snapserver/snapweb/stop.png
+share/snapserver/snapweb/styles.css