aboutsummaryrefslogtreecommitdiff
path: root/multimedia/snappy/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /multimedia/snappy/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'multimedia/snappy/Makefile')
-rw-r--r--multimedia/snappy/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/multimedia/snappy/Makefile b/multimedia/snappy/Makefile
new file mode 100644
index 000000000000..385074b5871b
--- /dev/null
+++ b/multimedia/snappy/Makefile
@@ -0,0 +1,29 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/multimedia/snappy/Makefile 19571 2014-04-25 18:12:46Z kwm $
+
+PORTNAME= snappy
+PORTVERSION= 1.0
+CATEGORIES= multimedia gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+PKGNAMESUFFIX= player
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Open source gstreamer media player
+
+LIB_DEPENDS= libclutter-gst-2.0.so:${PORTSDIR}/multimedia/clutter-gst \
+ libclutter-1.0.so:${PORTSDIR}/graphics/clutter \
+ libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3
+
+USES= desktop-file-utils gettext gmake pathfix \
+ pkgconfig tar:xz
+USE_GNOME= gnomeprefix gtk30 intlhack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GSTREAMER1= yes
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>