aboutsummaryrefslogtreecommitdiff
path: root/multimedia/streamlink
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-04-27 15:47:49 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-04-27 15:47:49 +0000
commit100532e19f78a406d56f80a9982a058ccc437ca1 (patch)
treea3822b2d91261cfbd5125408f5f9a69756e7a26e /multimedia/streamlink
parentc4913cf8d6f9826b1bc7ecdf1358ad74866827be (diff)
downloadports-100532e19f78a406d56f80a9982a058ccc437ca1.tar.gz
ports-100532e19f78a406d56f80a9982a058ccc437ca1.zip
multimedia/streamlink: add missing requisites
https://streamlink.github.io/install.html#dependencies - py-pysocks is a mandatory dependency (the import isn't guarded by try...except) - ffmpeg and rtmpdump are formally optional, but required for high-profile streaming sites, make them options enabled by default - add PORTREVISION=1 to pull pysocks in.
Notes
Notes: svn path=/head/; revision=533145
Diffstat (limited to 'multimedia/streamlink')
-rw-r--r--multimedia/streamlink/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/multimedia/streamlink/Makefile b/multimedia/streamlink/Makefile
index 869749f9d3c2..d6ec6ba3c28e 100644
--- a/multimedia/streamlink/Makefile
+++ b/multimedia/streamlink/Makefile
@@ -2,6 +2,7 @@
PORTNAME= streamlink
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}isodate>0:devel/py-isodate@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycryptodome>=3.4.3:security/py-pycryptodome@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pysocks>0:net/py-pysocks${PY_FLAVOUR} \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}websocket-client>0:www/py-websocket-client@${PY_FLAVOR}
@@ -32,17 +34,19 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-OPTIONS_DEFINE= PYCOUNTRY
-OPTIONS_DEFAULT=
+OPTIONS_DEFINE= FFMPEG PYCOUNTRY RTMPDUMP
+OPTIONS_DEFAULT= FFMPEG RTMPDUMP
.if !exists(../../textproc/py-iso3166/Makefile)
OPTIONS_DEFAULT+= PYCOUNTRY
.endif
PYCOUNTRY_DESC= Use pycountry instead of py-iso-639 and py-iso3166
+FFMPEG_RUN_DEPENDS= ffmpeg:multimedia/ffmpeg
PYCOUNTRY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}country>0:devel/py-country@${PY_FLAVOR}
PYCOUNTRY_RUN_DEPENDS_OFF= ${PYTHON_PKGNAMEPREFIX}iso-639>0:textproc/py-iso-639@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}iso3166>0:textproc/py-iso3166@${PY_FLAVOR}
PYCOUNTRY_MAKE_ENV= STREAMLINK_USE_PYCOUNTRY=1
+RTMPDUMP_RUN_DEPENDS= rtmpdump:multimedia/rtmpdump
do-test: .PHONY
cd ${WRKSRC} && ${SETENV} PYTHONPATH=${WRKSRC}/src ${PYTHON_CMD} -u -m pytest -v -ra \