aboutsummaryrefslogtreecommitdiff
path: root/multimedia/svt-vp9
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-09-09 19:31:37 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-09-09 19:31:37 +0000
commitc01f522ca1a992b11fe5e1b25fb0a6eb4b898e15 (patch)
tree23f3fe73031a36d2caf7d26134d735101bf1a615 /multimedia/svt-vp9
parentab8f4d124b76be9a6b9b86e697741eef9be5f991 (diff)
downloadports-c01f522ca1a992b11fe5e1b25fb0a6eb4b898e15.tar.gz
ports-c01f522ca1a992b11fe5e1b25fb0a6eb4b898e15.zip
multimedia/svt-vp9: update to s20190906
Notes
Notes: svn path=/head/; revision=511659
Diffstat (limited to 'multimedia/svt-vp9')
-rw-r--r--multimedia/svt-vp9/Makefile28
-rw-r--r--multimedia/svt-vp9/distinfo6
-rw-r--r--multimedia/svt-vp9/files/patch-Source_Lib_Codec_EbThreads.h26
3 files changed, 37 insertions, 23 deletions
diff --git a/multimedia/svt-vp9/Makefile b/multimedia/svt-vp9/Makefile
index 91918c3801da..1f7677b6bb4b 100644
--- a/multimedia/svt-vp9/Makefile
+++ b/multimedia/svt-vp9/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= svt-vp9
-PORTVERSION= s20190620
-PORTREVISION= 1
+PORTVERSION= s20190906
CATEGORIES= multimedia
MAINTAINER= jbeich@FreeBSD.org
@@ -24,31 +23,20 @@ USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= OpenVisualCloud
GH_PROJECT= SVT-VP9
-GH_TAGNAME= 8f99fda
+GH_TAGNAME= e3dd26e
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= NATIVE
post-patch:
-# Default CFLAGS are already set by USES=cmake
- @${REINPLACE_CMD} -i .flags -E -e 's/ -mavx//' \
- -e 's/-O2 -flto //' \
- -e '/C_FLAGS_(RELEASE|DEBUG)/d' \
- -e '/NASM_FLAGS_DEBUG/d' \
+# Keep using nasm and drop vendor -O/-g
+ @${REINPLACE_CMD} -e '/find_program.*yasm/d' \
+ -Ee '/set.*(release|debug)_flags_to_test/,/\)/d' \
${WRKSRC}/CMakeLists.txt
-# Avoid devel/yasm dependency
- @${REINPLACE_CMD} -i .typo 's/MAKE_ASM_NASM_COMPILER/s&/' \
- ${WRKSRC}/CMakeLists.txt
-# Avoid lang/gcc* dependency
- @${REINPLACE_CMD} -i .gcc -e 's/gcc-//' \
- -e '/CMAKE_C/{ s/STREQUAL/MATCHES/; s/"GNU/&|Clang/; }' \
- ${WRKSRC}/CMakeLists.txt \
- ${WRKSRC}/Source/Lib/*/CMakeLists.txt
# Avoid conflict with standard types
@${GREP} -Flr '_T_DEFINED' ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -i .types 's/_T_DEFINED/_DEFINED/'
# Avoid platform whitelists for generic non-Windows code
- @${REINPLACE_CMD} -i .opsys 's/Linux/${OPSYS}/' \
- ${WRKSRC}/CMakeLists.txt \
- ${WRKSRC}/Source/Lib/*/CMakeLists.txt
@${GREP} --exclude='*/third_party/*' -Flr '__linux' ${WRKSRC} | ${XARGS} \
- ${REINPLACE_CMD} -i .opsys -E 's/__linux(__)?/__${OPSYS}__/'
+ ${REINPLACE_CMD} -i .opsys -E 's/__linux(__)?/__unix__/'
.include <bsd.port.mk>
diff --git a/multimedia/svt-vp9/distinfo b/multimedia/svt-vp9/distinfo
index 1fc3f5498beb..55518d189276 100644
--- a/multimedia/svt-vp9/distinfo
+++ b/multimedia/svt-vp9/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1561075709
-SHA256 (OpenVisualCloud-SVT-VP9-s20190620-8f99fda_GH0.tar.gz) = 27175f5446a150703828ed4d2cef09e52d28f30eed9d8a9eeb4743dfc31d2c9b
-SIZE (OpenVisualCloud-SVT-VP9-s20190620-8f99fda_GH0.tar.gz) = 981849
+TIMESTAMP = 1567798965
+SHA256 (OpenVisualCloud-SVT-VP9-s20190906-e3dd26e_GH0.tar.gz) = cea71a73e234c0970da553c5a16893fab6f1a2e14559edb276c9d805882541b1
+SIZE (OpenVisualCloud-SVT-VP9-s20190906-e3dd26e_GH0.tar.gz) = 985323
diff --git a/multimedia/svt-vp9/files/patch-Source_Lib_Codec_EbThreads.h b/multimedia/svt-vp9/files/patch-Source_Lib_Codec_EbThreads.h
new file mode 100644
index 000000000000..e16a8ffec414
--- /dev/null
+++ b/multimedia/svt-vp9/files/patch-Source_Lib_Codec_EbThreads.h
@@ -0,0 +1,26 @@
+Source/Lib/Codec/EbEncHandle.c:1531:5: error: use of undeclared identifier 'cpu_set_t'
+Source/Lib/Codec/EbThreads.h:102:62: note: expanded from macro 'EB_CREATETHREAD'
+ pthread_setaffinity_np(*((pthread_t*)pointer),sizeof(cpu_set_t),&group_affinity); \
+ ^
+
+--- Source/Lib/Codec/EbThreads.h.orig 2019-09-06 19:42:45 UTC
++++ Source/Lib/Codec/EbThreads.h
+@@ -93,6 +93,18 @@ extern uint64_t *total_lib_memory;
+ } \
+ lib_thread_count++;
+ #elif defined(__linux__)
++#define __USE_GNU
++#define _GNU_SOURCE
++#ifdef __FreeBSD__
++#define cpu_set_t cpuset_t
++#else
++#include <sched.h>
++#endif
++#include <pthread.h>
++#if defined(__DragonFly__) || defined(__FreeBSD__)
++#include <pthread_np.h>
++#endif
++extern cpu_set_t group_affinity;
+ #define EB_CREATETHREAD(type, pointer, n_elements, pointer_class, thread_function, thread_context) \
+ pointer = eb_create_thread(thread_function, thread_context); \
+ if (pointer == (type)EB_NULL) { \