aboutsummaryrefslogtreecommitdiff
path: root/multimedia/tivodecode
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-01 21:07:25 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-01 21:07:25 +0000
commit7bd84681e169355ab0dd138644bb2fd618a50b51 (patch)
tree0661c51f8b260df3f7f924d911cafe41c68ba816 /multimedia/tivodecode
parenta841b9e43b1b6aacbbe41363401b2df6223913fb (diff)
downloadports-7bd84681e169355ab0dd138644bb2fd618a50b51.tar.gz
ports-7bd84681e169355ab0dd138644bb2fd618a50b51.zip
This software converts a .TiVo file (produced by the TiVoToGo functionality
on recent TiVo software releases) to a normal MPEG file. This has the same functionality as using TiVo's supplied DirectShow DLL on Windows with a tool such as DirectShowDump, but is portable to different architectures and operating systems, and runs on the command line using files or pipes. The conversion still requires the valid MAK of the TiVo which recorded the file, so it cannot be used to circumvent their protection, simply to provide the same level of access as is already available on Windows. WWW: http://tivodecode.sourceforge.net/ PR: ports/107409 Submitted by: Yi-Hsuan Hsin <mhsin at mhsin.org>
Notes
Notes: svn path=/head/; revision=181217
Diffstat (limited to 'multimedia/tivodecode')
-rw-r--r--multimedia/tivodecode/Makefile35
-rw-r--r--multimedia/tivodecode/distinfo3
-rw-r--r--multimedia/tivodecode/files/extra-patch-tivo-parse.c10
-rw-r--r--multimedia/tivodecode/pkg-descr10
-rw-r--r--multimedia/tivodecode/pkg-plist4
5 files changed, 62 insertions, 0 deletions
diff --git a/multimedia/tivodecode/Makefile b/multimedia/tivodecode/Makefile
new file mode 100644
index 000000000000..a046f2eadba1
--- /dev/null
+++ b/multimedia/tivodecode/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: tivodecode
+# Date created: 2007-01-01
+# Whom: Yi-Hsuan Hsin <mhsin@mhsin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tivodecode
+DISTVERSION= 0.1.4
+CATEGORIES= multimedia
+MASTER_SITES= SF
+
+MAINTAINER= mhsin@mhsin.org
+COMMENT= Converts .TiVo files to normal MPEG files
+
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-tivo-parse.c
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/CFLAGS=/CFLAGS+=/' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/objects.dir/tivodecode ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/tivodecode/distinfo b/multimedia/tivodecode/distinfo
new file mode 100644
index 000000000000..6f333568aa79
--- /dev/null
+++ b/multimedia/tivodecode/distinfo
@@ -0,0 +1,3 @@
+MD5 (tivodecode-0.1.4.tar.gz) = b0131ce1de4f2c2057f31a29f7f13c45
+SHA256 (tivodecode-0.1.4.tar.gz) = b48855ab01f6bb75d77036f08b9774cc60564af68493abcd726023db03381037
+SIZE (tivodecode-0.1.4.tar.gz) = 25456
diff --git a/multimedia/tivodecode/files/extra-patch-tivo-parse.c b/multimedia/tivodecode/files/extra-patch-tivo-parse.c
new file mode 100644
index 000000000000..c831be3be48d
--- /dev/null
+++ b/multimedia/tivodecode/files/extra-patch-tivo-parse.c
@@ -0,0 +1,10 @@
+--- tivo-parse.c.orig Tue Jan 2 02:30:58 2007
++++ tivo-parse.c Tue Jan 2 02:31:12 2007
+@@ -8,6 +8,7 @@
+ #ifdef WIN32
+ # include <windows.h>
+ #else
++# include <sys/types.h>
+ # include <netinet/in.h>
+ #endif
+ #include "sha1.h"
diff --git a/multimedia/tivodecode/pkg-descr b/multimedia/tivodecode/pkg-descr
new file mode 100644
index 000000000000..b95a6636d114
--- /dev/null
+++ b/multimedia/tivodecode/pkg-descr
@@ -0,0 +1,10 @@
+This software converts a .TiVo file (produced by the TiVoToGo functionality
+on recent TiVo software releases) to a normal MPEG file. This has the same
+functionality as using TiVo's supplied DirectShow DLL on Windows with a tool
+such as DirectShowDump, but is portable to different architectures and
+operating systems, and runs on the command line using files or pipes. The
+conversion still requires the valid MAK of the TiVo which recorded the file,
+so it cannot be used to circumvent their protection, simply to provide the
+same level of access as is already available on Windows.
+
+WWW: http://tivodecode.sourceforge.net/
diff --git a/multimedia/tivodecode/pkg-plist b/multimedia/tivodecode/pkg-plist
new file mode 100644
index 000000000000..e165bd563698
--- /dev/null
+++ b/multimedia/tivodecode/pkg-plist
@@ -0,0 +1,4 @@
+bin/tivodecode
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%