aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
commit951c1f5d1c7354f058f5919d858dbb0c174dc73e (patch)
tree6146e775343aaf339921799078894a48fef9aa15 /multimedia/totem
parentc9b47f0427d70ba42c2d53271f8b64b8e8096825 (diff)
downloadports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.tar.gz
ports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.zip
The FreeBSD GNOME team proudly presents GNOME 3.28 for FreeBSD.
The offical GNOME 3.28 release notes can be found at https://help.gnome.org/misc/release-notes/3.28/ Thanks to Antoine Brodin for running the exp-runs. PR: 229761
Notes
Notes: svn path=/head/; revision=480951
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile70
-rw-r--r--multimedia/totem/distinfo5
-rw-r--r--multimedia/totem/pkg-descr4
-rw-r--r--multimedia/totem/pkg-plist101
4 files changed, 73 insertions, 107 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 45792eee6a7e..abbda4d68c95 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= totem
-PORTVERSION= 3.18.1
-PORTREVISION= 6
+PORTVERSION= 3.26.1
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -11,74 +10,61 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gstreamer-based video player for the GNOME 3 Desktop
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
- ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:misc/gnome-icon-theme \
- pylint:devel/pylint1 \
+ pylint:devel/pylint \
appstream-glib>=0:devel/appstream-glib \
itstool:textproc/itstool \
- grilo-plugins2>=0:net/grilo-plugins2
+ grilo-plugins>=0:net/grilo-plugins
LIB_DEPENDS= libgdata.so:devel/libgdata \
- libdbus-glib-1.so:devel/dbus-glib \
+ libcogl.so:graphics/cogl \
+ libclutter-1.0.so:graphics/clutter \
libclutter-gst-3.0.so:multimedia/clutter-gst3 \
libclutter-gtk-1.0.so:graphics/clutter-gtk3 \
libpeas-1.0.so:devel/libpeas \
+ libjson-glib-1.0.so:devel/json-glib \
+ libgrilo-0.3.so:net/grilo \
+ libzeitgeist-2.0.so:sysutils/zeitgeist \
libtotem-plparser.so:multimedia/totem-pl-parser
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
- ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:misc/gnome-icon-theme \
${PYTHON_PKGNAMEPREFIX}libpeas>=0:devel/py-libpeas@${PY_FLAVOR} \
gnome-settings-daemon>=2.91.0:sysutils/gnome-settings-daemon \
gnome-icon-theme-symbolic>=2.91.0:x11-themes/gnome-icon-theme-symbolic \
- grilo-plugins2>=0:net/grilo-plugins2
+ grilo-plugins>=0:net/grilo-plugins
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake gnome libtool \
- pathfix pkgconfig python:2.7 tar:xz
-USE_GNOME= gtk30 intlhack introspection:build libxml2 nautilus3 \
+USES= desktop-file-utils gettext gnome localbase meson \
+ pkgconfig python:3.4+ tar:xz
+USE_GNOME= cairo gtk30 intlhack introspection libxml2 nautilus3 \
pygobject3
USE_XORG= x11 xorgproto xtst ice sm
USE_GSTREAMER1= core good bad soup ugly
INSTALLS_ICONS= yes
-GNU_CONFIGURE= yes
+USE_GL= egl
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include -Wno-error=format-nonliteral
-CFLAGS+= -I${LOCALBASE}/include -Wno-error=format-nonliteral
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LIBS="-lXrandr"
-CONFIGURE_ARGS= --with-plugins="${TOTEM_PLUGINS}"
-#CONFIGURE_ENV+= APPDATA_VALIDATE="${LOCALBASE}/bin/appdata-validate --nonet"
-MAKE_ENV= XDG_CACHE_HOME=${WRKDIR}
-INSTALL_TARGET= install-strip
+
+BINARY_ALIAS= python3=${PYTHON_VERSION}
GLIB_SCHEMAS= org.gnome.totem.enums.xml \
org.gnome.totem.gschema.xml \
- org.gnome.totem.plugins.opensubtitles.gschema.xml
-
-OPTIONS_DEFINE= LIRC
-
-PLIST_SUB+= PYVER=${PYTHON_VER:S/.//}
-
-OPTIONS_DEFAULT=
-
-# check configure script for allowed_plugins="..." for new plugins
-TOTEM_PLUGINS= apple-trailers autoload-subtitles brasero-disc-recorder chapters \
- dbusservice im-status grilo gromit iplayer media-player-keys \
- nautilus ontop opensubtitles properties recent \
- save-file screensaver screenshot sidebar-test skipto vimeo \
- youtube
+ org.gnome.totem.plugins.opensubtitles.gschema.xml \
+ org.gnome.totem.plugins.pythonconsole.gschema.xml
-# pythonconsole samplepython
-# vala sample-vala
-# iplayer zeitgeist-dp grilo
+# https://bugzilla.gnome.org/show_bug.cgi?id=786248
+# https://github.com/mesonbuild/meson/issues/1994
+MAKE_JOBS_UNSAFE=yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MLIRC}
-LIB_DEPENDS+= liblirc_client.so:comms/lirc
-PLIST_SUB+= LIRC=""
-TOTEM_PLUGINS:= ${TOTEM_PLUGINS} lirc
+.if ${ARCH} == i386 || ${OSVERSION} <= 1100000
+MESON_ARGS= -Denable-vala=no
+PLIST_SUB+= VALA="@comment "
.else
-PLIST_SUB+= LIRC="@comment "
+BUILD_DEPENDS+= valac:lang/vala
+PLIST_SUB+= VALA=""
.endif
.if defined(WITH_DVD_DEVICE)
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index c498e3262ce2..06effe458692 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnome3/totem-3.18.1.tar.xz) = d7816eae9606846c44fd508902eae10bdaed28e6d4f621531990d473184107a2
-SIZE (gnome3/totem-3.18.1.tar.xz) = 3172416
+TIMESTAMP = 1529610772
+SHA256 (gnome3/totem-3.26.1.tar.xz) = 298160c9ee8d34f1ac6586c69e0440e3586a75fd4b1719d79f908edb9c00c382
+SIZE (gnome3/totem-3.26.1.tar.xz) = 3281392
diff --git a/multimedia/totem/pkg-descr b/multimedia/totem/pkg-descr
index 3f33f1f5f682..caf3b0955d44 100644
--- a/multimedia/totem/pkg-descr
+++ b/multimedia/totem/pkg-descr
@@ -1,7 +1,5 @@
-Totem is simple movie player for the Gnome 2 desktop based on xine.
+Totem is simple movie player for the Gnome 3 desktop based on xine.
It features a simple playlist, a full-screen mode, seek and volume controls,
as well as a pretty complete keyboard navigation.
WWW: http://www.gnome.org/projects/totem/
-
--- Hendrik Scholz <hendrik@scholz.net>
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index 76b427f5c625..ede38b87def6 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -1,111 +1,69 @@
bin/totem
-bin/totem-audio-preview
bin/totem-video-thumbnailer
include/totem/1.0/totem-dirs.h
include/totem/1.0/totem-interface.h
include/totem/1.0/totem-plugin.h
include/totem/1.0/totem.h
lib/girepository-1.0/Totem-1.0.typelib
-lib/libtotem.a
lib/libtotem.so
lib/libtotem.so.0
lib/libtotem.so.0.0.0
-lib/nautilus/extensions-3.0/libtotem-properties-page.a
lib/nautilus/extensions-3.0/libtotem-properties-page.so
lib/totem/plugins/apple-trailers/apple-trailers.plugin
-lib/totem/plugins/apple-trailers/libapple-trailers.a
lib/totem/plugins/apple-trailers/libapple-trailers.so
lib/totem/plugins/autoload-subtitles/autoload-subtitles.plugin
-lib/totem/plugins/autoload-subtitles/libautoload-subtitles.a
lib/totem/plugins/autoload-subtitles/libautoload-subtitles.so
lib/totem/plugins/brasero-disc-recorder/brasero-disc-recorder.plugin
-lib/totem/plugins/brasero-disc-recorder/libbrasero-disc-recorder.a
lib/totem/plugins/brasero-disc-recorder/libbrasero-disc-recorder.so
lib/totem/plugins/dbus/dbusservice.plugin
lib/totem/plugins/dbus/dbusservice.py
-lib/totem/plugins/dbus/dbusservice.pyc
-lib/totem/plugins/dbus/dbusservice.pyo
lib/totem/plugins/gromit/gromit.plugin
-lib/totem/plugins/gromit/libgromit.a
lib/totem/plugins/gromit/libgromit.so
-lib/totem/plugins/im-status/libtotem-im-status.a
lib/totem/plugins/im-status/libtotem-im-status.so
lib/totem/plugins/im-status/totem-im-status.plugin
-%%LIRC%%lib/totem/plugins/lirc/liblirc.a
-%%LIRC%%lib/totem/plugins/lirc/liblirc.so
-%%LIRC%%lib/totem/plugins/lirc/lirc.plugin
-%%LIRC%%lib/totem/plugins/lirc/totem_lirc_default
-lib/totem/plugins/media-player-keys/libmedia_player_keys.a
lib/totem/plugins/media-player-keys/libmedia_player_keys.so
lib/totem/plugins/media-player-keys/media-player-keys.plugin
-lib/totem/plugins/ontop/libontop.a
lib/totem/plugins/ontop/libontop.so
lib/totem/plugins/ontop/ontop.plugin
lib/totem/plugins/opensubtitles/hash.py
-lib/totem/plugins/opensubtitles/hash.pyc
-lib/totem/plugins/opensubtitles/hash.pyo
lib/totem/plugins/opensubtitles/opensubtitles.plugin
lib/totem/plugins/opensubtitles/opensubtitles.py
-lib/totem/plugins/opensubtitles/opensubtitles.pyc
-lib/totem/plugins/opensubtitles/opensubtitles.pyo
lib/totem/plugins/opensubtitles/opensubtitles.ui
-lib/totem/plugins/properties/libmovie-properties.a
lib/totem/plugins/properties/libmovie-properties.so
lib/totem/plugins/properties/movie-properties.plugin
-lib/totem/plugins/recent/librecent.a
+lib/totem/plugins/pythonconsole/console.py
+lib/totem/plugins/pythonconsole/pythonconsole.plugin
+lib/totem/plugins/pythonconsole/pythonconsole.py
lib/totem/plugins/recent/librecent.so
lib/totem/plugins/recent/recent.plugin
-lib/totem/plugins/save-file/libsave-file.a
+%%VALA%%lib/totem/plugins/rotation/librotation.so
+%%VALA%%lib/totem/plugins/rotation/rotation.plugin
lib/totem/plugins/save-file/libsave-file.so
lib/totem/plugins/save-file/save-file.plugin
-lib/totem/plugins/screensaver/libscreensaver.a
lib/totem/plugins/screensaver/libscreensaver.so
lib/totem/plugins/screensaver/screensaver.plugin
lib/totem/plugins/screenshot/gallery.ui
-lib/totem/plugins/screenshot/libscreenshot.a
lib/totem/plugins/screenshot/libscreenshot.so
lib/totem/plugins/screenshot/screenshot.plugin
-lib/totem/plugins/skipto/libskipto.a
lib/totem/plugins/skipto/libskipto.so
lib/totem/plugins/skipto/skipto.plugin
lib/totem/plugins/skipto/skipto.ui
-lib/totem/plugins/vimeo/libvimeo.a
+lib/totem/plugins/variable-rate/libvariable-rate.so
+lib/totem/plugins/variable-rate/variable-rate.plugin
lib/totem/plugins/vimeo/libvimeo.so
lib/totem/plugins/vimeo/vimeo.plugin
+%%VALA%%lib/totem/plugins/zeitgeist-dp/libtotem-zeitgeist-dp-plugin.so
+%%VALA%%lib/totem/plugins/zeitgeist-dp/zeitgeist-dp.plugin
libdata/pkgconfig/totem.pc
+libexec/totem-gallery-thumbnailer
man/man1/totem-video-thumbnailer.1.gz
man/man1/totem.1.gz
share/GConf/gsettings/opensubtitles.convert
+share/GConf/gsettings/pythonconsole.convert
share/GConf/gsettings/totem.convert
-share/appdata/org.gnome.Totem.appdata.xml
share/applications/org.gnome.Totem.desktop
share/dbus-1/services/org.gnome.Totem.service
share/gir-1.0/Totem-1.0.gir
-share/gtk-doc/html/totem/BaconVideoWidget.html
-share/gtk-doc/html/totem/TotemObject.html
-share/gtk-doc/html/totem/annotation-glossary.html
-share/gtk-doc/html/totem/api-index-deprecated.html
-share/gtk-doc/html/totem/api-index-full.html
-share/gtk-doc/html/totem/core-api.html
-share/gtk-doc/html/totem/home.png
-share/gtk-doc/html/totem/index.html
-share/gtk-doc/html/totem/index.sgml
-share/gtk-doc/html/totem/ix02.html
-share/gtk-doc/html/totem/ix03.html
-share/gtk-doc/html/totem/ix04.html
-share/gtk-doc/html/totem/ix05.html
-share/gtk-doc/html/totem/left-insensitive.png
-share/gtk-doc/html/totem/left.png
-share/gtk-doc/html/totem/right-insensitive.png
-share/gtk-doc/html/totem/right.png
-share/gtk-doc/html/totem/style.css
-share/gtk-doc/html/totem/totem-Interface.html
-share/gtk-doc/html/totem/totem-TotemPlugin.html
-share/gtk-doc/html/totem/totem-plugins.html
-share/gtk-doc/html/totem/totem.devhelp2
-share/gtk-doc/html/totem/tutorials.html
-share/gtk-doc/html/totem/up-insensitive.png
-share/gtk-doc/html/totem/up.png
share/help/C/totem/figures/totem_next_button.png
share/help/C/totem/figures/totem_pause_button.png
share/help/C/totem/figures/totem_play_button.png
@@ -236,6 +194,16 @@ share/help/gl/totem/figures/totem_volume_maximum_button.png
share/help/gl/totem/figures/totem_volume_mute_button.png
share/help/gl/totem/index.docbook
share/help/gl/totem/legal.xml
+share/help/hr/totem/figures/totem_next_button.png
+share/help/hr/totem/figures/totem_pause_button.png
+share/help/hr/totem/figures/totem_play_button.png
+share/help/hr/totem/figures/totem_previous_button.png
+share/help/hr/totem/figures/totem_show_playlist_button.png
+share/help/hr/totem/figures/totem_start_window.png
+share/help/hr/totem/figures/totem_volume_maximum_button.png
+share/help/hr/totem/figures/totem_volume_mute_button.png
+share/help/hr/totem/index.docbook
+share/help/hr/totem/legal.xml
share/help/id/totem/figures/totem_next_button.png
share/help/id/totem/figures/totem_pause_button.png
share/help/id/totem/figures/totem_play_button.png
@@ -266,6 +234,16 @@ share/help/ja/totem/figures/totem_volume_maximum_button.png
share/help/ja/totem/figures/totem_volume_mute_button.png
share/help/ja/totem/index.docbook
share/help/ja/totem/legal.xml
+share/help/nb/totem/figures/totem_next_button.png
+share/help/nb/totem/figures/totem_pause_button.png
+share/help/nb/totem/figures/totem_play_button.png
+share/help/nb/totem/figures/totem_previous_button.png
+share/help/nb/totem/figures/totem_show_playlist_button.png
+share/help/nb/totem/figures/totem_start_window.png
+share/help/nb/totem/figures/totem_volume_maximum_button.png
+share/help/nb/totem/figures/totem_volume_mute_button.png
+share/help/nb/totem/index.docbook
+share/help/nb/totem/legal.xml
share/help/oc/totem/figures/totem_next_button.png
share/help/oc/totem/figures/totem_pause_button.png
share/help/oc/totem/figures/totem_play_button.png
@@ -396,13 +374,13 @@ share/help/zh_TW/totem/figures/totem_volume_maximum_button.png
share/help/zh_TW/totem/figures/totem_volume_mute_button.png
share/help/zh_TW/totem/index.docbook
share/help/zh_TW/totem/legal.xml
-share/icons/hicolor/16x16/apps/totem.png
-share/icons/hicolor/22x22/apps/totem.png
-share/icons/hicolor/24x24/apps/totem.png
-share/icons/hicolor/256x256/apps/totem.png
-share/icons/hicolor/32x32/apps/totem.png
-share/icons/hicolor/48x48/apps/totem.png
-share/icons/hicolor/scalable/apps/totem-symbolic.svg
+share/icons/hicolor/16x16/apps/org.gnome.Totem.png
+share/icons/hicolor/22x22/apps/org.gnome.Totem.png
+share/icons/hicolor/24x24/apps/org.gnome.Totem.png
+share/icons/hicolor/256x256/apps/org.gnome.Totem.png
+share/icons/hicolor/32x32/apps/org.gnome.Totem.png
+share/icons/hicolor/48x48/apps/org.gnome.Totem.png
+share/icons/hicolor/symbolic/apps/org.gnome.Totem-symbolic.svg
share/locale/af/LC_MESSAGES/totem.mo
share/locale/am/LC_MESSAGES/totem.mo
share/locale/ar/LC_MESSAGES/totem.mo
@@ -435,6 +413,7 @@ share/locale/eu/LC_MESSAGES/totem.mo
share/locale/fa/LC_MESSAGES/totem.mo
share/locale/fi/LC_MESSAGES/totem.mo
share/locale/fr/LC_MESSAGES/totem.mo
+share/locale/fur/LC_MESSAGES/totem.mo
share/locale/ga/LC_MESSAGES/totem.mo
share/locale/gd/LC_MESSAGES/totem.mo
share/locale/gl/LC_MESSAGES/totem.mo
@@ -498,10 +477,12 @@ share/locale/zh_CN/LC_MESSAGES/totem.mo
share/locale/zh_HK/LC_MESSAGES/totem.mo
share/locale/zh_TW/LC_MESSAGES/totem.mo
share/locale/zu/LC_MESSAGES/totem.mo
+share/metainfo/org.gnome.Totem.appdata.xml
share/thumbnailers/totem.thumbnailer
%%DATADIR%%/controls.ui
%%DATADIR%%/playlist.ui
%%DATADIR%%/preferences.ui
%%DATADIR%%/properties.ui
+%%DATADIR%%/shortcuts.ui
%%DATADIR%%/totem.ui
%%DATADIR%%/uri.ui