aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
commitaad09bc5e23eb75a7a865a8b0002fbc6e13d4659 (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /multimedia/totem
parent5c818b158c5b9479669f8322b4da8c48f5c30ef9 (diff)
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=351936
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 062628efbfd1..4f7b50421c91 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -4,7 +4,7 @@
PORTNAME= totem
PORTVERSION= 2.32.0
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -24,11 +24,10 @@ CONFLICTS= totem-3.[0-9]*
GNU_CONFIGURE= yes
USE_PYTHON= yes
-USES= pathfix gettext gmake desktop-file-utils libtool pkgconfig tar:bzip2 \
- shebangfix
+USES= desktop-file-utils gettext gmake libtool:keepla pathfix \
+ pkgconfig shebangfix tar:bzip2
SHEBANG_FILES= data/totem-bugreport.py
-USE_GNOME= gnomeprefix intlhack nautilus2 \
- pygtk2 gnomehier
+USE_GNOME= gnomehier gnomeprefix intlhack nautilus2 pygtk2
USE_GSTREAMER= core gconf hal good mpeg2dec soup ugly python gio
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip