aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vapoursynth-l-smash-works
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-03-13 05:43:41 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-03-13 05:43:41 +0000
commitea98b283c27771a1df56e4ba323fdfa1ebf01069 (patch)
tree5af2ebc118d7f5795a67632f052cdf69d75569c5 /multimedia/vapoursynth-l-smash-works
parent40ddcf42ef024efc2a604404282ed5c1dfffd68e (diff)
downloadports-ea98b283c27771a1df56e4ba323fdfa1ebf01069.tar.gz
ports-ea98b283c27771a1df56e4ba323fdfa1ebf01069.zip
Fix build on non-x86 architectures:
cc1: error: unrecognized command line option "-msse2" Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=495563
Diffstat (limited to 'multimedia/vapoursynth-l-smash-works')
-rw-r--r--multimedia/vapoursynth-l-smash-works/Makefile9
-rw-r--r--multimedia/vapoursynth-l-smash-works/files/extra-patch-GNUmakefile10
2 files changed, 18 insertions, 1 deletions
diff --git a/multimedia/vapoursynth-l-smash-works/Makefile b/multimedia/vapoursynth-l-smash-works/Makefile
index 03ca24ef53f6..addabe8f9510 100644
--- a/multimedia/vapoursynth-l-smash-works/Makefile
+++ b/multimedia/vapoursynth-l-smash-works/Makefile
@@ -58,4 +58,11 @@ post-install:
(cd ${WRKSRC} && ${COPYTREE_SHARE} \
"${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# disable sse on non-x86 archs
+.if ${ARCH} != amd64 && ${ARCH} != i386
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-GNUmakefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/vapoursynth-l-smash-works/files/extra-patch-GNUmakefile b/multimedia/vapoursynth-l-smash-works/files/extra-patch-GNUmakefile
new file mode 100644
index 000000000000..51a9df19598b
--- /dev/null
+++ b/multimedia/vapoursynth-l-smash-works/files/extra-patch-GNUmakefile
@@ -0,0 +1,10 @@
+--- GNUmakefile.orig 2018-03-31 09:55:14 UTC
++++ GNUmakefile
+@@ -53,7 +53,7 @@ endif
+
+ .depend: config.mak
+ @$(RM) .depend
+- @$(foreach SRC, $(SRC_ALL:%=$(SRCDIR)/%), $(CC) $(SRC) $(CFLAGS) -msse2 -g0 -MT $(SRC:$(SRCDIR)/%.c=%.o) -MM >> .depend;)
++ @$(foreach SRC, $(SRC_ALL:%=$(SRCDIR)/%), $(CC) $(SRC) $(CFLAGS) -g0 -MT $(SRC:$(SRCDIR)/%.c=%.o) -MM >> .depend;)
+
+ config.mak: