aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vapoursynth
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-11-06 16:42:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-11-06 16:42:19 +0000
commitb886f720e139c9db5966911c62c7349413855fa0 (patch)
tree208927200d400401b12297ca21598aa12a70e204 /multimedia/vapoursynth
parent9a636a4ce3d6746d1077b9898407059e59f6eb32 (diff)
downloadports-b886f720e139c9db5966911c62c7349413855fa0.tar.gz
ports-b886f720e139c9db5966911c62c7349413855fa0.zip
multimedia/vapoursynth: update to R48
Notes
Notes: svn path=/head/; revision=516899
Diffstat (limited to 'multimedia/vapoursynth')
-rw-r--r--multimedia/vapoursynth/Makefile2
-rw-r--r--multimedia/vapoursynth/distinfo6
-rw-r--r--multimedia/vapoursynth/files/patch-non-x8618
3 files changed, 14 insertions, 12 deletions
diff --git a/multimedia/vapoursynth/Makefile b/multimedia/vapoursynth/Makefile
index 9a0afa5f8127..0f8477d6fad6 100644
--- a/multimedia/vapoursynth/Makefile
+++ b/multimedia/vapoursynth/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= vapoursynth
-PORTVERSION= R47.2
+DISTVERSION= R48
CATEGORIES= multimedia
MAINTAINER= jbeich@FreeBSD.org
diff --git a/multimedia/vapoursynth/distinfo b/multimedia/vapoursynth/distinfo
index c0f0bd326b1f..939c2a45eae8 100644
--- a/multimedia/vapoursynth/distinfo
+++ b/multimedia/vapoursynth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1565895705
-SHA256 (vapoursynth-vapoursynth-R47.2_GH0.tar.gz) = 8ce4553f9fc5e5bbfb26ec9c0c5bf94be307530f947424c713ef67bc8a6d22b2
-SIZE (vapoursynth-vapoursynth-R47.2_GH0.tar.gz) = 585731
+TIMESTAMP = 1571984167
+SHA256 (vapoursynth-vapoursynth-R48_GH0.tar.gz) = 3e98d134e16af894cf7040e4383e4ef753cafede34d5d77c42a2bb89790c50a8
+SIZE (vapoursynth-vapoursynth-R48_GH0.tar.gz) = 611523
diff --git a/multimedia/vapoursynth/files/patch-non-x86 b/multimedia/vapoursynth/files/patch-non-x86
index 4d125f9348b7..7484ac6f981c 100644
--- a/multimedia/vapoursynth/files/patch-non-x86
+++ b/multimedia/vapoursynth/files/patch-non-x86
@@ -1,6 +1,6 @@
---- src/core/cpufeatures.c.orig 2018-07-13 15:12:57 UTC
-+++ src/core/cpufeatures.c
-@@ -69,7 +69,7 @@ void getCPUFeatures(CPUFeatures *cpuFeatures) {
+--- src/core/cpufeatures.cpp.orig 2019-10-25 06:16:07 UTC
++++ src/core/cpufeatures.cpp
+@@ -102,7 +102,7 @@ static void doGetCPUFeatures(CPUFeatures *cpuFeatures)
}
}
}
@@ -8,21 +8,23 @@
+#elif defined(VS_TARGET_OS_LINUX) && defined(__linux__)
#include <sys/auxv.h>
- void getCPUFeatures(CPUFeatures *cpuFeatures) {
-@@ -98,5 +98,9 @@ void getCPUFeatures(CPUFeatures *cpuFeatures) {
+ static void doGetCPUFeatures(CPUFeatures *cpuFeatures) {
+@@ -131,7 +131,11 @@ static void doGetCPUFeatures(CPUFeatures *cpuFeatures)
#endif
}
#else
-#warning "Do not know how to get CPU features."
-+void getCPUFeatures(CPUFeatures *cpuFeatures) {
++static void doGetCPUFeatures(CPUFeatures *cpuFeatures) {
+ memset(cpuFeatures, 0, sizeof(CPUFeatures));
+
+ cpuFeatures->can_run_vs = 1;
+}
#endif
---- src/core/cpufeatures.h.orig 2018-07-13 15:12:57 UTC
+
+ const CPUFeatures *getCPUFeatures(void) {
+--- src/core/cpufeatures.h.orig 2019-10-25 06:16:07 UTC
+++ src/core/cpufeatures.h
-@@ -59,8 +59,6 @@ typedef struct CPUFeatures {
+@@ -63,8 +63,6 @@ typedef struct CPUFeatures {
char efp_double;
char dfp;
char vsx;