aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-control
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-03-26 19:16:54 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-03-26 19:16:54 +0000
commit8404535fe74a67d790ed45578c84a27576a768cd (patch)
tree9cbe5947f1bc52ab10beb32932bf91db092d18cf /multimedia/vdr-plugin-control
parent0f8592a752db2bbc69de164655d2e424f89e9504 (diff)
downloadports-8404535fe74a67d790ed45578c84a27576a768cd.tar.gz
ports-8404535fe74a67d790ed45578c84a27576a768cd.zip
Notes
Diffstat (limited to 'multimedia/vdr-plugin-control')
-rw-r--r--multimedia/vdr-plugin-control/Makefile43
-rw-r--r--multimedia/vdr-plugin-control/distinfo4
-rw-r--r--multimedia/vdr-plugin-control/files/patch-Makefile14
-rw-r--r--multimedia/vdr-plugin-control/files/patch-StringArray.c14
-rw-r--r--multimedia/vdr-plugin-control/files/patch-control.c10
-rw-r--r--multimedia/vdr-plugin-control/files/patch-stack.c14
-rw-r--r--multimedia/vdr-plugin-control/files/patch-telnet.c14
-rw-r--r--multimedia/vdr-plugin-control/pkg-descr14
-rw-r--r--multimedia/vdr-plugin-control/pkg-plist1
9 files changed, 128 insertions, 0 deletions
diff --git a/multimedia/vdr-plugin-control/Makefile b/multimedia/vdr-plugin-control/Makefile
new file mode 100644
index 000000000000..f11f07e916e6
--- /dev/null
+++ b/multimedia/vdr-plugin-control/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: vdr-plugin-control
+# Date created: Wed Apr 14 18:11:42 CEST 2010
+# Whom: Juergen Lock <nox@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdr-plugin-control
+PORTVERSION= 0.0.2a45
+PORTREVISION= 6
+CATEGORIES= multimedia
+MASTER_SITES= http://ricomp.de/vdr/
+DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION:S/a45/a/}${DISTVERSIONSUFFIX}
+EXTRACT_SUFX= .tgz
+
+PATCH_SITES= http://ppa.launchpad.net/the-vdr-team/unstable-plugins/ubuntu/pool/main/v/vdr-plugin-control/ \
+ ${MASTER_SITE_LOCAL}
+PATCH_SITE_SUBDIR= nox/
+PATCHFILES= ${PORTNAME}_${PORTVERSION:S/a45/a-45/}yavdr1.diff.gz
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video Disk Recorder - telnet control plugin
+
+PATCH_STRIP= -p1
+HAVE_CONFIGURE= yes
+PORTDOCS= COPYING README
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION:S/a45/a/}
+
+.include "${.CURDIR}/../vdr/Makefile.plugins"
+
+post-patch: post-patch-plugin
+ for i in ${WRKSRC}/vdr-plugin-${PLUGIN}-${DISTVERSION:S/a45/a/}/debian/patches/*.dpatch; do \
+ ${PATCH} -d ${WRKSRC} `${SED} -n '/^#PATCHOPTIONS:/{s///;p;q;}' $$i` --forward --quiet <$$i ;\
+ done
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-control/distinfo b/multimedia/vdr-plugin-control/distinfo
new file mode 100644
index 000000000000..695a7e9a2675
--- /dev/null
+++ b/multimedia/vdr-plugin-control/distinfo
@@ -0,0 +1,4 @@
+SHA256 (vdr/vdr-control-0.0.2a.tgz) = e32012511cac2f333a59d4da250ca63d222abe574f99eb55c567d9752ef0d565
+SIZE (vdr/vdr-control-0.0.2a.tgz) = 27441
+SHA256 (vdr/vdr-plugin-control_0.0.2a-45yavdr1.diff.gz) = 806c6b29b43988c9fd3b0421e5a3af03517a5088a6a0b2ed622fdf7afa15c7fa
+SIZE (vdr/vdr-plugin-control_0.0.2a-45yavdr1.diff.gz) = 5129
diff --git a/multimedia/vdr-plugin-control/files/patch-Makefile b/multimedia/vdr-plugin-control/files/patch-Makefile
new file mode 100644
index 000000000000..8bd4da587bb1
--- /dev/null
+++ b/multimedia/vdr-plugin-control/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -67,6 +67,11 @@ dist: clean
+ clean:
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
+
++APIVERSION = $(shell sed -ne '/define APIVERSION/s/^.*"\(.*\)".*$$/\1/p' $(VDRDIR)/config.h)
++
++install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
++
+ ### Implicit rules:
+
+ %.o: %.c
diff --git a/multimedia/vdr-plugin-control/files/patch-StringArray.c b/multimedia/vdr-plugin-control/files/patch-StringArray.c
new file mode 100644
index 000000000000..6fd5d56a1e42
--- /dev/null
+++ b/multimedia/vdr-plugin-control/files/patch-StringArray.c
@@ -0,0 +1,14 @@
+--- a/StringArray.c
++++ b/StringArray.c
+@@ -11,7 +11,11 @@
+ #endif // _GNU_SOURCE
+
+
++#ifdef __FreeBSD__
++#include <stdlib.h>
++#else
+ #include <malloc.h>
++#endif
+ #include <string.h>
+ #include <stdio.h>
+
diff --git a/multimedia/vdr-plugin-control/files/patch-control.c b/multimedia/vdr-plugin-control/files/patch-control.c
new file mode 100644
index 000000000000..386691c91eb2
--- /dev/null
+++ b/multimedia/vdr-plugin-control/files/patch-control.c
@@ -0,0 +1,10 @@
+--- a/control.c
++++ b/control.c
+@@ -69,6 +69,7 @@ cPluginControl::~cPluginControl()
+ // Clean up after yourself!
+ delete(_pReceivers);
+ delete(_pTerminal);
++ delete(glCtrlState);
+ }
+
+
diff --git a/multimedia/vdr-plugin-control/files/patch-stack.c b/multimedia/vdr-plugin-control/files/patch-stack.c
new file mode 100644
index 000000000000..662e56281747
--- /dev/null
+++ b/multimedia/vdr-plugin-control/files/patch-stack.c
@@ -0,0 +1,14 @@
+--- a/stack.c
++++ b/stack.c
+@@ -12,7 +12,11 @@
+
+
+
++#ifdef __FreeBSD__
++#include <stdlib.h>
++#else
+ #include <malloc.h>
++#endif
+ #include <string.h>
+ #include <sys/socket.h>
+
diff --git a/multimedia/vdr-plugin-control/files/patch-telnet.c b/multimedia/vdr-plugin-control/files/patch-telnet.c
new file mode 100644
index 000000000000..388224714293
--- /dev/null
+++ b/multimedia/vdr-plugin-control/files/patch-telnet.c
@@ -0,0 +1,14 @@
+--- a/telnet.c
++++ b/telnet.c
+@@ -12,7 +12,11 @@
+
+
+
++#ifdef __FreeBSD__
++#include <stdlib.h>
++#else
+ #include <malloc.h>
++#endif
+ #include <string.h>
+ //#include <sys/socket.h>
+
diff --git a/multimedia/vdr-plugin-control/pkg-descr b/multimedia/vdr-plugin-control/pkg-descr
new file mode 100644
index 000000000000..4a68c709b9e1
--- /dev/null
+++ b/multimedia/vdr-plugin-control/pkg-descr
@@ -0,0 +1,14 @@
+http://www.linuxtv.org/vdrwiki/index.php/Control-plugin
+
+The 'control' plugin brings the ability to VDR to control
+the whole OSD over a telnet client.
+
+To reach this, 'control' listens on a network socket
+(default is port 2002). If a client wants to connect, VDR
+checks if that client is allowed to connect to VDR (see in
+the documentation of VDR about the svdrphosts.conf file for
+more info). If the connection is etablished, 'control'
+sends the curent OSD state to the client. Also all key
+strokes at the client side are redirected to VDR.
+
+WWW: http://ricomp.de/vdr/down_en.html
diff --git a/multimedia/vdr-plugin-control/pkg-plist b/multimedia/vdr-plugin-control/pkg-plist
new file mode 100644
index 000000000000..0e78d2763d1d
--- /dev/null
+++ b/multimedia/vdr-plugin-control/pkg-plist
@@ -0,0 +1 @@
+lib/vdr/libvdr-control.so.1.7.17