aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-extrecmenu
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-06-19 18:02:20 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-06-19 18:02:20 +0000
commit575c57e1dca068bb46433d7898c2f7973a503f58 (patch)
treecf942712f9d7c5c1614736c251ad5e46bdd9c5e4 /multimedia/vdr-plugin-extrecmenu
parent3041887c3ef7f01dc8d2e51c3728779dbec5a6f1 (diff)
downloadports-575c57e1dca068bb46433d7898c2f7973a503f58.tar.gz
ports-575c57e1dca068bb46433d7898c2f7973a503f58.zip
The EXTended RECordings MENU plugin provides additional functions to VDR's
recordings menu: * renaming recordings and directories * moving recordings and directories, also between different filesystems * adjustable display of recording's length, date and size * directories are always shown on top of the list * reworked layout using icons for showing the status of list entries (directory, new recording, moving recording/directory, cutting recording, dvd archiv entry) * extended recordings info menu, shows name, path, channel, size, lifetime and priority of the recording * free disk space is shown for the filesystem of the current directory * sorting by name or date, adjustable for each directory; type of sorting will be stored * ascending/descending sorting * extends VDR's '-r'-option commands with 'move' and 'rename' * functionality of the DVDArchive-patch (see below) * protecting recordings in co-work with the PIN-plugin * a cutter queue WWW: http://projects.vdr-developer.org/projects/show/plg-extrecmenu
Notes
Notes: svn path=/head/; revision=299650
Diffstat (limited to 'multimedia/vdr-plugin-extrecmenu')
-rw-r--r--multimedia/vdr-plugin-extrecmenu/Makefile34
-rw-r--r--multimedia/vdr-plugin-extrecmenu/distinfo2
-rw-r--r--multimedia/vdr-plugin-extrecmenu/files/patch-Makefile21
-rw-r--r--multimedia/vdr-plugin-extrecmenu/files/patch-mymenurecordings.c14
-rw-r--r--multimedia/vdr-plugin-extrecmenu/pkg-descr22
-rw-r--r--multimedia/vdr-plugin-extrecmenu/pkg-plist23
6 files changed, 116 insertions, 0 deletions
diff --git a/multimedia/vdr-plugin-extrecmenu/Makefile b/multimedia/vdr-plugin-extrecmenu/Makefile
new file mode 100644
index 000000000000..aa84ff111d53
--- /dev/null
+++ b/multimedia/vdr-plugin-extrecmenu/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: vdr-plugin-extrecmenu
+# Date created: Mon Jun 4 18:08:53 CEST 2012
+# Whom: Juergen Lock <nox@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdr-plugin-extrecmenu
+PORTVERSION= 1.2.2
+CATEGORIES= multimedia
+MASTER_SITES= http://projects.vdr-developer.org/attachments/download/936/
+DISTNAME= vdr-${PLUGIN}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video Disk Recorder - extended recordings menu
+
+PATCH_STRIP= -p1
+HAVE_CONFIGURE= yes
+PORTDOCS= COPYING README HISTORY
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${PLUGIN}-${PORTVERSION}
+
+.include "${.CURDIR}/../vdr/Makefile.plugins"
+
+post-patch: post-patch-plugin
+
+post-install: post-install-pluginlocales
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-extrecmenu/distinfo b/multimedia/vdr-plugin-extrecmenu/distinfo
new file mode 100644
index 000000000000..9a8c91f475e6
--- /dev/null
+++ b/multimedia/vdr-plugin-extrecmenu/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vdr/vdr-extrecmenu-1.2.2.tgz) = ac920ee4c43497958ca158d2b81490208cd5caf92545ce809adb8a73f71dfe5e
+SIZE (vdr/vdr-extrecmenu-1.2.2.tgz) = 734012
diff --git a/multimedia/vdr-plugin-extrecmenu/files/patch-Makefile b/multimedia/vdr-plugin-extrecmenu/files/patch-Makefile
new file mode 100644
index 000000000000..8ed76494d5ef
--- /dev/null
+++ b/multimedia/vdr-plugin-extrecmenu/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -108,7 +108,11 @@ i18n: $(I18Nmsgs) $(I18Npot)
+
+ libvdr-$(PLUGIN).so: $(OBJS)
+ $(CXX) $(CXXFLAGS) -shared $(OBJS) -o $@
++ifdef FREEBSD
++ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
++else
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
++endif
+
+ dist: clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+@@ -120,3 +124,6 @@ dist: clean
+
+ clean:
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot
++
++install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
diff --git a/multimedia/vdr-plugin-extrecmenu/files/patch-mymenurecordings.c b/multimedia/vdr-plugin-extrecmenu/files/patch-mymenurecordings.c
new file mode 100644
index 000000000000..61c40d75373b
--- /dev/null
+++ b/multimedia/vdr-plugin-extrecmenu/files/patch-mymenurecordings.c
@@ -0,0 +1,14 @@
+--- a/mymenurecordings.c
++++ b/mymenurecordings.c
+@@ -1031,7 +1031,11 @@ eOSState myMenuRecordings::Play()
+ buffer=NULL;
+ }
+ golastreplayed=true;
++#if APIVERSNUM < 10728
+ myReplayControl::SetRecording(recording->FileName(),recording->Title());
++#else
++ myReplayControl::SetRecording(recording->FileName());
++#endif
+ cControl::Shutdown();
+ isyslog("[extrecmenu] starting replay of recording");
+ cControl::Launch(new myReplayControl());
diff --git a/multimedia/vdr-plugin-extrecmenu/pkg-descr b/multimedia/vdr-plugin-extrecmenu/pkg-descr
new file mode 100644
index 000000000000..447e117b242f
--- /dev/null
+++ b/multimedia/vdr-plugin-extrecmenu/pkg-descr
@@ -0,0 +1,22 @@
+The EXTended RECordings MENU plugin provides additional functions to VDR's
+recordings menu:
+
+* renaming recordings and directories
+* moving recordings and directories, also between different filesystems
+* adjustable display of recording's length, date and size
+* directories are always shown on top of the list
+* reworked layout using icons for showing the status of list entries
+ (directory, new recording, moving recording/directory, cutting recording,
+ dvd archiv entry)
+* extended recordings info menu, shows name, path, channel, size, lifetime and
+ priority of the recording
+* free disk space is shown for the filesystem of the current directory
+* sorting by name or date, adjustable for each directory; type of sorting will
+ be stored
+* ascending/descending sorting
+* extends VDR's '-r'-option commands with 'move' and 'rename'
+* functionality of the DVDArchive-patch (see below)
+* protecting recordings in co-work with the PIN-plugin
+* a cutter queue
+
+WWW: http://projects.vdr-developer.org/projects/show/plg-extrecmenu
diff --git a/multimedia/vdr-plugin-extrecmenu/pkg-plist b/multimedia/vdr-plugin-extrecmenu/pkg-plist
new file mode 100644
index 000000000000..c6b9c363b6f5
--- /dev/null
+++ b/multimedia/vdr-plugin-extrecmenu/pkg-plist
@@ -0,0 +1,23 @@
+lib/vdr/libvdr-extrecmenu.so.%%APIVERSION%%
+%%NLS%%share/locale/ca_ES/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/cs_CZ/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/da_DK/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/de_DE/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/el_GR/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/et_EE/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/hr_HR/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/hu_HU/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/nl_NL/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/nn_NO/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/pl_PL/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/ro_RO/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/sk_SK/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/sl_SI/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/sv_SE/LC_MESSAGES/vdr-extrecmenu.mo
+%%NLS%%share/locale/tr_TR/LC_MESSAGES/vdr-extrecmenu.mo