aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-infosatepg
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-03-01 12:21:13 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-03-01 12:21:13 +0000
commit47452dcb43fe706a104d820e5e33726758a0362a (patch)
tree5b514c92c45cfe80c1cae5cd74f5bbac9f011628 /multimedia/vdr-plugin-infosatepg
parent7a2c2ce6e780ec6a01f1de55c980810b9175edce (diff)
downloadports-47452dcb43fe706a104d820e5e33726758a0362a.tar.gz
ports-47452dcb43fe706a104d820e5e33726758a0362a.zip
Notes
Diffstat (limited to 'multimedia/vdr-plugin-infosatepg')
-rw-r--r--multimedia/vdr-plugin-infosatepg/Makefile12
-rw-r--r--multimedia/vdr-plugin-infosatepg/files/patch-Makefile2
2 files changed, 7 insertions, 7 deletions
diff --git a/multimedia/vdr-plugin-infosatepg/Makefile b/multimedia/vdr-plugin-infosatepg/Makefile
index f7bd39ecbf7b..3147b6bbfcf4 100644
--- a/multimedia/vdr-plugin-infosatepg/Makefile
+++ b/multimedia/vdr-plugin-infosatepg/Makefile
@@ -17,16 +17,16 @@ HAVE_CONFIGURE= yes
PORTDOCS= COPYING README HISTORY
WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION}
-NO_STAGE= yes
.include "${.CURDIR}/../vdr/Makefile.plugins"
post-patch: post-patch-plugin
+pre-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/vdr
+
post-install: post-install-pluginlocales
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
-.endif
- ${INSTALL} -o ${VDR_USER} -g ${VDR_GROUP} -d /var/cache/vdr/${PLUGIN}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+ ${MKDIR} ${STAGEDIR}/var/cache/vdr/${PLUGIN}
.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-infosatepg/files/patch-Makefile b/multimedia/vdr-plugin-infosatepg/files/patch-Makefile
index 442e90a98803..75f98bc8f2c5 100644
--- a/multimedia/vdr-plugin-infosatepg/files/patch-Makefile
+++ b/multimedia/vdr-plugin-infosatepg/files/patch-Makefile
@@ -18,4 +18,4 @@
@-rm -f $(OBJS) $(DEPFILE) *.so* *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot
+
+install:
-+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)