aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-osdteletext
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-03-26 19:19:18 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-03-26 19:19:18 +0000
commita4dcbee0781c27ccfc2b6c72652aa9dfe487047e (patch)
treee27dcc110cfceb3e6078defbbe14501458112829 /multimedia/vdr-plugin-osdteletext
parentc1b09324915817d3ee549b49945e5596b4cdf07a (diff)
downloadports-a4dcbee0781c27ccfc2b6c72652aa9dfe487047e.tar.gz
ports-a4dcbee0781c27ccfc2b6c72652aa9dfe487047e.zip
Osd-Teletext displays the teletext directly on VDR's OSD. Both sound and video are played in the background. WWW: http://projects.vdr-developer.org/projects/show/plg-osdteletext
Notes
Notes: svn path=/head/; revision=271804
Diffstat (limited to 'multimedia/vdr-plugin-osdteletext')
-rw-r--r--multimedia/vdr-plugin-osdteletext/Makefile36
-rw-r--r--multimedia/vdr-plugin-osdteletext/distinfo2
-rw-r--r--multimedia/vdr-plugin-osdteletext/files/patch-Makefile15
-rw-r--r--multimedia/vdr-plugin-osdteletext/files/patch-vdr-osdteletext-0.8.330
-rw-r--r--multimedia/vdr-plugin-osdteletext/pkg-descr6
-rw-r--r--multimedia/vdr-plugin-osdteletext/pkg-plist11
6 files changed, 100 insertions, 0 deletions
diff --git a/multimedia/vdr-plugin-osdteletext/Makefile b/multimedia/vdr-plugin-osdteletext/Makefile
new file mode 100644
index 000000000000..f74111db6b84
--- /dev/null
+++ b/multimedia/vdr-plugin-osdteletext/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: vdr-plugin-osdteletext
+# Date created: Wed Apr 14 18:11:42 CEST 2010
+# Whom: Juergen Lock <nox@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdr-plugin-osdteletext
+PORTVERSION= 0.9.0
+PORTREVISION= 5
+CATEGORIES= multimedia
+MASTER_SITES= http://projects.vdr-developer.org/attachments/download/416/
+DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video Disk Recorder - OSD teletext plugin
+
+PATCH_STRIP= -p1
+HAVE_CONFIGURE= yes
+PORTDOCS= COPYING README
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION}
+
+.include "${.CURDIR}/../vdr/Makefile.plugins"
+
+post-patch: post-patch-plugin
+
+post-install: post-install-pluginlocales
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+.endif
+ ${INSTALL} -o ${VDR_USER} -g ${VDR_GROUP} -d /var/cache/vdr/vtx
+
+.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-osdteletext/distinfo b/multimedia/vdr-plugin-osdteletext/distinfo
new file mode 100644
index 000000000000..a9f0571cb36a
--- /dev/null
+++ b/multimedia/vdr-plugin-osdteletext/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vdr/vdr-osdteletext-0.9.0.tgz) = 6ae02a6918e8eababf49a9388a89740d1d56f3f63d2bcc99b4dc7c8108035240
+SIZE (vdr/vdr-osdteletext-0.9.0.tgz) = 60498
diff --git a/multimedia/vdr-plugin-osdteletext/files/patch-Makefile b/multimedia/vdr-plugin-osdteletext/files/patch-Makefile
new file mode 100644
index 000000000000..cf8be7f4f332
--- /dev/null
+++ b/multimedia/vdr-plugin-osdteletext/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- osdteletext-0.8.3/Makefile.orig
++++ osdteletext-0.8.3/Makefile
+@@ -110,8 +114,11 @@ dist: clean
+
+ clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+- @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
+
+ install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
++ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
++
++install-readme:
+ @install -d ../../man
+ @install README ../../man/$(PLUGIN).man
diff --git a/multimedia/vdr-plugin-osdteletext/files/patch-vdr-osdteletext-0.8.3 b/multimedia/vdr-plugin-osdteletext/files/patch-vdr-osdteletext-0.8.3
new file mode 100644
index 000000000000..2ca093201bf4
--- /dev/null
+++ b/multimedia/vdr-plugin-osdteletext/files/patch-vdr-osdteletext-0.8.3
@@ -0,0 +1,30 @@
+diff -ur orig/osdteletext-0.8.3/Makefile osdteletext-0.8.3/Makefile
+--- orig/osdteletext-0.8.3/Makefile 2009-05-25 20:28:59.000000000 +0200
++++ osdteletext-0.8.3/Makefile 2010-03-16 17:31:20.000000000 +0100
+@@ -94,7 +94,11 @@
+
+ libvdr-$(PLUGIN).so: $(OBJS)
+ $(CXX) $(CXXFLAGS) -shared $(OBJS) -o $@
++ifdef FREEBSD
++ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
++else
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
++endif
+
+ dist: clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+diff -ur orig/osdteletext-0.8.3/txtrecv.c osdteletext-0.8.3/txtrecv.c
+--- orig/osdteletext-0.8.3/txtrecv.c 2009-05-25 20:28:59.000000000 +0200
++++ osdteletext-0.8.3/txtrecv.c 2010-03-16 17:29:53.000000000 +0100
+@@ -22,7 +22,11 @@
+ #include <pthread.h>
+ #include <signal.h>
+ #include <errno.h>
++#ifdef __FreeBSD__
++#include <sys/mount.h>
++#else
+ #include <sys/vfs.h>
++#endif
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/multimedia/vdr-plugin-osdteletext/pkg-descr b/multimedia/vdr-plugin-osdteletext/pkg-descr
new file mode 100644
index 000000000000..5499f356cda4
--- /dev/null
+++ b/multimedia/vdr-plugin-osdteletext/pkg-descr
@@ -0,0 +1,6 @@
+http://www.linuxtv.org/vdrwiki/index.php/Osdteletext-plugin
+
+Osd-Teletext displays the teletext directly on VDR's OSD.
+Both sound and video are played in the background.
+
+WWW: http://projects.vdr-developer.org/projects/show/plg-osdteletext
diff --git a/multimedia/vdr-plugin-osdteletext/pkg-plist b/multimedia/vdr-plugin-osdteletext/pkg-plist
new file mode 100644
index 000000000000..433ebd923320
--- /dev/null
+++ b/multimedia/vdr-plugin-osdteletext/pkg-plist
@@ -0,0 +1,11 @@
+lib/vdr/libvdr-osdteletext.so.1.7.17
+@exec /usr/bin/install -o %%VDR_USER%% -g %%VDR_GROUP%% -d /var/cache/vdr/vtx
+%%NLS%%share/locale/ca_ES/LC_MESSAGES/vdr-osdteletext.mo
+%%NLS%%share/locale/de_DE/LC_MESSAGES/vdr-osdteletext.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/vdr-osdteletext.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/vdr-osdteletext.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/vdr-osdteletext.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/vdr-osdteletext.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/vdr-osdteletext.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/vdr-osdteletext.mo
+%%NLS%%share/locale/uk_UA/LC_MESSAGES/vdr-osdteletext.mo