aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-reelchannelscan
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-05-11 20:15:16 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-05-11 20:15:16 +0000
commitac9fa58473cd407f14fae4be64d330ae20e7ee4a (patch)
treeb6734398db894dca1765e046682d191409e004e7 /multimedia/vdr-plugin-reelchannelscan
parent173c3958a94fd8bcdc793ffd8c11126510723c9f (diff)
downloadports-ac9fa58473cd407f14fae4be64d330ae20e7ee4a.tar.gz
ports-ac9fa58473cd407f14fae4be64d330ae20e7ee4a.zip
- Fix crashes and wrong channels.conf entries caused by wrong/missing
DVB-S(2) sources in some cases. - Only limit DVB-S(2) sources to what's in diseqc.conf if vdr is configured to actually use it. - Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=273980
Diffstat (limited to 'multimedia/vdr-plugin-reelchannelscan')
-rw-r--r--multimedia/vdr-plugin-reelchannelscan/Makefile2
-rw-r--r--multimedia/vdr-plugin-reelchannelscan/files/patch-csmenu.c35
2 files changed, 36 insertions, 1 deletions
diff --git a/multimedia/vdr-plugin-reelchannelscan/Makefile b/multimedia/vdr-plugin-reelchannelscan/Makefile
index a51641fd11d9..6f1ba58d5249 100644
--- a/multimedia/vdr-plugin-reelchannelscan/Makefile
+++ b/multimedia/vdr-plugin-reelchannelscan/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vdr-plugin-reelchannelscan
PORTVERSION= 0.6.1b1.7.15
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= LOCAL/nox \
http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu/pool/main/v/vdr-plugin-reelchannelscan/
diff --git a/multimedia/vdr-plugin-reelchannelscan/files/patch-csmenu.c b/multimedia/vdr-plugin-reelchannelscan/files/patch-csmenu.c
new file mode 100644
index 000000000000..5a1f4208b3de
--- /dev/null
+++ b/multimedia/vdr-plugin-reelchannelscan/files/patch-csmenu.c
@@ -0,0 +1,35 @@
+--- a/csmenu.c
++++ b/csmenu.c
+@@ -378,8 +378,12 @@ void cMenuChannelscan::Set()
+
+ // avoid C/T-positions for SAT
+ // and take Astra as start position
+- if (srcTypes[currentTuner] >= SAT && (source == cSource::FromString("C") || source == cSource::FromString("T"))) {
+- source = cSource::FromString("S19.2E");
++ if (srcTypes[currentTuner] >= SAT && (source == cSource::FromString("C") || source == cSource::FromString("T") || !Sources.Get(source))) {
++ cDiseqc *d = Diseqcs.First();
++ if (Setup.DiSEqC > 0 && d)
++ source = d->Source();
++ else
++ source = cSource::FromString("S19.2E");
+ }
+
+ Add(new cMenuEditStraItem(tr("Search Mode"), &scanMode, 2, searchTexts));
+@@ -1209,7 +1213,7 @@ eOSState cMyMenuEditSrcItem::ProcessKey(
+ {
+ if (NORMALKEY(Key) == kLeft) // TODO might want to increase the delta if repeated quickly?
+ {
+- if(cSource::IsSat(source->Code()) && !cPluginManager::GetPlugin("mcli")) {
++ if(cSource::IsSat(source->Code()) && !cPluginManager::GetPlugin("mcli") && Setup.DiSEqC > 0) {
+ source = oldSrc;
+ while(!found && source && (source->Code() & cSource::stSat)) {
+ for (cDiseqc *p = Diseqcs.First(); p && !found; p = Diseqcs.Next(p)) {
+@@ -1231,7 +1235,7 @@ eOSState cMyMenuEditSrcItem::ProcessKey(
+ }
+ }
+ } else if (NORMALKEY(Key) == kRight) {
+- if (cSource::IsSat(source->Code()) && !cPluginManager::GetPlugin("mcli")) {
++ if (cSource::IsSat(source->Code()) && !cPluginManager::GetPlugin("mcli") && Setup.DiSEqC > 0) {
+ source = oldSrc;
+ while(!found && source && (source->Code() & cSource::stSat)) {
+ for (cDiseqc *p = Diseqcs.First(); p && !found; p = Diseqcs.Next(p)) {