aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-sleeptimer
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-06-19 18:42:12 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-06-19 18:42:12 +0000
commit06a1a754bf11f8d8bd5f7a48aaca173bf6cef618 (patch)
treec52fc6c0fdf6d98bbdbfaa0ad6db66308f0a2d76 /multimedia/vdr-plugin-sleeptimer
parentd95ff34009ff04c9b302834a93a37e7ff36b1f8e (diff)
downloadports-06a1a754bf11f8d8bd5f7a48aaca173bf6cef618.tar.gz
ports-06a1a754bf11f8d8bd5f7a48aaca173bf6cef618.zip
- Update multimedia/vdr and multimedia/vdr-plugins to 1.7.28 .
- Update xineliboutput XKeySym.Pause key in example remote.conf. ("space" instead of "Space") - Add multimedia/vdr-plugin-extrecmenu 1.2.2 to vdr-plugins metaport. - Update multimedia/vdr-plugin-skinenigmang to 0.1.2s20120606 git snapshot. - Update www/vdr-plugin-live to 0.2.0s20120325 git snapshot. - Bump PORTREVISION for all other plugins and add api fixes where necessary. - Add HISTORY to PORTDOCS for most plugins. (those that have it) - Remove shlib major versions from LIB_DEPENDS to pet portlint.
Notes
Notes: svn path=/head/; revision=299655
Diffstat (limited to 'multimedia/vdr-plugin-sleeptimer')
-rw-r--r--multimedia/vdr-plugin-sleeptimer/Makefile4
-rw-r--r--multimedia/vdr-plugin-sleeptimer/files/patch-Makefile9
-rw-r--r--multimedia/vdr-plugin-sleeptimer/files/patch-i18.c14
3 files changed, 16 insertions, 11 deletions
diff --git a/multimedia/vdr-plugin-sleeptimer/Makefile b/multimedia/vdr-plugin-sleeptimer/Makefile
index ddcdc887f176..092210066260 100644
--- a/multimedia/vdr-plugin-sleeptimer/Makefile
+++ b/multimedia/vdr-plugin-sleeptimer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vdr-plugin-sleeptimer
PORTVERSION= 0.8.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= http://projects.vdr-developer.org/attachments/download/652/
EXTRACT_SUFX= .tgz
@@ -17,7 +17,7 @@ COMMENT= Video Disk Recorder - sleep timer plugin
PATCH_STRIP= -p1
HAVE_CONFIGURE= yes
-PORTDOCS= COPYING README
+PORTDOCS= COPYING README HISTORY
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PLUGIN}-${PORTVERSION}
diff --git a/multimedia/vdr-plugin-sleeptimer/files/patch-Makefile b/multimedia/vdr-plugin-sleeptimer/files/patch-Makefile
index a14f1df9789b..3a230caa2e85 100644
--- a/multimedia/vdr-plugin-sleeptimer/files/patch-Makefile
+++ b/multimedia/vdr-plugin-sleeptimer/files/patch-Makefile
@@ -1,14 +1,5 @@
--- a/Makefile
+++ b/Makefile
-@@ -50,7 +50,7 @@ DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I
-
- ### The object files (add further files here):
-
--OBJS = $(PLUGIN).o i18n.o
-+OBJS = $(PLUGIN).o
-
- ### Implicit rules:
-
@@ -110,3 +110,6 @@ dist: clean
clean:
@-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
diff --git a/multimedia/vdr-plugin-sleeptimer/files/patch-i18.c b/multimedia/vdr-plugin-sleeptimer/files/patch-i18.c
new file mode 100644
index 000000000000..1a759fb42398
--- /dev/null
+++ b/multimedia/vdr-plugin-sleeptimer/files/patch-i18.c
@@ -0,0 +1,14 @@
+--- a/i18n.c
++++ b/i18n.c
+@@ -6,9 +6,10 @@
+ * $Id: i18n.c 1.3 2002/06/23 13:05:59 kls Exp $
+ */
+
+-#include "i18n.h"
++#include <vdr/config.h>
+
+ #if VDRVERSNUM < 10507
++#include "i18n.h"
+
+ const tI18nPhrase Phrases[] = {
+ { "Not active",// English