aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-sleeptimer
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-08-05 20:16:27 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-08-05 20:16:27 +0000
commitf0c3d0386b65bd03c62b9177884a4dc211da3e1b (patch)
tree558620add2256b80e620d6c34a740a09cae2489b /multimedia/vdr-plugin-sleeptimer
parentffb8f0807f47e1d5f465cbca1a6046220cf7cd25 (diff)
downloadports-f0c3d0386b65bd03c62b9177884a4dc211da3e1b.tar.gz
ports-f0c3d0386b65bd03c62b9177884a4dc211da3e1b.zip
Shutdown vdr, mute or execute a custom command after a configurable timespan. User keys and keymacros.conf are supported. WWW: http://projects.vdr-developer.org/projects/plg-sleeptimer
Notes
Notes: svn path=/head/; revision=278975
Diffstat (limited to 'multimedia/vdr-plugin-sleeptimer')
-rw-r--r--multimedia/vdr-plugin-sleeptimer/Makefile33
-rw-r--r--multimedia/vdr-plugin-sleeptimer/distinfo2
-rw-r--r--multimedia/vdr-plugin-sleeptimer/files/patch-Makefile9
-rw-r--r--multimedia/vdr-plugin-sleeptimer/pkg-descr6
-rw-r--r--multimedia/vdr-plugin-sleeptimer/pkg-plist22
5 files changed, 72 insertions, 0 deletions
diff --git a/multimedia/vdr-plugin-sleeptimer/Makefile b/multimedia/vdr-plugin-sleeptimer/Makefile
new file mode 100644
index 000000000000..0e3dc27fce14
--- /dev/null
+++ b/multimedia/vdr-plugin-sleeptimer/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: vdr-plugin-sleeptimer
+# Date created: Fri Jul 22 21:45:54 CEST 2011
+# Whom: Juergen Lock <nox@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdr-plugin-sleeptimer
+PORTVERSION= 0.8.2
+CATEGORIES= multimedia
+MASTER_SITES= http://projects.vdr-developer.org/attachments/download/652/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video Disk Recorder - sleep timer plugin
+
+PATCH_STRIP= -p1
+HAVE_CONFIGURE= yes
+PORTDOCS= COPYING README
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${PLUGIN}-${PORTVERSION}
+
+.include "${.CURDIR}/../vdr/Makefile.plugins"
+
+post-patch: post-patch-plugin
+
+post-install: post-install-pluginlocales
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-sleeptimer/distinfo b/multimedia/vdr-plugin-sleeptimer/distinfo
new file mode 100644
index 000000000000..62b1707b9bee
--- /dev/null
+++ b/multimedia/vdr-plugin-sleeptimer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vdr/vdr-plugin-sleeptimer-0.8.2.tgz) = 81e924bc0ea3587238cf2b090713076320aa3b8f5417561691e2a6ba543ff28c
+SIZE (vdr/vdr-plugin-sleeptimer-0.8.2.tgz) = 22483
diff --git a/multimedia/vdr-plugin-sleeptimer/files/patch-Makefile b/multimedia/vdr-plugin-sleeptimer/files/patch-Makefile
new file mode 100644
index 000000000000..3a230caa2e85
--- /dev/null
+++ b/multimedia/vdr-plugin-sleeptimer/files/patch-Makefile
@@ -0,0 +1,9 @@
+--- a/Makefile
++++ b/Makefile
+@@ -110,3 +110,6 @@ dist: clean
+ clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
++
++install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
diff --git a/multimedia/vdr-plugin-sleeptimer/pkg-descr b/multimedia/vdr-plugin-sleeptimer/pkg-descr
new file mode 100644
index 000000000000..526205cc0f04
--- /dev/null
+++ b/multimedia/vdr-plugin-sleeptimer/pkg-descr
@@ -0,0 +1,6 @@
+http://www.linuxtv.org/vdrwiki/index.php/Sleeptimer-plugin
+
+Shutdown vdr, mute or execute a custom command after a configurable
+timespan. User keys and keymacros.conf are supported.
+
+WWW: http://projects.vdr-developer.org/projects/plg-sleeptimer
diff --git a/multimedia/vdr-plugin-sleeptimer/pkg-plist b/multimedia/vdr-plugin-sleeptimer/pkg-plist
new file mode 100644
index 000000000000..c394f4e57c32
--- /dev/null
+++ b/multimedia/vdr-plugin-sleeptimer/pkg-plist
@@ -0,0 +1,22 @@
+lib/vdr/libvdr-sleeptimer.so.1.7.19
+%%NLS%%share/locale/ca_ES/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/cs_CZ/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/da_DK/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/de_DE/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/el_GR/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/et_EE/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/hr_HR/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/hu_HU/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/nl_NL/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/nn_NO/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/pl_PL/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/ro_RO/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/sl_SI/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/sv_SE/LC_MESSAGES/vdr-sleeptimer.mo
+%%NLS%%share/locale/tr_TR/LC_MESSAGES/vdr-sleeptimer.mo