aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-softdevice
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-04-21 14:10:58 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-04-21 14:10:58 +0000
commit21694da2c566eaa9c10c6ef28211ff5dcc64fc0b (patch)
treeaddbbf4b5bdb1599aaa2de3e5468c3e5086cf6ac /multimedia/vdr-plugin-softdevice
parent81c24ded0d6dc41a98692d88f643711724fd25c1 (diff)
downloadports-21694da2c566eaa9c10c6ef28211ff5dcc64fc0b.tar.gz
ports-21694da2c566eaa9c10c6ef28211ff5dcc64fc0b.zip
Notes
Diffstat (limited to 'multimedia/vdr-plugin-softdevice')
-rw-r--r--multimedia/vdr-plugin-softdevice/Makefile2
-rw-r--r--multimedia/vdr-plugin-softdevice/files/patch-Makefile9
-rw-r--r--multimedia/vdr-plugin-softdevice/files/patch-i18n.h13
-rw-r--r--multimedia/vdr-plugin-softdevice/files/patch-softdevice.c12
-rw-r--r--multimedia/vdr-plugin-softdevice/pkg-plist6
5 files changed, 38 insertions, 4 deletions
diff --git a/multimedia/vdr-plugin-softdevice/Makefile b/multimedia/vdr-plugin-softdevice/Makefile
index b30824012fa8..523da6dca425 100644
--- a/multimedia/vdr-plugin-softdevice/Makefile
+++ b/multimedia/vdr-plugin-softdevice/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vdr-plugin-softdevice
PORTVERSION= 0.5.0p20100414
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= multimedia
MASTER_SITES= LOCAL
MASTER_SITE_SUBDIR= nox/
diff --git a/multimedia/vdr-plugin-softdevice/files/patch-Makefile b/multimedia/vdr-plugin-softdevice/files/patch-Makefile
index 757f5db4c5cf..f36147d1d06b 100644
--- a/multimedia/vdr-plugin-softdevice/files/patch-Makefile
+++ b/multimedia/vdr-plugin-softdevice/files/patch-Makefile
@@ -1,5 +1,14 @@
--- Makefile.orig
+++ Makefile
+@@ -233,7 +238,7 @@ DEFINES += -DPLUGINLIBDIR='"$(PLUGINLIBD
+
+ TARGETS = libvdr-$(PLUGIN).so
+ LIBS = $(FFMPEGLIBS)
+-OBJS = $(PLUGIN).o utils.o i18n.o video.o mpeg2decoder.o \
++OBJS = $(PLUGIN).o utils.o video.o mpeg2decoder.o \
+ audio.o video-dummy.o \
+ setup-softdevice.o setup-softdevice-menu.o \
+ setup-softlog.o setup-softlog-menu.o\
@@ -438,3 +438,9 @@ MacVdrClient_obj = video_shm.o video-qua
MacVdrClient: $(MacVdrClient_obj)
$(CXX) $(LDFLAGS) $(MacVdrClient_obj) -framework Carbon -framework AGL -framework OpenGL -lpthread -o $@
diff --git a/multimedia/vdr-plugin-softdevice/files/patch-i18n.h b/multimedia/vdr-plugin-softdevice/files/patch-i18n.h
new file mode 100644
index 000000000000..8f69bd32edde
--- /dev/null
+++ b/multimedia/vdr-plugin-softdevice/files/patch-i18n.h
@@ -0,0 +1,13 @@
+--- i18n.h.orig
++++ i18n.h
+@@ -9,8 +9,10 @@
+ #ifndef _I18N__H
+ #define _I18N__H
+
++#if (APIVERSNUM < 10507)
+ #include <vdr/i18n.h>
+
+ extern const tI18nPhrase Phrases[];
++#endif
+
+ #endif //_I18N__H
diff --git a/multimedia/vdr-plugin-softdevice/files/patch-softdevice.c b/multimedia/vdr-plugin-softdevice/files/patch-softdevice.c
new file mode 100644
index 000000000000..4fb9aad3f585
--- /dev/null
+++ b/multimedia/vdr-plugin-softdevice/files/patch-softdevice.c
@@ -0,0 +1,12 @@
+--- softdevice.c.orig
++++ softdevice.c
+@@ -1254,7 +1254,9 @@ bool cPluginSoftDevice::Service(const ch
+ bool cPluginSoftDevice::Start(void)
+ {
+ // Start any background activities the plugin shall perform.
++#if (APIVERSNUM < 10507)
+ RegisterI18n(Phrases);
++#endif
+ return true;
+ }
+
diff --git a/multimedia/vdr-plugin-softdevice/pkg-plist b/multimedia/vdr-plugin-softdevice/pkg-plist
index 9c087e25bfe6..573b90fb2f76 100644
--- a/multimedia/vdr-plugin-softdevice/pkg-plist
+++ b/multimedia/vdr-plugin-softdevice/pkg-plist
@@ -1,7 +1,7 @@
bin/ShmClient
-lib/vdr/libvdr-softdevice.so.1.7.22
-lib/vdr/libsoftdevice-xv.so.1.7.22
-lib/vdr/libsoftdevice-shm.so.1.7.22
+lib/vdr/libvdr-softdevice.so.%%APIVERSION%%
+lib/vdr/libsoftdevice-xv.so.%%APIVERSION%%
+lib/vdr/libsoftdevice-shm.so.%%APIVERSION%%
%%NLS%%share/locale/ca_ES/LC_MESSAGES/vdr-softdevice.mo
%%NLS%%share/locale/cs_CZ/LC_MESSAGES/vdr-softdevice.mo
%%NLS%%share/locale/da_DK/LC_MESSAGES/vdr-softdevice.mo