aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-streamdev
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-05-17 18:57:17 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-05-17 18:57:17 +0000
commit00c4181b3ecc512d6668a128a4510d259aa0f1d5 (patch)
treeafa6eadc4a4f7cd5a3c62b99f18bc77a64c2d3e4 /multimedia/vdr-plugin-streamdev
parent301598e7bd450b793ba02cf3bf932e96860ac966 (diff)
downloadports-00c4181b3ecc512d6668a128a4510d259aa0f1d5.tar.gz
ports-00c4181b3ecc512d6668a128a4510d259aa0f1d5.zip
Update to 0.5.2 .
Notes
Notes: svn path=/head/; revision=296854
Diffstat (limited to 'multimedia/vdr-plugin-streamdev')
-rw-r--r--multimedia/vdr-plugin-streamdev/Makefile10
-rw-r--r--multimedia/vdr-plugin-streamdev/distinfo4
-rw-r--r--multimedia/vdr-plugin-streamdev/files/patch-server-recplayer.c4
3 files changed, 9 insertions, 9 deletions
diff --git a/multimedia/vdr-plugin-streamdev/Makefile b/multimedia/vdr-plugin-streamdev/Makefile
index 7933ca7117b6..264e4a85b485 100644
--- a/multimedia/vdr-plugin-streamdev/Makefile
+++ b/multimedia/vdr-plugin-streamdev/Makefile
@@ -6,23 +6,23 @@
#
PORTNAME= vdr-plugin-streamdev
-PORTVERSION= 0.5.1p20120311
+PORTVERSION= 0.5.2
CATEGORIES= multimedia
-MASTER_SITES= http://projects.vdr-developer.org/attachments/download/497/:release \
+MASTER_SITES= http://projects.vdr-developer.org/attachments/download/953/:release \
LOCAL:snapshot
MASTER_SITE_SUBDIR= nox/:snapshot
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
+DISTFILES= ${DISTNAME:S/plugin-//}${EXTRACT_SUFX}:release
+EXTRACT_SUFX= .tgz
MAINTAINER= nox@FreeBSD.org
COMMENT= Video Disk Recorder - stream device plugin
RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-USE_BZIP2= yes
PORTDOCS= COPYING README
HAVE_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PLUGIN}-${PORTVERSION}
VDR_PLUGIN_MAKEFILES= ${WRKSRC}/client/Makefile \
${WRKSRC}/server/Makefile
diff --git a/multimedia/vdr-plugin-streamdev/distinfo b/multimedia/vdr-plugin-streamdev/distinfo
index a13c8b7292a9..395870fc0a69 100644
--- a/multimedia/vdr-plugin-streamdev/distinfo
+++ b/multimedia/vdr-plugin-streamdev/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vdr/vdr-plugin-streamdev-0.5.1p20120311.tar.bz2) = 519bc2295b7e17504c25beadc4715853bdc095d1e112b0416e74bd083d895122
-SIZE (vdr/vdr-plugin-streamdev-0.5.1p20120311.tar.bz2) = 148996
+SHA256 (vdr/vdr-streamdev-0.5.2.tgz) = 554d71f251a1f0be94c6883a5df52340eaa728758271a0f0a486fee90620f2dd
+SIZE (vdr/vdr-streamdev-0.5.2.tgz) = 182629
diff --git a/multimedia/vdr-plugin-streamdev/files/patch-server-recplayer.c b/multimedia/vdr-plugin-streamdev/files/patch-server-recplayer.c
index 2096711a9aec..4dabd813f32e 100644
--- a/multimedia/vdr-plugin-streamdev/files/patch-server-recplayer.c
+++ b/multimedia/vdr-plugin-streamdev/files/patch-server-recplayer.c
@@ -1,12 +1,12 @@
--- server/recplayer.c.orig
+++ server/recplayer.c
-@@ -196,8 +196,10 @@ unsigned long RecPlayer::getBlock(unsign
+@@ -199,8 +199,10 @@ unsigned long RecPlayer::getBlock(unsign
fseek(file, filePosition, SEEK_SET);
if (fread(&buffer[got], getFromThisSegment, 1, file) != 1) return 0; // umm, big problem.
+#ifdef __linux__
// Tell linux not to bother keeping the data in the FS cache
- posix_fadvise(file->_fileno, filePosition, getFromThisSegment, POSIX_FADV_DONTNEED);
+ posix_fadvise(fileno(file), filePosition, getFromThisSegment, POSIX_FADV_DONTNEED);
+#endif
got += getFromThisSegment;