aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-vdrmanager
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-03-01 12:21:13 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-03-01 12:21:13 +0000
commit47452dcb43fe706a104d820e5e33726758a0362a (patch)
tree5b514c92c45cfe80c1cae5cd74f5bbac9f011628 /multimedia/vdr-plugin-vdrmanager
parent7a2c2ce6e780ec6a01f1de55c980810b9175edce (diff)
downloadports-47452dcb43fe706a104d820e5e33726758a0362a.tar.gz
ports-47452dcb43fe706a104d820e5e33726758a0362a.zip
- Finally stagify the vdr ports. \o/
- Use new LIB_DEPENDS syntax. - Change multimedia/vdr-plugins defaults and bump PORTREVISION for it. (switch from xvdr to vnsiserver and disable plugins depending on ffmpeg0)
Notes
Notes: svn path=/head/; revision=346615
Diffstat (limited to 'multimedia/vdr-plugin-vdrmanager')
-rw-r--r--multimedia/vdr-plugin-vdrmanager/Makefile15
-rw-r--r--multimedia/vdr-plugin-vdrmanager/files/patch-Makefile2
2 files changed, 9 insertions, 8 deletions
diff --git a/multimedia/vdr-plugin-vdrmanager/Makefile b/multimedia/vdr-plugin-vdrmanager/Makefile
index 59ae60b65ead..79dbbc4133ce 100644
--- a/multimedia/vdr-plugin-vdrmanager/Makefile
+++ b/multimedia/vdr-plugin-vdrmanager/Makefile
@@ -14,17 +14,18 @@ COMMENT= Video Disk Recorder - VDR-Manager server plugin
PATCH_STRIP= -p1
PORTDOCS= COPYING README HISTORY
-NO_STAGE= yes
.include "${.CURDIR}/../vdr/Makefile.plugins"
post-patch: post-patch-plugin
+pre-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/vdr
+
post-install:
- @${MKDIR} ${PREFIX}/etc/vdr/plugins
- @${INSTALL_DATA} ${WRKSRC}/examples/plugin.vdrmanager.conf ${PREFIX}/etc/vdr/plugins/plugin.vdrmanager.conf.sample
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
-.endif
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/vdr/plugins
+ @${INSTALL_DATA} ${WRKSRC}/examples/plugin.vdrmanager.conf \
+ ${STAGEDIR}${PREFIX}/etc/vdr/plugins/plugin.vdrmanager.conf.sample
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-vdrmanager/files/patch-Makefile b/multimedia/vdr-plugin-vdrmanager/files/patch-Makefile
index c1c4550ecc81..0eac21c279ab 100644
--- a/multimedia/vdr-plugin-vdrmanager/files/patch-Makefile
+++ b/multimedia/vdr-plugin-vdrmanager/files/patch-Makefile
@@ -6,4 +6,4 @@
@-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
+
+install:
-+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)